summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-22 13:58:04 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-22 14:03:25 -0500
commitea27b89e74e08b5a96d9ecf9b8e70d5406a4e591 (patch)
treea800f989b6bd7d7930f74612802d1f886bdbcb0d
parentapp-admin/puppet: 6.19.1 bump (diff)
downloadgentoo-ea27b89e74e08b5a96d9ecf9b8e70d5406a4e591.tar.gz
gentoo-ea27b89e74e08b5a96d9ecf9b8e70d5406a4e591.tar.bz2
gentoo-ea27b89e74e08b5a96d9ecf9b8e70d5406a4e591.zip
app-admin/puppet-agent: 6.19.1 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/puppet-agent/Manifest1
-rw-r--r--app-admin/puppet-agent/puppet-agent-6.19.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 63a890981a0c..fa6ad88fdc02 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -1,3 +1,4 @@
DIST puppet-agent_6.15.0-1stretch_amd64.deb 22581842 BLAKE2B 19c45427e56a41f6030836129a7fb2824ea47f1000745a8c74b0968c61f719d3cef9a0e02f51009b8e91c4ad66445c074ccc203754bb13d82007316a3d053c60 SHA512 4ec7e04fb6bab697bfccd369740a57f735476a4614dbfa1f7c893901f5ffb9d6ce3d79886b6e035805b1a8f2c3de3e0b9b468b08909881df6022c9700c7a2768
DIST puppet-agent_6.15.0-1stretch_i386.deb 22917002 BLAKE2B 5bab2b6cdde11a46e64996074e8db50d48d004b601c0d08ddfde9c8dec0c0f62da1176b9148d084f0250b582460606b7cd0a97291d157a186b7a97dee4184c51 SHA512 89e676491f7b7b44c9c747b129166db7b025adf76d9911d12d7d026aa8d04de293d3d1c638ca309ee8ed45a37c49b4ab0076ea0c711ac0e43f4297084446784f
DIST puppet-agent_6.18.0-1focal_amd64.deb 22258752 BLAKE2B 547d06b16b2c95ec9be72bd82e1aa0a4a4b511075da73f29ebecdef32ca4ed9b965a38a7c071d9bcc8c444b6974159df97f020878c0e4a20d1f50ff23d4c1129 SHA512 00f0cfd96176f5311f0bab14016ab88da03ecc10fd9e2bf28fc2d9a399600c56a97e23095694be5382005fef0df1c4fe3ff0d1aec3a46d85f74c729a3c62476a
+DIST puppet-agent_6.19.1-1focal_amd64.deb 22221600 BLAKE2B 22b03ef1f86b34955e8bad7c63a2022d2832dadd554316baf75419d6543e8a569902fb92a81a3dcc817401f06aa7dd47143a6cbd383f0e531c465cd3203dc4ed SHA512 4819a3509066516b0be76bc0f2afe94611405f7ac52fe50890d57c86a8a9c6c70787d46cb4b77085666f3e74bcb83a11acf1fef5d1e6ed3151ea06cbb8df3170
diff --git a/app-admin/puppet-agent/puppet-agent-6.19.1.ebuild b/app-admin/puppet-agent/puppet-agent-6.19.1.ebuild
new file mode 100644
index 000000000000..d2a6b4ff967b
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-6.19.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils systemd unpacker
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet"
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym ../../../../usr/lib64/xcrypt/libcrypt.so.1 /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}