summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-03-22 10:24:17 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-03-22 10:25:25 -0500
commitecce4c9a716054dfdee2e5cc938d1b0dff1a4669 (patch)
tree6dd9f1dc8e497515caed290572b6c561da7efcee
parentapp-emulation/diskimage-builder: 2.12.1 bup and cleanup (diff)
downloadgentoo-ecce4c9a716054dfdee2e5cc938d1b0dff1a4669.tar.gz
gentoo-ecce4c9a716054dfdee2e5cc938d1b0dff1a4669.tar.bz2
gentoo-ecce4c9a716054dfdee2e5cc938d1b0dff1a4669.zip
net-analyzer/icinga2: 2.8.2 bup
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--net-analyzer/icinga2/Manifest1
-rw-r--r--net-analyzer/icinga2/icinga2-2.8.2.ebuild176
2 files changed, 177 insertions, 0 deletions
diff --git a/net-analyzer/icinga2/Manifest b/net-analyzer/icinga2/Manifest
index b71de2bd5a19..0b6e9f882e74 100644
--- a/net-analyzer/icinga2/Manifest
+++ b/net-analyzer/icinga2/Manifest
@@ -1 +1,2 @@
DIST icinga2-2.8.1.tar.gz 2501182 BLAKE2B a32e60f8888d43eacedaee3cb33b719e2e405a6123710f7806b6c82eccb80eeb0ab0318a34302a5f3b310b258702214148f34719f166b3a3807ef2c9d4b28fa0 SHA512 27dcd2de1a9fa81327fa9cf25f25171e471715b4506dfd312bcd6c10408520cef86d260762f4340a00aaa7824c8ab65baadf541b7e104bd378204667dc92f762
+DIST icinga2-2.8.2.tar.gz 2507304 BLAKE2B 0f2cc58fff6d9f648b302c3af07e24fcf20e0c10c140d4052991477e1dbf5c158157f0c64e8d3aa26a6fadc46db25eb26d7b5d5c791a8a7d91445be10f0cecea SHA512 55a9791fa14d0e3e559b3083ec83ad301b62a677a1b56ad30227b1a3591612e2fe536a34a25705fb935a6ca8e42f45ff006f9856b47103da054db15582455579
diff --git a/net-analyzer/icinga2/icinga2-2.8.2.ebuild b/net-analyzer/icinga2/icinga2-2.8.2.ebuild
new file mode 100644
index 000000000000..4108f14e4147
--- /dev/null
+++ b/net-analyzer/icinga2/icinga2-2.8.2.ebuild
@@ -0,0 +1,176 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+if [[ ${PV} != 9999 ]]; then
+ inherit cmake-utils depend.apache eutils systemd toolchain-funcs user wxwidgets
+ SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+else
+ inherit cmake-utils depend.apache eutils git-r3 systemd toolchain-funcs user wxwidgets
+ EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
+ EGIT_BRANCH="master"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Distributed, general purpose, network monitoring engine"
+HOMEPAGE="http://icinga.org/icinga2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins studio +vim-syntax"
+WX_GTK_VER="3.0"
+
+CDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ >=dev-libs/boost-1.58-r1
+ console? ( dev-libs/libedit )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql:= )"
+
+DEPEND="
+ ${CDEPEND}
+ sys-devel/bison
+ >=sys-devel/flex-2.5.35"
+
+RDEPEND="
+ ${CDEPEND}
+ plugins? ( || (
+ net-analyzer/monitoring-plugins
+ net-analyzer/nagios-plugins
+ ) )
+ mail? ( virtual/mailx )
+ classicui? ( net-analyzer/icinga[web] )
+ studio? ( x11-libs/wxGTK:3.0 )"
+
+REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+ if use studio ; then
+ setup-wxwidgets
+ fi
+ enewgroup icinga
+ enewgroup icingacmd
+ enewgroup nagios # for plugins
+ enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
+}
+
+src_configure() {
+ sed -i 's/FLAGS\}\ \-g/FLAGS\}\ \-lpthread\ /g' CMakeLists.txt || die
+ local mycmakeargs=(
+ -DICINGA2_UNITY_BUILD=FALSE
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc
+ -DCMAKE_INSTALL_LOCALSTATEDIR=/var
+ -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
+ -DICINGA2_PLUGINDIR="/usr/$(get_libdir)/nagios/plugins"
+ -DICINGA2_USER=icinga
+ -DICINGA2_GROUP=icingacmd
+ -DICINGA2_COMMAND_GROUP=icingacmd
+ -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
+ -DLOGROTATE_HAS_SU=ON
+ )
+ # default to off if minimal, allow the flags to be set otherwise
+ if use minimal; then
+ mycmakeargs+=(
+ -DICINGA2_WITH_MYSQL=OFF
+ -DICINGA2_WITH_PGSQL=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DICINGA2_WITH_PGSQL=$(usex postgres ON OFF)
+ -DICINGA2_WITH_MYSQL=$(usex mysql ON OFF)
+ )
+ fi
+ # LTO
+ if use lto; then
+ mycmakeargs+=(
+ -DICINGA2_LTO_BUILD=ON
+ )
+ else
+ mycmakeargs+=(
+ -DICINGA2_LTO_BUILD=OFF
+ )
+ fi
+ # STUDIO
+ if use studio; then
+ mycmakeargs+=(
+ -DICINGA2_WITH_STUDIO=ON
+ )
+ else
+ mycmakeargs+=(
+ -DICINGA2_WITH_STUDIO=OFF
+ )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
+ cd "${BUILDDIR}" || die
+
+ emake DESTDIR="${D}" install
+
+ einstalldocs
+
+ newinitd "${FILESDIR}"/icinga2.initd icinga2
+
+ if use mysql ; then
+ docinto schema
+ newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
+ docinto schema/upgrade
+ dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
+ elif use postgres ; then
+ docinto schema
+ newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
+ docinto schema/upgrade
+ dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
+ fi
+
+ keepdir /etc/icinga2
+ keepdir /var/lib/icinga2/api/zones
+ keepdir /var/lib/icinga2/api/repository
+ keepdir /var/lib/icinga2/api/log
+ keepdir /var/spool/icinga2/perfdata
+
+ rm -r "${D}/var/run" || die "failed to remove /var/run"
+ rm -r "${D}/var/cache" || die "failed to remove /var/cache"
+
+ fowners root:icinga /etc/icinga2
+ fperms 0750 /etc/icinga2
+ fowners icinga:icinga /var/lib/icinga2
+ fowners icinga:icinga /var/spool/icinga2
+ fowners -R icinga:icingacmd /var/lib/icinga2/api
+ fowners icinga:icinga /var/spool/icinga2/perfdata
+ fowners icinga:icingacmd /var/log/icinga2
+
+ fperms ug+rwX,o-rwx /etc/icinga2
+ fperms ug+rwX,o-rwx /var/lib/icinga2
+ fperms ug+rwX,o-rwx /var/spool/icinga2
+ fperms ug+rwX,o-rwx /var/log/icinga2
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles
+ doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
+ doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
+ fi
+
+ if use nano-syntax; then
+ insinto /usr/share/nano
+ doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} && ${REPLACING_VERSIONS} != ${PV} ]]; then
+ elog "DB IDO schema upgrade may be required required.
+ http://docs.icinga.org/icinga2/snapshot/doc/module/icinga2/chapter/upgrading-icinga-2"
+ fi
+}