summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-01-13 18:23:17 +0800
committerYixun Lan <dlan@gentoo.org>2021-01-14 07:01:38 +0800
commitece0688d7e87c228aae050c734caabc71310201b (patch)
tree556b5719ddbeccc4fc0958e9fffe5e586b29365a
parentdev-lang/go: Stabilize 1.15.6-r1 ppc64, #764509 (diff)
downloadgentoo-ece0688d7e87c228aae050c734caabc71310201b.tar.gz
gentoo-ece0688d7e87c228aae050c734caabc71310201b.tar.bz2
gentoo-ece0688d7e87c228aae050c734caabc71310201b.zip
dev-python/python-linux-procfs: version bump 0.6.3
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--dev-python/python-linux-procfs/Manifest1
-rw-r--r--dev-python/python-linux-procfs/python-linux-procfs-0.6.3.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-linux-procfs/Manifest b/dev-python/python-linux-procfs/Manifest
index cf7f084be080..9c5966272ecc 100644
--- a/dev-python/python-linux-procfs/Manifest
+++ b/dev-python/python-linux-procfs/Manifest
@@ -1 +1,2 @@
DIST python-linux-procfs-0.6.1.tar.xz 18540 BLAKE2B efda66e0264db15b0c1904b9dca631683d089207abe57d165a25e71f68194c249a22394c997a13a71b0333aa27dbe7ac1b47488f715e22655d0f9217346d7ce7 SHA512 14f7510828d5a3eea1a8267041b604046392dbb8d7980b03b4d10bdefa88a89a5f69acdfea77255ba664c2ef33ce52273490214b3f76d2865e7b1dcc83e8e265
+DIST python-linux-procfs-0.6.3.tar.xz 18808 BLAKE2B 02fdc0349dd456819f67f82d6836a44e3285e16d9654dd52b58ac7d86e48bc559feda18f105db7911ac5f670fd0e6cfd5c6cc69a958a3e8494813ff244f8b06f SHA512 18e42bf12456893740c5ec950ffcca86945b1ff202a6ea3ae6ac800145771a39b4ab7e8bbb440210d48d0fe9de646e334095afd0b20060e2e28ab3fa844f6140
diff --git a/dev-python/python-linux-procfs/python-linux-procfs-0.6.3.ebuild b/dev-python/python-linux-procfs/python-linux-procfs-0.6.3.ebuild
new file mode 100644
index 000000000000..06ab368f999e
--- /dev/null
+++ b/dev-python/python-linux-procfs/python-linux-procfs-0.6.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python classes to extract information from the Linux kernel /proc files"
+HOMEPAGE="
+ https://git.kernel.org/pub/scm/libs/python/python-linux-procfs/
+ https://kernel.googlesource.com/pub/scm/libs/python/python-linux-procfs/python-linux-procfs/"
+SRC_URI="https://cdn.kernel.org/pub/software/libs/python/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"