summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-16 11:03:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-16 11:36:29 +0200
commiteced857ed9e46527da0466762e27e9602c312237 (patch)
treec7e2c55d2c5b8cfc2deca0b6d2305ce378da573b
parentsys-process/numactl: keyword ~arm64 (diff)
downloadgentoo-eced857ed9e46527da0466762e27e9602c312237.tar.gz
gentoo-eced857ed9e46527da0466762e27e9602c312237.tar.bz2
gentoo-eced857ed9e46527da0466762e27e9602c312237.zip
media-libs/x265: convert to cpu_flags_arm
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--media-libs/x265/x265-2.4.ebuild6
-rw-r--r--media-libs/x265/x265-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/media-libs/x265/x265-2.4.ebuild b/media-libs/x265/x265-2.4.ebuild
index 8e49624f425e..9aa6aafc30d2 100644
--- a/media-libs/x265/x265-2.4.ebuild
+++ b/media-libs/x265/x265-2.4.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/116"
-IUSE="+10bit +12bit neon numa pic power8 test"
+IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
@@ -158,8 +158,8 @@ multilib_src_configure() {
# bug #510890
myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
elif [[ ${ABI} = arm ]] ; then
- myabicmakeargs+=( -DENABLE_ASSEMBLY=$(usex pic OFF $(usex neon ON OFF)) )
- use neon && use pic && ewarn "PIC has been requested but arm neon asm is not PIC-safe, disabling it."
+ myabicmakeargs+=( -DENABLE_ASSEMBLY=$(usex pic OFF $(usex cpu_flags_arm_neon ON OFF)) )
+ use cpu_flags_arm_neon && use pic && ewarn "PIC has been requested but arm neon asm is not PIC-safe, disabling it."
fi
local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index 8e49624f425e..9aa6aafc30d2 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/116"
-IUSE="+10bit +12bit neon numa pic power8 test"
+IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
@@ -158,8 +158,8 @@ multilib_src_configure() {
# bug #510890
myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
elif [[ ${ABI} = arm ]] ; then
- myabicmakeargs+=( -DENABLE_ASSEMBLY=$(usex pic OFF $(usex neon ON OFF)) )
- use neon && use pic && ewarn "PIC has been requested but arm neon asm is not PIC-safe, disabling it."
+ myabicmakeargs+=( -DENABLE_ASSEMBLY=$(usex pic OFF $(usex cpu_flags_arm_neon ON OFF)) )
+ use cpu_flags_arm_neon && use pic && ewarn "PIC has been requested but arm neon asm is not PIC-safe, disabling it."
fi
local MULTIBUILD_VARIANTS=( $(x265_get_variants) )