summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-08-16 15:47:45 +0200
committerSebastian Pipping <sping@gentoo.org>2021-08-16 15:47:45 +0200
commitecf3e1728074f529f58f97150ed0f010c72021a4 (patch)
tree78f89d13177f80f595cb023c88eb896320797888
parentdev-python/iminuit: Add scipy test-dep (diff)
downloadgentoo-ecf3e1728074f529f58f97150ed0f010c72021a4.tar.gz
gentoo-ecf3e1728074f529f58f97150ed0f010c72021a4.tar.bz2
gentoo-ecf3e1728074f529f58f97150ed0f010c72021a4.zip
dev-python/ujson: 4.1.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.20, Repoman-3.0.3
-rw-r--r--dev-python/ujson/Manifest1
-rw-r--r--dev-python/ujson/ujson-4.1.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/ujson/Manifest b/dev-python/ujson/Manifest
index 90f2344aa4a5..e48fc8c2c9da 100644
--- a/dev-python/ujson/Manifest
+++ b/dev-python/ujson/Manifest
@@ -1 +1,2 @@
DIST ujson-4.0.2.tar.gz 7129106 BLAKE2B 8ebf68c6bac65100baeee4f95f175ada09ba48b9efe1876b7b1ff2c3cf87d1a50d8300a981fd97eac73e4c5a70af1b7fddcd468aa6067aac8a2e44133f397057 SHA512 ece12d4407cb7cdb647597ff7fc32e4390fc4c790c59e764da5c5644e5dec470c48cb6a6aaa18429cb713643e5205c5d26b2d2d2195bc90f3a171615d3dbd80d
+DIST ujson-4.1.0.tar.gz 7129002 BLAKE2B 0a9b8d90ca977b3abf7a3dbcb42fc40d9b6faa120ea59aac2aacb83faadf36cb3c0ca1073579f6bc5f94c6bd45550d82e55e1859b0afc7b3bed511e63626703f SHA512 b3661c23fcdad2dbbac1d92b319f85ad3b7b575c1e773f5207cc83811974ed8de0e9780acb50986fcdea1c4237d5ded8d10a9bb641468b198824f5da15b8ae0e
diff --git a/dev-python/ujson/ujson-4.1.0.ebuild b/dev-python/ujson/ujson-4.1.0.ebuild
new file mode 100644
index 000000000000..3d2e889a9b9d
--- /dev/null
+++ b/dev-python/ujson/ujson-4.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
+HOMEPAGE="https://pypi.org/project/ujson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytz[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest