summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-23 10:07:36 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-23 10:12:25 +0300
commited2ce8eda5423ad4fb0f922df06a49f8c73dc12a (patch)
treea0dfce294cc4ba5b230368e82ab19295b20480f9
parentapp-admin/awscli: add 1.22.101 (diff)
downloadgentoo-ed2ce8eda5423ad4fb0f922df06a49f8c73dc12a.tar.gz
gentoo-ed2ce8eda5423ad4fb0f922df06a49f8c73dc12a.tar.bz2
gentoo-ed2ce8eda5423ad4fb0f922df06a49f8c73dc12a.zip
dev-python/fonttools: add 4.33.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.33.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index abe838319248..07ed79e7d6be 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -4,3 +4,4 @@ DIST fonttools-4.31.2.tar.gz 2965796 BLAKE2B d776073e7a9358e67b8753dd4557e2b1b4c
DIST fonttools-4.32.0.tar.gz 2966840 BLAKE2B 67a79c8c2e26f9f72fcf6ea4ab5ee3712d3541b47528a209221f9fcf82a5b5db589561200e4b6911a32102a4f4dc4b4e34c8271eb97b1cee18a81b3039efdf03 SHA512 a71a44601c7ec9f709ddc14da1c26d1248909fba8a0bfb7104ebe5f9b85949fe479c5eabdd2c94086d9999756035291e68bb7e861488d4123ccf667ac3ac2e03
DIST fonttools-4.33.0.tar.gz 3525052 BLAKE2B 5ea275adbfbf6e01222f6eba8f5eef7afe533b9692e6a7a2fb644fb68dec632ab2962d6b7f6b4ff876676e8314aadbfc04a005ea7a389904e398723feaa756d0 SHA512 147f6d41d1a6b27ebe6973cb91a90384291ad8c7b75b71c3b814908012530066b79f4c39bdd6da9e98614ef61b1cc19803756aba73e4da7ce2e82147390f0023
DIST fonttools-4.33.1.tar.gz 3526591 BLAKE2B c720e9159602168bc2f435f96e9b470e95a748e3e61aac717659e01e5998c8ead825056fe6114cb40be47ab1ebcd7dc6f3152cccd87aec5b49134147694aa3eb SHA512 14e4da0e146d4b88ab6375ad7c912f1ec6f437386e2d676bbffcd5a84be980151ed4f77f69bf618843b321106ca763af564cf05dfb6fa11888f02adfde7d74b2
+DIST fonttools-4.33.2.tar.gz 3526700 BLAKE2B faa8db2d5ba80a7cb2cd4fb82045aa821f72d296c3b0994f266c69bc1f38b9c46a24208612d539e3576d75371d95d49d9a103fed8ab7604ebf0df50ec8f25d2f SHA512 dd032f9f8d9167aa8d83137006062a5d293aeb4116cd2b24a9d5d3d750887876214a6b6e9fe54efd569cada64164c76f242b234569d86b45e5f279d6c1a5db95
diff --git a/dev-python/fonttools/fonttools-4.33.2.ebuild b/dev-python/fonttools/fonttools-4.33.2.ebuild
new file mode 100644
index 000000000000..f0532d0a8742
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.33.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/fs-2.4.9[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ export FONTTOOLS_WITH_CYTHON=1
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest Tests fontTools || die "Tests failed with ${EPYTHON}"
+}