summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-27 02:28:02 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-27 10:10:04 +1200
commited78f2696909417e81239c455fc9346b5d4e2a34 (patch)
tree59ef1c8594af4b66bc6cbc84b51122eb63ef6089
parentdev-util/diffoscope: bump up to 149 (diff)
downloadgentoo-ed78f2696909417e81239c455fc9346b5d4e2a34.tar.gz
gentoo-ed78f2696909417e81239c455fc9346b5d4e2a34.tar.bz2
gentoo-ed78f2696909417e81239c455fc9346b5d4e2a34.zip
dev-perl/Compress-Bzip2: Bump to versoin 2.270.0
- EAPI7 - Unconditionally patch bad tests - Pass CFLAGS to make - Fix LICENSE Upstream: - Fix various null derefs - Drop support for 5.6 explicitly Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Compress-Bzip2/Compress-Bzip2-2.270.0.ebuild41
-rw-r--r--dev-perl/Compress-Bzip2/Manifest1
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Compress-Bzip2/Compress-Bzip2-2.270.0.ebuild b/dev-perl/Compress-Bzip2/Compress-Bzip2-2.270.0.ebuild
new file mode 100644
index 000000000000..772c9cd6ebe8
--- /dev/null
+++ b/dev-perl/Compress-Bzip2/Compress-Bzip2-2.270.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_VERSION=2.27
+DIST_AUTHOR=RURBAN
+inherit perl-module
+
+DESCRIPTION="Interface to Bzip2 compression library"
+# perl5.x or newer license
+# https://bugs.gentoo.org/718946#c7
+LICENSE="|| ( Artistic GPL-1+ ) BZIP2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~mips ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-arch/bzip2
+ virtual/perl-Carp
+ virtual/perl-File-Spec
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+PERL_RM_FILES=(
+ t/900_kwalitee.t
+ t/900_leaktrace.t
+ t/900_meta.t
+ t/900_perl_minimum_version.t
+ t/900_pod-coverage.t
+ t/900_pod.t
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/Compress-Bzip2/Manifest b/dev-perl/Compress-Bzip2/Manifest
index 2c00fc41d060..96d6ce02a8eb 100644
--- a/dev-perl/Compress-Bzip2/Manifest
+++ b/dev-perl/Compress-Bzip2/Manifest
@@ -1 +1,2 @@
DIST Compress-Bzip2-2.26.tar.gz 886999 BLAKE2B b7107d522c172958f9cf137b2fa5ba7a88da8114b467eb20eb7da5d67f09d86105277ad4711cff0cfc3478518557fb37cbc8a1b80d1f37070d51e69b93747f3b SHA512 be1670303496a9f48989777468234d52276b34e6c0fdb6e99d2199134f353f1ee32e0489a3797ab3a2d4777bb5f03f78dff39f3bf75b8cc511b754da2b7e4959
+DIST Compress-Bzip2-2.27.tar.gz 895618 BLAKE2B d9ea154068caad5edc24888d23609a40be8006fb2d88b9eabf27142b3997e4e03eaa14fb04341eed9a8b896e911f737d3b0cc67803684c8fc37f5e1bff850578 SHA512 4c3ff0354a0fd4b561ed80f9a8cc63a98921a1dd584535805e5158d492424b5fb67aac6e02be76209910584f10dcebe3d3e954999346ed6cdf192aa340c2d2cd