summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-07-12 14:15:38 -0400
committerTim Harder <radhermit@gentoo.org>2016-07-12 14:15:38 -0400
commitee6c6d3374d9e692e30814c163f848705138287a (patch)
tree85a231761e942bbea4491643e4a0fe17e67ef958
parentsys-fs/fuse: version bump to 2.9.7 (diff)
downloadgentoo-ee6c6d3374d9e692e30814c163f848705138287a.tar.gz
gentoo-ee6c6d3374d9e692e30814c163f848705138287a.tar.bz2
gentoo-ee6c6d3374d9e692e30814c163f848705138287a.zip
dev-python/llfuse: version bump to 1.1
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index 257d4c64ef80..d8e94afe42c7 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -3,3 +3,4 @@ DIST llfuse-0.41.tar.bz2 397155 SHA256 58079acce2ed03305bfea998cfad7c5d1815c85c2
DIST llfuse-0.42.1.tar.bz2 320282 SHA256 8ee9f190682d1c94e6522e77064fcdb4c7b07e71a6b9d1193ac1527972a98b59 SHA512 b87b26a3b19db954110248233f393c2c445d42b0fd89d83da3282d1f21f9ef6285721f3348e86d00d46584e3fc9896c6111d9573a103505476ab4f59d2c1b444 WHIRLPOOL c08d356e8170180aba87de9b5fb8f716a99865040582f90ec4a144c88b27f10f5e36ef4af20a29367cf3e4ae971a1a1b731e2717f7d1dece70754af49a4e535b
DIST llfuse-0.43.tar.bz2 323979 SHA256 550c23c99ab1da711e816bdd980d588de174e143bc96cdb1f11c6ae6af35c7a1 SHA512 d3dfd33898eefd5774d007c960ac72f6c7a509ad18b5fb520a07f8c9b23414ba3f171e7d36a8703cdb2421270c3a3da82626cb6be7eb0cb3840d29506926c73f WHIRLPOOL 07b9e181f48d2f6d512436c775011b81f5db2e144809c9010e3a6cb263be75ebea1bebac7ecd02e242214b31feb18bafc0b996d36b257db152762769bdb5f127
DIST llfuse-1.0.tar.bz2 323706 SHA256 fa521ce77a8c0ac1c8c21e6d4b0705dacc0ddd627439c2b3827c674909c027d2 SHA512 17d5fc91083dc29b11120980b68d000605582a757bf61a09ce4b840105fe0dc2b6afa416d09bf2abf11fd3c8bcbd5dfa4d90a9c9cc955c80a38111fb594e8b06 WHIRLPOOL aa8d22d0e7c6f5121c981c3c4fe7999aada35fa3bd5189c1ea14715366880af40105e8c35b4da7a098df449b277761a8dc50c489e65a074de430227599f032ac
+DIST llfuse-1.1.tar.bz2 326175 SHA256 e250d59f3ed0d91a6bdcf81ab8af5ade994de3abb96bc5e64cd465a8265e9ffb SHA512 8e468c35cf74ab25a17b17364bbb5b5c8ab02ab5f4fe911970792dc57b5a7d87bea3889a81ff8dafd4438de3ea1ec96ec974025a33f177c84347c0830c6e1432 WHIRLPOOL d49738f666478f0e267045df0a68435cdf7a12e95ead306ab678d6a56843ddd419be49d4bd8c76990b21b08e051f0ae7e5bf641d94c69c4ccc2e989f73711024
diff --git a/dev-python/llfuse/llfuse-1.1.ebuild b/dev-python/llfuse/llfuse-1.1.ebuild
new file mode 100644
index 000000000000..3805b28f8025
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://python-llfuse.googlecode.com/ https://pypi.python.org/pypi/llfuse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=sys-fs/fuse-2.8.0
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}