summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-02-02 18:41:50 -0500
committerMichael Orlitzky <mjo@gentoo.org>2022-02-02 19:21:07 -0500
commitee75ce635b2cfc37d9fe7ad741c43d02c87eb0bd (patch)
tree02a36c90ec81be333f7a1871d1124267399d0eb5
parentsci-mathematics/giac: version bump. Disable quickjs. (diff)
downloadgentoo-ee75ce635b2cfc37d9fe7ad741c43d02c87eb0bd.tar.gz
gentoo-ee75ce635b2cfc37d9fe7ad741c43d02c87eb0bd.tar.bz2
gentoo-ee75ce635b2cfc37d9fe7ad741c43d02c87eb0bd.zip
sci-mathematics/giac: remove old "unused" giac-1.7.0.45.ebuild.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/giac/Manifest1
-rw-r--r--sci-mathematics/giac/giac-1.7.0.45.ebuild165
2 files changed, 0 insertions, 166 deletions
diff --git a/sci-mathematics/giac/Manifest b/sci-mathematics/giac/Manifest
index 259cb91e5543..ba633ee610c4 100644
--- a/sci-mathematics/giac/Manifest
+++ b/sci-mathematics/giac/Manifest
@@ -1,3 +1,2 @@
DIST giac_1.7.0-13.tar.gz 86447065 BLAKE2B 4d91e83608f7ec376d133c2784ffce99447a9dd78b5c8582b81a0aae0b8ac59eec4db3ee4a8bcb39202c777c300178a181f2dc2ac74ab445ddba2f3efa0ecb1b SHA512 99fff7ce5117fd8c106601ead03679805d529fe12d5372cdd4ae54824aa6fdcbdaaa1a62ea1153391a1a65af8970e38fca7d95ca9983755ff06053f1d8b6d65a
-DIST giac_1.7.0-45.tar.gz 96780194 BLAKE2B c43b0f89ad664b419db5d98541f23d3259a32b462d71f3a4fe06ea2ac3de0dd71d903308cd8e241758d809d0755a2f070bae03434a75abc94f17b1d8cbda03a2 SHA512 47fa019fee526d584f5dbc67adb4326e2680649ad942a2140d033ecd66957ba7a21441f02a3ba55d009bbd6756da239fcee99cab2a361993aae4df6e9f79a1a7
DIST giac_1.7.0-47.tar.gz 96787570 BLAKE2B b05b3f44f10695a5d085df0a0db9aba761ac011964caeb247bd6034ca2a41505e5eb30df0de494826270703d9b62fbb3b9d4869f4cdd32d1d88636f374fbae16 SHA512 60a8550f7da2a163365759266660421c936797a9d52c3ba3802b5e00610fc460b49ccef44df809331abb1cbb65432e283fb4484b1efffb577c4802ab44fecff7
diff --git a/sci-mathematics/giac/giac-1.7.0.45.ebuild b/sci-mathematics/giac/giac-1.7.0.45.ebuild
deleted file mode 100644
index 70e638c38502..000000000000
--- a/sci-mathematics/giac/giac-1.7.0.45.ebuild
+++ /dev/null
@@ -1,165 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic xdg-utils
-
-FETCH_P="${PN}_"$(ver_rs 3 '-')
-MY_PV=$(ver_cut 1-3)
-DESCRIPTION="A free C++ Computer Algebra System library and its interfaces"
-HOMEPAGE="https://www-fourier.ujf-grenoble.fr/~parisse/giac.html"
-SRC_URI="https://www-fourier.ujf-grenoble.fr/~parisse/debian/dists/stable/main/source/${FETCH_P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-LANGS="el en es pt"
-IUSE="ao doc +ecm examples gc +glpk gui static-libs test"
-for X in ${LANGS} ; do
- IUSE="${IUSE} l10n_${X}"
-done
-
-# nauty and cliquer are automagical dependencies
-RDEPEND="dev-libs/gmp:=[cxx(+)]
- sys-libs/readline:=
- gui? ( x11-libs/fltk
- media-libs/libpng:= )
- ao? ( media-libs/libao )
- dev-libs/mpfr:=
- sci-libs/mpfi
- sci-libs/gsl:=
- sci-mathematics/pari:=[threads]
- dev-libs/ntl:=
- virtual/lapack
- virtual/blas
- net-misc/curl
- sci-mathematics/cliquer
- sci-mathematics/nauty
- ecm? ( sci-mathematics/gmp-ecm )
- glpk? ( sci-mathematics/glpk )
- gc? ( dev-libs/boehm-gc )"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="dev-tex/hevea
- virtual/pkgconfig
- virtual/yacc"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.7.0.1-gsl_lapack.patch"
- "${FILESDIR}/${PN}-1.6.0-pari-2.11.patch"
-)
-
-REQUIRED_USE="test? ( gui )"
-
-# The mirror restriction is due to the French documentation for which
-# "Other kind of redistributions require the consent of the copyright
-# holder."
-RESTRICT="!test? ( test ) mirror"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- append-cxxflags -std=c++14 # bug 788283
-
- if use gui; then
- append-cppflags -I$(fltk-config --includedir)
- append-lfs-flags
-
- # Get the big-L flags from fltk's LDFLAGS.
- append-ldflags $(fltk-config --ldflags | sed -e 's/\(-L\S*\)\s.*/\1/')
- fi
-
- # Using libsamplerate is currently broken
- #
- # The giac build system supports --docdir, but the path /usr/share/giac/doc
- # is hard-coded throughout the source code, so passing anything else to
- # ./configure --docdir just causes problems. Later, we'll put things right.
- #
- # micropython is for specific use in an upstream project
- econf \
- --enable-gmpxx \
- --disable-samplerate \
- --disable-micropy \
- --docdir="${EPREFIX}"/usr/share/giac/doc \
- $(use_enable static-libs static) \
- $(use_enable gui) \
- $(use_enable gui png) \
- $(use_enable ao) \
- $(use_enable ecm) \
- $(use_enable glpk) \
- $(use_enable gc)
-
-}
-
-src_install() {
- docompress -x "/usr/share/doc/${PF}/"{aide_cas,doc,examples}
- emake install DESTDIR="${D}"
-
- # Move all of /usr/share/giac (which contains only documentation) to
- # its /usr/share/doc/${PF} counterpart.
- dodir /usr/share/doc
- mv "${ED}"/usr/share/giac "${ED}/usr/share/doc/${PF}" || die
-
- # and create a symlink from the original location to the new one
- dosym "./doc/${PF}" /usr/share/giac
-
- # This is duplicated in ${ED}/usr/share/doc/${PF}/examples
- rm -r "${ED}/usr/share/doc/${PF}/doc/Exemples" || die
-
- # These aren't supposed to be installed at all.
- find "${ED}/usr/share/doc/${PF}" -type f -name 'Makefile*' -delete || die
-
- # The French docs are not freely licensed according to the README.
- rm -r "${ED}/usr/share/doc/${PF}/doc/fr" || die
-
- dodoc AUTHORS ChangeLog INSTALL NEWS README TROUBLES
- if ! use gui; then
- rm -rf \
- "${ED}"/usr/bin/x* \
- "${ED}"/usr/share/application-registry \
- "${ED}"/usr/share/applications \
- "${ED}"/usr/share/icons \
- || die "failed to clean up fltk files"
- fi
-
- if ! use doc; then
- rm -r "${ED}/usr/share/doc/${PF}/doc" || die "failed to remove doc directory"
- else
- for lang in ${LANGS}; do
- if use l10n_$lang; then
- dosym ../aide_cas "/usr/share/doc/${PF}/doc/${lang}/aide_cas"
- else
- rm -r "${ED}/usr/share/giac/doc/${lang}" \
- || die "failed to remove ${lang} documentation"
- fi
- done
- fi
-
- if ! use examples; then
- rm -r "${ED}/usr/share/doc/${PF}/examples" \
- || die "failed to remove examples"
- fi
-
- find "${ED}" -type f -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- if use gui; then
- xdg_desktop_database_update
- xdg_icon_cache_update
- fi
-}
-
-pkg_postrm() {
- if use gui; then
- xdg_desktop_database_update
- xdg_icon_cache_update
- fi
-}