summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-08 13:21:29 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-08 13:21:29 +0100
commitef0c907f6a3a63b48b344de0fe889e331c03aec9 (patch)
tree952d9e4e901a38fefa58947424d87cc1d0ae1325
parentsys-boot/mbr-gpt: treeclean (diff)
downloadgentoo-ef0c907f6a3a63b48b344de0fe889e331c03aec9.tar.gz
gentoo-ef0c907f6a3a63b48b344de0fe889e331c03aec9.tar.bz2
gentoo-ef0c907f6a3a63b48b344de0fe889e331c03aec9.zip
app-editors/elvis: treeclean
Closes: https://bugs.gentoo.org/884429 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--app-editors/elvis/Manifest1
-rw-r--r--app-editors/elvis/elvis-2.2.0-r8.ebuild108
-rw-r--r--app-editors/elvis/files/elvis-2.2.0-glibc-2.10.patch48
-rw-r--r--app-editors/elvis/files/elvis-2.2.0-interix.patch11
-rw-r--r--app-editors/elvis/files/ft2.3-symbol-collision-fix.patch73
-rw-r--r--app-editors/elvis/metadata.xml8
-rw-r--r--profiles/package.mask5
7 files changed, 0 insertions, 254 deletions
diff --git a/app-editors/elvis/Manifest b/app-editors/elvis/Manifest
deleted file mode 100644
index 03ab34d3a5ad..000000000000
--- a/app-editors/elvis/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST elvis-2.2_0.tar.gz 1439293 BLAKE2B c061370a3a9a9d24bcdba65f1d16b5b8d7dd6a5a9e777949c80862f8e9ce879dac6685f625c0fd86cae26efbbf58277d9626be2f4e513d1b1bed131cc60eb95d SHA512 847cc9ac0af170798abd4725f7dc2ec74d4931fb761b58836d4016d36da5657176bd8cdcdae02bc08438b18e8ce2433eb3340ec2503630fd2992e83ba06adf42
diff --git a/app-editors/elvis/elvis-2.2.0-r8.ebuild b/app-editors/elvis/elvis-2.2.0-r8.ebuild
deleted file mode 100644
index ded9e0a3c4c4..000000000000
--- a/app-editors/elvis/elvis-2.2.0-r8.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit versionator toolchain-funcs
-
-MY_PV=$(replace_version_separator 2 '_')
-
-DESCRIPTION="A vi/ex clone"
-HOMEPAGE="http://elvis.the-little-red-haired-girl.org"
-SRC_URI="ftp://ftp.cs.pdx.edu/pub/elvis/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 ~riscv x86 ~ppc-macos ~sparc-solaris"
-IUSE="X doc"
-
-RDEPEND="
- sys-libs/ncurses:0=
- app-eselect/eselect-vi
- X? (
- >=x11-libs/libX11-1.0.0
- >=x11-libs/libXt-1.0.0
- >=x11-libs/libXpm-3.5.4.2
- >=x11-libs/libXft-2.1.8.2
- )"
-
-DEPEND="
- ${RDEPEND}
- X? ( x11-base/xorg-proto )
- virtual/pkgconfig"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-PATCHES=(
- "${FILESDIR}"/ft2.3-symbol-collision-fix.patch
- "${FILESDIR}"/${P}-glibc-2.10.patch
- "${FILESDIR}"/${P}-interix.patch
-)
-
-src_configure() {
- export CC="$(tc-getCC)"
- ./configure \
- --libs="$($(tc-getPKG_CONFIG) --libs ncurses)" \
- --prefix="${EPREFIX}"/usr \
- --bindir="${EPREFIX}"/usr/bin \
- --datadir="${EPREFIX}"/usr/share/elvis \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use_with X x) \
- || die
-
- # Some Makefile fixups (must happen after configure)
- # Use our CFLAGS
- sed -e "s#^CFLAGS=\(.*\)#CFLAGS=\1 ${CFLAGS}#g;" -i Makefile || \
- die "sed 1 failed"
-
- # We'll install the man-pages ourselves
- sed -i -e '/^ sh instman.sh/d' Makefile || die "sed 2 failed"
-
- # Don't try to write to /etc
- sed -i -e 's,/etc/elvis,${ED}/etc/elvis,g' Makefile || die "sed 3 failed"
-
- # Use LDFLAGS
- sed -i -e "s#\$(CC) \$(CFLAGS)#\$(CC) \$(CFLAGS) ${LDFLAGS}#" Makefile || \
- die "sed 4 failed"
-}
-
-src_install() {
- dodir /usr/bin
- dodir /usr/share/man/man1
- dodir /usr/share/elvis
- dodir /usr/share/doc/${PF}
- dodir /etc
-
- local docdir="${ED}/usr/share/doc/${PF}"
- if ! use doc; then
- docdir="${T}/doc-discard"
- fi
-
- emake install \
- PREFIX="${ED}"/usr \
- BINDIR="${ED}"/usr/bin \
- DATADIR="${ED}"/usr/share/elvis \
- DOCDIR="${docdir}"
-
- # Install the man-pages
- mv doc/elvis.man doc/elvis.1 || die
- mv doc/elvtags.man doc/elvtags.1 || die
- mv doc/ref.man doc/ref.1 || die
- doman doc/*.1
-
- # Fixup some READMEs
- sed -i -e "s,${ED},,g" "${ED}"/etc/elvis/README \
- || die 'sed /etc/elvis/README failed'
- sed -i -e "s,${ED},,g" "${ED}"/usr/share/elvis/README \
- || die 'sed /usr/share/elvis/README failed'
-}
-
-pkg_postinst() {
- einfo "Setting /usr/bin/vi symlink"
- eselect vi set "${PN}"
-}
-
-pkg_postrm() {
- einfo "Updating /usr/bin/vi symlink"
- eselect vi update
-}
diff --git a/app-editors/elvis/files/elvis-2.2.0-glibc-2.10.patch b/app-editors/elvis/files/elvis-2.2.0-glibc-2.10.patch
deleted file mode 100644
index 1a3d1affb303..000000000000
--- a/app-editors/elvis/files/elvis-2.2.0-glibc-2.10.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -ur elvis-2.2_0.orig/ref.c elvis-2.2_0/ref.c
---- elvis-2.2_0.orig/ref.c 2003-10-21 05:32:25.000000000 +0300
-+++ elvis-2.2_0/ref.c 2009-08-05 21:28:30.000000000 +0300
-@@ -42,7 +42,7 @@
-
- #if USE_PROTOTYPES
- static void usage(char *argv0);
--static char *getline(FILE *fp);
-+static char *get_line(FILE *fp);
- static void store(char *line, char **list);
- static LINECLS classify(char *line, LINECLS prev);
- static void lookup(TAG *tag);
-@@ -171,7 +171,7 @@
- /* This function reads a single line, and replaces the terminating newline with
- * a '\0' byte. The string will be in a static buffer. Returns NULL at EOF.
- */
--static char *getline(fp)
-+static char *get_line(fp)
- FILE *fp;
- {
- int ch;
-@@ -348,7 +348,7 @@
- }
-
- /* for each line... */
-- for (lnum = 1, lc = LC_COMPLETE; (line = getline(fp)) != NULL; lnum++)
-+ for (lnum = 1, lc = LC_COMPLETE; (line = get_line(fp)) != NULL; lnum++)
- {
- /* is this the tag definition? */
- if (taglnum > 0 ? taglnum == lnum : !strncmp(tagline, line, len))
-@@ -377,7 +377,7 @@
- {
- if (strchr(line, '(') != NULL)
- {
-- while ((line = getline(fp)) != NULL
-+ while ((line = get_line(fp)) != NULL
- && *line
- && ((*line != '#' && *line != '{')
- || line[strlen(line) - 1] == '\\'))
-@@ -387,7 +387,7 @@
- }
- else if ((lc = classify(line, lc)) == LC_PARTIAL)
- {
-- while ((line = getline(fp)) != NULL
-+ while ((line = get_line(fp)) != NULL
- && (lc = classify(line, lc)) == LC_PARTIAL)
- {
- puts(line);
diff --git a/app-editors/elvis/files/elvis-2.2.0-interix.patch b/app-editors/elvis/files/elvis-2.2.0-interix.patch
deleted file mode 100644
index e16024374716..000000000000
--- a/app-editors/elvis/files/elvis-2.2.0-interix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ru -x '*.Po' -x '*.Plo' elvis-2.2_0.orig/osunix/osblock.c elvis-2.2_0/osunix/osblock.c
---- elvis-2.2_0.orig/osunix/osblock.c 2008-04-03 12:00:26 +0200
-+++ elvis-2.2_0/osunix/osblock.c 2008-04-03 12:01:53 +0200
-@@ -293,5 +293,7 @@
- return;
- #endif
-
-+#ifndef __INTERIX
- sync();
-+#endif
- }
diff --git a/app-editors/elvis/files/ft2.3-symbol-collision-fix.patch b/app-editors/elvis/files/ft2.3-symbol-collision-fix.patch
deleted file mode 100644
index aac099e56ef7..000000000000
--- a/app-editors/elvis/files/ft2.3-symbol-collision-fix.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-diff -ur elvis-2.2_0-orig/guix11/tags elvis-2.2_0/guix11/tags
---- elvis-2.2_0-orig/guix11/tags 2003-10-20 19:32:26.000000000 -0700
-+++ elvis-2.2_0/guix11/tags 2007-08-17 12:56:28.000000000 -0700
-@@ -31,7 +31,7 @@
- DEFAULT_TOOLFG guix11.c 40;" d ln:40 file:
- DEFAULT_XENCODING guix11.c 48;" d ln:48 file:
- FT_DEFAULT xdialog.h 10;" ln:10 enum:X_FIELDTYPE
--FT_FILE xdialog.h 10;" ln:10 enum:X_FIELDTYPE
-+FT_FILEC xdialog.h 10;" ln:10 enum:X_FIELDTYPE
- FT_LOCKED xdialog.h 10;" ln:10 enum:X_FIELDTYPE
- FT_NUMBER xdialog.h 10;" ln:10 enum:X_FIELDTYPE
- FT_ONEOF xdialog.h 10;" ln:10 enum:X_FIELDTYPE
-diff -ur elvis-2.2_0-orig/guix11/xdialog.c elvis-2.2_0/guix11/xdialog.c
---- elvis-2.2_0-orig/guix11/xdialog.c 2003-10-20 19:32:26.000000000 -0700
-+++ elvis-2.2_0/guix11/xdialog.c 2007-08-17 12:56:28.000000000 -0700
-@@ -387,7 +387,7 @@
- case 'o': ft = FT_ONEOF, limit = scan; break;
- case 'n': ft = FT_NUMBER, limit = scan; break;
- case 's': ft = FT_STRING; break;
-- case 'f': ft = FT_FILE; break;
-+ case 'f': ft = FT_FILEC; break;
- case 'l': ft = FT_LOCKED; break;
- }
-
-@@ -556,7 +556,7 @@
- break;
-
- case FT_STRING:
-- case FT_FILE:
-+ case FT_FILEC:
- button = addbutton(dia, "<", 'l', ELVCTRL('L'));
- button->y = dia->y0 + dia->rowh * i;
- button->x = dia->x0 + 3;
-@@ -1111,7 +1111,7 @@
- newvalue = keystring(dia, key);
- break;
-
-- case FT_FILE:
-+ case FT_FILEC:
- #ifdef FEATURE_COMPLETE
- if (key == '\t')
- {
-@@ -1179,7 +1179,7 @@
- switch (dia->field[row].ft)
- {
- case FT_STRING:
-- case FT_FILE:
-+ case FT_FILEC:
- case FT_NUMBER:
- case FT_LOCKED:
- drawtext(dia, row);
-@@ -1207,7 +1207,7 @@
- break;
-
- case FT_STRING:
-- case FT_FILE:
-+ case FT_FILEC:
- if (button->shape == 'l')
- if (row == dia->current
- ? dia->shift > 0
-diff -ur elvis-2.2_0-orig/guix11/xdialog.h elvis-2.2_0/guix11/xdialog.h
---- elvis-2.2_0-orig/guix11/xdialog.h 2003-10-20 19:32:26.000000000 -0700
-+++ elvis-2.2_0/guix11/xdialog.h 2007-08-17 12:56:28.000000000 -0700
-@@ -5,7 +5,7 @@
- FT_ONEOF, /* one of a preset list; includes boolean */
- FT_NUMBER, /* numeric field */
- FT_STRING, /* string field */
-- FT_FILE, /* string field where <Tab> does filename completion */
-+ FT_FILEC, /* string field where <Tab> does filename completion */
- FT_LOCKED /* non-editable field */
- } X_FIELDTYPE;
- typedef struct
-
diff --git a/app-editors/elvis/metadata.xml b/app-editors/elvis/metadata.xml
deleted file mode 100644
index 6be55e0ac363..000000000000
--- a/app-editors/elvis/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>vim@gentoo.org</email>
- <name>Gentoo Vim Project</name>
-</maintainer>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 87010f9482ed..cf537116dd99 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -976,11 +976,6 @@ dev-ruby/hipchat
# release was 11 years ago. Removal in 30 days.
dev-ruby/iobuffer
-# Marek Szuba <marecki@gentoo.org> (2022-12-05)
-# No releases since 2003 (!), upstream effectively dead, no Unicode support,
-# EAPI 6. Removal in 30 days (#884429)
-app-editors/elvis
-
# Sam James <sam@gentoo.org> (2022-12-03)
# Dev channel releases are only for people who
# are developers or want more experimental features