summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-23 16:23:58 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-23 17:36:18 +0100
commitef313b95fd716343f17ca56fc419d68a4cd8e028 (patch)
treec8acf0798ec8a2c744e69815bdf5a5d8804b5df1
parentkde-apps/cantor: Drop unused Python3_EXECUTABLE cmakearg (diff)
downloadgentoo-ef313b95fd716343f17ca56fc419d68a4cd8e028.tar.gz
gentoo-ef313b95fd716343f17ca56fc419d68a4cd8e028.tar.bz2
gentoo-ef313b95fd716343f17ca56fc419d68a4cd8e028.zip
dev-python/botocore: Bump to 1.29.97
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.97.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index eeffbf643107..e2d2cf54434f 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.29.93.gh.tar.gz 11239506 BLAKE2B 7a05d5c611cbeda21e62abbbe13ab18
DIST botocore-1.29.94.gh.tar.gz 11242930 BLAKE2B d6abdda0ad69bfa635c2cdccefff5c0feaa27fb1a307d5cacb140ded35c246a52ebbe5657a9317bdc1441939d2bd62d5829b2ecce01c05976f56737f92fc3f62 SHA512 23c1fb835d492f414a0a67ac03e50ea31f6343676c7e6e8649067b11e3213f84eb068562fe5bd9a49ead9e37381ab132ac820d98fa4af805b41eaf53b0f9cb1b
DIST botocore-1.29.95.gh.tar.gz 11252473 BLAKE2B 500dfc60af5127b56d41fc8ffa2742b5a0086614e48517590c795ae51ea55936a621e4a88d27248a9c52dfb4fe99c716ac2b191329071b94c13078facf4b0967 SHA512 2efbff00cc696930bb71713ce18ad61449c2e79c0ede48218347e3c410a9ff9752c44a35dd03f45286c2f6e05b34e85bd8b01c0c9f92d877c9e2d0209b6cafe6
DIST botocore-1.29.96.gh.tar.gz 11257444 BLAKE2B 28cea7e2909a4c1f5a399633dbaa52b87fedc25f4c9cfc9f7c9a977dc84f86dcb3da9d1109b2c77e815bb5338337c850f260d9c2adc27d1f8bd529f087c2a299 SHA512 a6c414e275d7b31eed94175fd54142a909b8957685ab6779488704c905595f83c0bf376d5d37386266b103a3efde1a46f853ac7b1631056069903c0c57b55da2
+DIST botocore-1.29.97.gh.tar.gz 11258219 BLAKE2B 5bbbe250a80203d993ee2ad36770f839cbe6a086d63446f4b537c7015f686840726e15680762ece85869b676d51385c1302952ecd4a5607b2a07b9db1d0df9cc SHA512 0ef137c6a51546126000f5a7b8ff413d17d9684a36fdc7977b04cca090a757b76f1bd1cea02cd733eb4581c370cdd9214a033f7dc4766e02d2f1b5140c098e2a
diff --git a/dev-python/botocore/botocore-1.29.97.ebuild b/dev-python/botocore/botocore-1.29.97.ebuild
new file mode 100644
index 000000000000..0f4daaa48e81
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.97.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}