summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2019-12-09 16:54:27 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-12-10 19:25:27 +0200
commitef3e2ec193479555e539b84676bb79f2177b92a3 (patch)
tree0a62dd2e54b22ab0222fbaf1195819b8edef1cb2
parentwww-client/qutebrowser: Add version bump 1.8.1 (diff)
downloadgentoo-ef3e2ec193479555e539b84676bb79f2177b92a3.tar.gz
gentoo-ef3e2ec193479555e539b84676bb79f2177b92a3.tar.bz2
gentoo-ef3e2ec193479555e539b84676bb79f2177b92a3.zip
www-client/qutebrowser: Bump 9999
Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index 9808d790b8a3..4786a63c56fb 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{3_5,3_6} )
+EAPI=7
-inherit distutils-r1 eutils gnome2-utils xdg-utils
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+
+inherit distutils-r1 eutils xdg-utils
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
@@ -21,11 +22,11 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="scripts test"
-COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${COMMON_DEPEND}
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="
app-text/asciidoc
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="
dev-python/attrs[${PYTHON_USEDEP}]
>=dev-python/jinja-2.8[${PYTHON_USEDEP}]
>=dev-python/pygments-2.1.3[${PYTHON_USEDEP}]
@@ -44,7 +45,7 @@ RESTRICT="test"
python_compile_all() {
if [[ ${PV} == "9999" ]]; then
- "${PYTHON}" scripts/asciidoc2html.py || die "Failed generating docs"
+ "${EPYTHON}" scripts/asciidoc2html.py || die "Failed generating docs"
fi
a2x -f manpage doc/${PN}.1.asciidoc || die "Failed generating man page"