summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-05-23 17:46:56 +0200
committerJeroen Roovers <jer@gentoo.org>2017-05-23 17:48:16 +0200
commitef605e06c7725c8c9cd7513f430098ac46de6c11 (patch)
treed454b39159b7b3ec3c20615f39759453615a5131
parentdev-python/paver: remove old (diff)
downloadgentoo-ef605e06c7725c8c9cd7513f430098ac46de6c11.tar.gz
gentoo-ef605e06c7725c8c9cd7513f430098ac46de6c11.tar.bz2
gentoo-ef605e06c7725c8c9cd7513f430098ac46de6c11.zip
app-text/pinfo: Add clearfilenameprefix patch by Sophie Hamilton (bug #619452).
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--app-text/pinfo/files/pinfo-0.6.10-clearfilenameprefix.patch10
-rw-r--r--app-text/pinfo/pinfo-0.6.10-r6.ebuild57
2 files changed, 67 insertions, 0 deletions
diff --git a/app-text/pinfo/files/pinfo-0.6.10-clearfilenameprefix.patch b/app-text/pinfo/files/pinfo-0.6.10-clearfilenameprefix.patch
new file mode 100644
index 000000000000..0835d166932e
--- /dev/null
+++ b/app-text/pinfo/files/pinfo-0.6.10-clearfilenameprefix.patch
@@ -0,0 +1,10 @@
+--- a/src/filehandling_functions.c
++++ b/src/filehandling_functions.c
+@@ -758,6 +758,7 @@
+ tmpfilename = tmpfilename2; /* later we will refere only to tmp2 */
+ }
+
++ clearfilenameprefix();
+ for (i = -1; i < infopathcount; i++) /* go through all paths */
+ {
+ if (i == -1)
diff --git a/app-text/pinfo/pinfo-0.6.10-r6.ebuild b/app-text/pinfo/pinfo-0.6.10-r6.ebuild
new file mode 100644
index 000000000000..eaf6c3d4fb5d
--- /dev/null
+++ b/app-text/pinfo/pinfo-0.6.10-r6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Hypertext info and man viewer based on (n)curses"
+HOMEPAGE="http://pinfo.alioth.debian.org/"
+SRC_URI="https://alioth.debian.org/frs/download.php/3351/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls readline"
+
+RDEPEND="sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ nls? ( virtual/libintl )
+"
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bison
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.9-as-needed.patch
+ "${FILESDIR}"/${PN}-0.6.9-GROFF_NO_SGR.patch
+ "${FILESDIR}"/${PN}-0.6.9-lzma-xz.patch
+ "${FILESDIR}"/${PN}-0.6.10-version.patch
+ "${FILESDIR}"/${PN}-0.6.10-info-suffix.patch
+ "${FILESDIR}"/${PN}-0.6.10-dir-file.patch
+ "${FILESDIR}"/${PN}-0.6.10-tinfo.patch
+ "${FILESDIR}"/${PN}-0.6.10-gettext-0.19.patch
+ "${FILESDIR}"/${PN}-0.6.10-ncurses-check.patch
+ "${FILESDIR}"/${PN}-0.6.10-libc-basename.patch
+ "${FILESDIR}"/${PN}-0.6.10-clearfilenameprefix.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ append-cflags -D_BSD_SOURCE -D_DEFAULT_SOURCE # sbrk()
+}
+
+src_configure() {
+ econf \
+ $(use_with readline) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" sysconfdir=/etc install
+}