summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-14 07:31:11 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-14 08:05:17 +0200
commitf001f48dfa5028e939b51260935e4e96fc3a5bb2 (patch)
tree9e3fb5b2bb0aefdee90eb24e4d63428c032a0d3f
parentdev-python/sqlglot: Bump to 25.11.2 (diff)
downloadgentoo-f001f48dfa5028e939b51260935e4e96fc3a5bb2.tar.gz
gentoo-f001f48dfa5028e939b51260935e4e96fc3a5bb2.tar.bz2
gentoo-f001f48dfa5028e939b51260935e4e96fc3a5bb2.zip
dev-python/tomlkit: Bump to 0.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.13.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 9f8a9784db1e..4aa0a70c607c 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1 +1,2 @@
DIST tomlkit-0.13.0.tar.gz 191792 BLAKE2B f5f865b49f9850281d01de2c2ba9c2d8685a10a5cd0f17c475d120978472485a5bd607dc4b283221eab69fc6e214259feafdbe85c8237fe9c80b49007523bb69 SHA512 46c5a771ff401e0b300dbd13708d78b63415653b87eb649898bf0bd58cedeb110622ff2f0ade0ad1cd517610229ba0f59b4d520cf2fa1eea6522ea0bc042317e
+DIST tomlkit-0.13.1.tar.gz 192625 BLAKE2B 1f1ebc96819eb742429d7d8a71b8f3aecdd964f0700052bb2f71ede866c5f97b25745bf95898d7b1005c881d3fdbb36c4cb872126a3be8192cb9c859eb153fbe SHA512 32023020de48d0eacd0ce886870b9a53defdb403b396eb03d0c026c221460eeede1f018586ae141d690722485446be0215582182809c590d1af9825e840b58ad
diff --git a/dev-python/tomlkit/tomlkit-0.13.1.ebuild b/dev-python/tomlkit/tomlkit-0.13.1.ebuild
new file mode 100644
index 000000000000..32ec3c8a18ae
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.13.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/python-poetry/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "poetry' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "tomlkit"
+ version = "${PV}"
+ description = "Style preserving TOML library"
+ EOF
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}