summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2023-06-10 14:10:18 +0200
committerSam James <sam@gentoo.org>2023-06-10 14:43:29 +0100
commitf032c51b6f880a6d3fb6e8070cd8e922d4f66b8d (patch)
tree123b0cf36b80447b87a3c6bf131bb812a530ced7
parentnet-im/telegram-desktop: Drop old (diff)
downloadgentoo-f032c51b6f880a6d3fb6e8070cd8e922d4f66b8d.tar.gz
gentoo-f032c51b6f880a6d3fb6e8070cd8e922d4f66b8d.tar.bz2
gentoo-f032c51b6f880a6d3fb6e8070cd8e922d4f66b8d.zip
net-im/telegram-desktop: Bump to 4.8.3
A very """minor""" upgrade, user-interface wise, but an annoying one from the packaging side of things. A new dependency to cppgir appeared, with no regards to packaging. This applies to cppgir itself as well, as it bundles another library. Dropped keywords, will need to be re-instated as the new dependencies gain support for additional architectures. D-Bus support was dropped: https://github.com/telegramdesktop/tdesktop/commit/0a011db483eaaf4f9eec33c6af77d3bdf049c816 (I don't wish to go against this flow and re-introduce glib support without dbus) Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31373 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-im/telegram-desktop/Manifest1
-rw-r--r--net-im/telegram-desktop/files/tdesktop-4.8.3-fix-clang.patch52
-rw-r--r--net-im/telegram-desktop/files/tdesktop-4.8.3-system-cppgir.patch50
-rw-r--r--net-im/telegram-desktop/telegram-desktop-4.8.3.ebuild210
4 files changed, 313 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index e4b269dc8954..644debcd4e0b 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -1 +1,2 @@
DIST tdesktop-4.8.1-full.tar.gz 63997319 BLAKE2B daac461f0b3205bf647027329660b43f4646db987e27bfe2a2848bfbfb3309c503132d1533f26e95512520417d30f5063b1c395b174787aa7533727549ee77e5 SHA512 4dc495e4502bdba634c4468af4f1321aef1152d619c811f004489f8616504a465069508239eae41a08a83e190a61d26881733ebc38dd88160f81dce070bb0567
+DIST tdesktop-4.8.3-full.tar.gz 64351425 BLAKE2B b2f18abee66364f9075dc9a924221092b511d092f755ebf44705efdc96b2cbfe71b77a1a375624fa48e072f2b3f9bd19795b456c5f03f236b164dba35febacf9 SHA512 11fdd39319d1fdae07094d0ab2cb919355015bee14567d88daf98f9e5332bfee7a938415800397e6f24224e97f6425fe0a1d7549d7de14b63f84ab7cb7741872
diff --git a/net-im/telegram-desktop/files/tdesktop-4.8.3-fix-clang.patch b/net-im/telegram-desktop/files/tdesktop-4.8.3-fix-clang.patch
new file mode 100644
index 000000000000..5135c3c5ef4b
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-4.8.3-fix-clang.patch
@@ -0,0 +1,52 @@
+Fix build issues with clang
+
+/var/tmp/portage/net-im/telegram-desktop-4.8.3/work/tdesktop-4.8.3-full/Telegram/lib_base/base/platform/linux/base_system_media_controls_linux.cpp:198:4: error: reference to 'GObject' is ambiguous
+ GObject::Object,
+ ^
+/usr/include/glib-2.0/gobject/gobject.h:192:42: note: candidate found by name lookup is 'GObject'
+typedef struct _GObject GObject;
+ ^
+/var/tmp/portage/net-im/telegram-desktop-4.8.3/work/tdesktop-4.8.3-full_build/gen/gobject/_functions_impl.hpp:10:11: note: candidate found by name lookup is 'gi::repository::GObject'
+namespace GObject {
+ ^
+--- tdesktop-4.8.3-full.orig/Telegram/lib_base/base/platform/linux/base_system_media_controls_linux.cpp
++++ tdesktop-4.8.3-full/Telegram/lib_base/base/platform/linux/base_system_media_controls_linux.cpp
+@@ -195,7 +195,7 @@
+ player().set_loop_status("None");
+ player().set_rate(1.0);
+ const auto executeCommand = [=](
+- GObject::Object,
++ gi::repository::GObject::Object,
+ Gio::DBusMethodInvocation invocation) {
+ base::Integration::Instance().enterFromEventLoop([&] {
+ _commandRequests.fire_copy(
+@@ -232,23 +232,23 @@
+ return true;
+ });
+ player().property_loop_status().signal_notify().connect([=](
+- GObject::Object,
+- GObject::ParamSpec) {
++ gi::repository::GObject::Object,
++ gi::repository::GObject::ParamSpec) {
+ base::Integration::Instance().enterFromEventLoop([&] {
+ _commandRequests.fire_copy(
+ LoopStatusToCommand(player().get_loop_status()));
+ });
+ });
+ player().property_shuffle().signal_notify().connect([=](
+- GObject::Object,
+- GObject::ParamSpec) {
++ gi::repository::GObject::Object,
++ gi::repository::GObject::ParamSpec) {
+ base::Integration::Instance().enterFromEventLoop([&] {
+ _commandRequests.fire_copy(Command::Shuffle);
+ });
+ });
+ player().property_volume().signal_notify().connect([=](
+- GObject::Object,
+- GObject::ParamSpec) {
++ gi::repository::GObject::Object,
++ gi::repository::GObject::ParamSpec) {
+ base::Integration::Instance().enterFromEventLoop([&] {
+ _volumeChangeRequests.fire_copy(player().get_volume());
+ });
diff --git a/net-im/telegram-desktop/files/tdesktop-4.8.3-system-cppgir.patch b/net-im/telegram-desktop/files/tdesktop-4.8.3-system-cppgir.patch
new file mode 100644
index 000000000000..54c79b3e5a0c
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-4.8.3-system-cppgir.patch
@@ -0,0 +1,50 @@
+Use system cppgir
+
+--- tdesktop-4.8.3-full.orig/cmake/external/glib/CMakeLists.txt
++++ tdesktop-4.8.3-full/cmake/external/glib/CMakeLists.txt
+@@ -7,14 +7,6 @@
+ add_library(external_glib INTERFACE IMPORTED GLOBAL)
+ add_library(desktop-app::external_glib ALIAS external_glib)
+
+-function(add_cppgir) # isolate scope
+- set(BUILD_TESTING OFF)
+- set(BUILD_DOC OFF)
+- set(CMAKE_DISABLE_FIND_PACKAGE_Qt5Core ON)
+- add_subdirectory(cppgir)
+-endfunction()
+-add_cppgir()
+-
+ include(generate_cppgir.cmake)
+ generate_cppgir(external_glib Gio-2.0)
+
+--- tdesktop-4.8.3-full.orig/cmake/external/glib/generate_cppgir.cmake
++++ tdesktop-4.8.3-full/cmake/external/glib/generate_cppgir.cmake
+@@ -4,6 +4,8 @@
+ # For license and copyright information please follow this link:
+ # https://github.com/desktop-app/legal/blob/master/LEGAL
+
++find_package(CppGir REQUIRED)
++
+ function(generate_cppgir target_name gir)
+ # cppgir generates all the dependent headers everytime, better to have a global folder
+ set(gen_dst ${CMAKE_BINARY_DIR}/gen)
+@@ -32,17 +34,16 @@
+ echo 1> ${gen_timestamp}
+ COMMENT "Generating C++ wrapper for ${gir} (${target_name})"
+ DEPENDS
+- cppgir
+ ${gir_path}
+ )
+ generate_target(${target_name} cppgir ${gen_timestamp} "" ${gen_dst})
+
+ get_target_property(target_type ${target_name} TYPE)
+ if (${target_type} STREQUAL "INTERFACE_LIBRARY")
+- target_link_libraries(${target_name} INTERFACE gi)
++ target_link_libraries(${target_name} INTERFACE CppGir::gi)
+ target_compile_definitions(${target_name} INTERFACE GI_INLINE GI_OBJECT_NEWV)
+ else()
+- target_link_libraries(${target_name} PUBLIC gi)
++ target_link_libraries(${target_name} PUBLIC CppGir::gi)
+ target_compile_definitions(${target_name} PUBLIC GI_INLINE GI_OBJECT_NEWV)
+ endif()
+ endfunction()
diff --git a/net-im/telegram-desktop/telegram-desktop-4.8.3.ebuild b/net-im/telegram-desktop/telegram-desktop-4.8.3.ebuild
new file mode 100644
index 000000000000..4060dde670a2
--- /dev/null
+++ b/net-im/telegram-desktop/telegram-desktop-4.8.3.ebuild
@@ -0,0 +1,210 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit xdg cmake python-any-r1 optfeature flag-o-matic
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org"
+
+MY_P="tdesktop-${PV}-full"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD GPL-3-with-openssl-exception LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="enchant +fonts +jemalloc screencast qt6 qt6-imageformats wayland +X"
+REQUIRED_USE="
+ qt6-imageformats? ( qt6 )
+"
+
+KIMAGEFORMATS_RDEPEND="
+ media-libs/libavif:=
+ media-libs/libheif:=
+ media-libs/libjxl
+"
+RDEPEND="
+ !net-im/telegram-desktop-bin
+ app-arch/lz4:=
+ dev-cpp/abseil-cpp:=
+ >=dev-cpp/glibmm-2.76:2.68
+ dev-libs/glib:2
+ dev-libs/libdispatch
+ dev-libs/libsigc++:2
+ dev-libs/openssl:=
+ dev-libs/protobuf
+ dev-libs/xxhash
+ media-libs/fontconfig:=
+ media-libs/libjpeg-turbo:=
+ ~media-libs/libtgvoip-2.4.4_p20221208
+ media-libs/openal
+ media-libs/opus:=
+ media-libs/rnnoise
+ ~media-libs/tg_owt-0_pre20230428:=[screencast=,X=]
+ media-video/ffmpeg:=[opus,vpx]
+ sys-libs/zlib:=[minizip]
+ virtual/opengl
+ !enchant? ( >=app-text/hunspell-1.7:= )
+ enchant? ( app-text/enchant:= )
+ jemalloc? ( dev-libs/jemalloc:=[-lazy-lock] )
+ !qt6? (
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5[dbus,jpeg,png,wayland?,X?]
+ >=dev-qt/qtimageformats-5.15:5
+ >=dev-qt/qtnetwork-5.15:5[ssl]
+ >=dev-qt/qtsvg-5.15:5
+ >=dev-qt/qtwidgets-5.15:5[png,X?]
+ kde-frameworks/kcoreaddons:=
+ )
+ qt6? (
+ dev-qt/qtbase:6[dbus,gui,network,opengl,widgets,X?]
+ dev-qt/qtimageformats:6
+ dev-qt/qtsvg:6
+ wayland? ( dev-qt/qtwayland:6 )
+ qt6-imageformats? ( ${KIMAGEFORMATS_RDEPEND} )
+ )
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-keysyms
+ )
+"
+DEPEND="${RDEPEND}
+ dev-cpp/cppgir
+ >=dev-cpp/ms-gsl-4
+ dev-cpp/range-v3
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-cpp/cppgir
+ >=dev-util/cmake-3.16
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+"
+# dev-libs/jemalloc:=[-lazy-lock] -> https://bugs.gentoo.org/803233
+
+PATCHES=(
+ "${FILESDIR}/tdesktop-4.2.4-jemalloc-only-telegram-r1.patch"
+ "${FILESDIR}/tdesktop-4.4.1-fix-dupe-main-decl.patch"
+ "${FILESDIR}/tdesktop-4.8.3-system-cppgir.patch"
+ "${FILESDIR}/tdesktop-4.8.3-fix-clang.patch"
+)
+
+# Current desktop-file-utils-0.26 does not understand Version=1.5
+QA_DESKTOP_FILE="usr/share/applications/${PN}.desktop"
+
+pkg_pretend() {
+ if has ccache ${FEATURES}; then
+ ewarn "ccache does not work with ${PN} out of the box"
+ ewarn "due to usage of precompiled headers"
+ ewarn "check bug https://bugs.gentoo.org/715114 for more info"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ # Bundle kde-frameworks/kimageformats for qt6, since it's impossible to
+ # build in gentoo right now.
+ if use qt6-imageformats; then
+ sed -e 's/DESKTOP_APP_USE_PACKAGED_LAZY/TRUE/' -i \
+ cmake/external/kimageformats/CMakeLists.txt || die
+ printf '%s\n' \
+ 'Q_IMPORT_PLUGIN(QAVIFPlugin)' \
+ 'Q_IMPORT_PLUGIN(HEIFPlugin)' \
+ 'Q_IMPORT_PLUGIN(QJpegXLPlugin)' \
+ >> cmake/external/qt/qt_static_plugins/qt_static_plugins.cpp || die
+ fi
+
+ # kde-frameworks/kcoreaddons is bundled when using qt6, see:
+ # cmake/external/kcoreaddons/CMakeLists.txt
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # The ABI of media-libs/tg_owt breaks if the -DNDEBUG flag doesn't keep
+ # the same state across both projects.
+ # See https://bugs.gentoo.org/866055
+ append-cppflags '-DNDEBUG'
+
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_tl-expected=ON # header only lib, some git version. prevents warnings.
+ -DQT_VERSION_MAJOR=$(usex qt6 6 5)
+
+ -DDESKTOP_APP_DISABLE_X11_INTEGRATION=$(usex !X)
+ -DDESKTOP_APP_DISABLE_WAYLAND_INTEGRATION=$(usex !wayland)
+ -DDESKTOP_APP_DISABLE_JEMALLOC=$(usex !jemalloc)
+ -DDESKTOP_APP_USE_ENCHANT=$(usex enchant) # enables enchant and disables hunspell
+ -DDESKTOP_APP_USE_PACKAGED_FONTS=$(usex !fonts) # use system fonts instead of bundled ones
+ )
+
+ if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+ einfo "Found custom API credentials"
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+ -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+ )
+ else
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+ # Building with snapcraft API credentials by default
+ # Custom API credentials can be obtained here:
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+ # After getting credentials you can export variables:
+ # export MY_TDESKTOP_API_ID="17349""
+ # export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+ # and restart the build"
+ # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+ # portage will use custom variable every build automatically
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="611335"
+ -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if ! use X && ! use screencast; then
+ ewarn "both the 'X' and 'screencast' USE flags are disabled, screen sharing won't work!"
+ ewarn
+ fi
+ if has_version '<dev-qt/qtcore-5.15.2-r10'; then
+ ewarn "Versions of dev-qt/qtcore lower than 5.15.2-r10 might cause telegram"
+ ewarn "to crash when pasting big images from the clipboard."
+ ewarn
+ fi
+ if ! use jemalloc && use elibc_glibc; then
+ # https://github.com/telegramdesktop/tdesktop/issues/16084
+ # https://github.com/desktop-app/cmake_helpers/pull/91#issuecomment-881788003
+ ewarn "Disabling USE=jemalloc on glibc systems may cause very high RAM usage!"
+ ewarn "Do NOT report issues about RAM usage without enabling this flag first."
+ ewarn
+ fi
+ if use qt6; then
+ ewarn "Qt6 support in gentoo is experimental."
+ ewarn "Please report any issues you may find, but don't expect"
+ ewarn "everything to work correctly as of yet."
+ ewarn
+ fi
+ if use wayland && ! use qt6; then
+ ewarn "Wayland-specific integrations have been deprecated with Qt5."
+ ewarn "The app will continue to function under wayland, but some"
+ ewarn "functionality may be reduced."
+ ewarn "These integrations are only supported when built with Qt6."
+ ewarn
+ fi
+ if use qt6 && ! use qt6-imageformats; then
+ elog "Enable USE=qt6-imageformats for AVIF, HEIF and JpegXL support"
+ elog
+ fi
+ optfeature_header
+ optfeature "shop payment support" net-libs/webkit-gtk:4
+ if ! use qt6; then
+ optfeature "AVIF, HEIF and JpegXL image support" kde-frameworks/kimageformats[avif,heif,jpegxl]
+ fi
+}