summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 17:44:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-02 22:16:13 +0100
commitf0341a3d4609a11915f0a658fe9f1792b2742bcf (patch)
treed5c7ec3c88c2c0c34b608b517ffef42e14c17483
parentsys-libs/libomp: Bump to 13.0.1 (diff)
downloadgentoo-f0341a3d4609a11915f0a658fe9f1792b2742bcf.tar.gz
gentoo-f0341a3d4609a11915f0a658fe9f1792b2742bcf.tar.bz2
gentoo-f0341a3d4609a11915f0a658fe9f1792b2742bcf.zip
sys-devel/clang-runtime: Bump to 13.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/clang-runtime/clang-runtime-13.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-13.0.1.ebuild b/sys-devel/clang-runtime/clang-runtime-13.0.1.ebuild
new file mode 100644
index 000000000000..8c8c806b5517
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-13.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"