summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-03-15 08:24:05 +0100
committerTupone Alfredo <tupone@gentoo.org>2019-03-15 08:24:59 +0100
commitf0437170eb42e30839073788456e18d5e695665b (patch)
tree3e8bc38f1023651f9002ab6117912f78c9bcc400
parentapp-admin/pwgen: stable 2.08 for sparc, bug #674636 (diff)
downloadgentoo-f0437170eb42e30839073788456e18d5e695665b.tar.gz
gentoo-f0437170eb42e30839073788456e18d5e695665b.tar.bz2
gentoo-f0437170eb42e30839073788456e18d5e695665b.zip
sci-mathematics/why3-for-spark: use virtual/emacs on dependency
Closes: https://bugs.gentoo.org/680312 Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--sci-mathematics/why3-for-spark/Manifest1
-rw-r--r--sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild83
-rw-r--r--sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild4
3 files changed, 2 insertions, 86 deletions
diff --git a/sci-mathematics/why3-for-spark/Manifest b/sci-mathematics/why3-for-spark/Manifest
index e6505ed60c75..8f9c5c3c62dc 100644
--- a/sci-mathematics/why3-for-spark/Manifest
+++ b/sci-mathematics/why3-for-spark/Manifest
@@ -1,2 +1 @@
-DIST why3-for-spark-gpl-2017-src.tar.gz 9248235 BLAKE2B d9eb7201dfd5962c88ac8995e3cd800bf318f575a5e6ff7d0219941c0f0c9052e6b2c95c7c16fcd81b90cac647d503041bf16560bd44b58e7e0ced1ef2314bd2 SHA512 8f444402f6c1744cd7c565117732935791b1ae7996a94314c40a66d125eae8a81f2257314246c94fd29d3cd16abcff6a50a152a1191a4aae39a2c8a8d7c3b9e1
DIST why3-for-spark-gpl-2018-src.tar.gz 7682767 BLAKE2B 0b0272ca4d5519ca402990b234d0847378bcd2a0949fea78ea10e355233a16aebe79b938cdf8e4daadabb909171cab83b9d6ccacf9f2dc1c0b57bb6da6fd1fe0 SHA512 fc798acf343484fd8e70f470a318753c9a0e9967ff579f20ec185bf3c2a75e7a4a556388fc86a378610ce4a467f3e722c6f610da34d4c33bc3d6b10551731f07
diff --git a/sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild b/sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild
deleted file mode 100644
index d7e68eab3720..000000000000
--- a/sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-MYP=${PN}-gpl-${PV}-src
-
-DESCRIPTION="Platform for deductive program verification"
-HOMEPAGE="http://why3.lri.fr/"
-SRC_URI="http://mirrors.cdn.adacore.com/art/591c45e2c7a447af2deed055
- -> ${MYP}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="coq doc emacs gtk html hypothesis-selection +ocamlopt profiling zarith zip"
-RESTRICT=strip
-
-DEPEND=">=dev-lang/ocaml-4.02.3[ocamlopt?]
- dev-ml/menhir
- coq? ( sci-mathematics/coq )
- doc? ( dev-tex/rubber )
- gtk? ( dev-ml/lablgtk[sourceview] )
- emacs? ( app-editors/emacs:* )
- html? ( dev-tex/hevea )
- hypothesis-selection? ( dev-ml/ocamlgraph )
- zarith? ( dev-ml/zarith )
- zip? ( >=dev-ml/camlzip-1.07 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"/${MYP}
-
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-
-REQUIRED_USE="html? ( doc )"
-
-src_prepare() {
- mv configure.{in,ac} || die
- sed -i \
- -e "s:configure.in:configure.ac:g" \
- Makefile.in
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-pvs-libs \
- --disable-isabelle-libs \
- $(use_enable coq coq-libs) \
- $(use_enable coq coq-tactic) \
- $(use_enable doc) \
- $(use_enable emacs emacs-compilation) \
- $(use_enable gtk ide) \
- $(use_enable html html-doc) \
- $(use_enable hypothesis-selection) \
- $(use_enable ocamlopt native-code) \
- $(use_enable profiling) \
- $(use_enable zarith) \
- $(use_enable zip)
-}
-
-src_compile() {
- default
- if use ocamlopt; then
- emake byte
- fi
- use doc && emake doc
-}
-
-src_install() {
- default
- emake DESTDIR="${D}" install-lib
- emake DESTDIR="${D}" install_spark2014_dev
- docompress -x /usr/share/doc/${PF}/examples
- dodoc -r examples
- if use doc; then
- dodoc doc/manual.pdf
- use html && dodoc -r doc/html
- fi
-}
diff --git a/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild b/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild
index da20dbb96af0..5400b37276c2 100644
--- a/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild
+++ b/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,7 +23,7 @@ DEPEND=">=dev-lang/ocaml-4.02.3[ocamlopt?]
coq? ( sci-mathematics/coq )
doc? ( dev-tex/rubber )
gtk? ( dev-ml/lablgtk[sourceview] )
- emacs? ( app-editors/emacs:* )
+ emacs? ( virtual/emacs )
html? ( dev-tex/hevea )
hypothesis-selection? ( dev-ml/ocamlgraph )
zarith? ( dev-ml/zarith )