summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-07-24 15:32:11 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-24 15:32:11 +0200
commitf04bcdc9c6ae99ace221937067fd4206a36ea310 (patch)
tree9171d071ba072956ff8994c58ee09f3c65422787
parentapp-shells/zsh: Bumped live ebuild to EAPI-7 (diff)
downloadgentoo-f04bcdc9c6ae99ace221937067fd4206a36ea310.tar.gz
gentoo-f04bcdc9c6ae99ace221937067fd4206a36ea310.tar.bz2
gentoo-f04bcdc9c6ae99ace221937067fd4206a36ea310.zip
sys-cluster/minikube: Version bump to 0.28.2
Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--sys-cluster/minikube/Manifest1
-rw-r--r--sys-cluster/minikube/minikube-0.28.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-cluster/minikube/Manifest b/sys-cluster/minikube/Manifest
index afb2ecb1d5ed..89445bfe2f92 100644
--- a/sys-cluster/minikube/Manifest
+++ b/sys-cluster/minikube/Manifest
@@ -1,2 +1,3 @@
DIST minikube-0.28.0.tar.gz 20350636 BLAKE2B 002bf7a45483a724d9ebc4f2fa3bad5b9451d9d550211e3e93f8b75555a39358fe11798d0c4b1632c3235ee21e82adc18c9b2f6f4ba9590eb998901f870b7d52 SHA512 bbcc8540b9d64a0ac9da93f912d44c66991d8377fdb96b02a656a8919347b4dd40669c08850582ea54adce6b1ef132c41376f21f4e3cc07e5776df9a3286f4e7
DIST minikube-0.28.1.tar.gz 20075323 BLAKE2B 47444de4c2245d13108b5f98544f5127565ab40178f0bfdda35f710d594b36f8d98dbde8157361172a3486411f7ce32689e87d6b126ba29d21c9061dd0b22fa9 SHA512 80591777cc419ac9dc3b27d444a5d8aa04f2482bd3c47edfbb6b8a74b3552610125dfc5244bbd2659ea46600ed17577e90bcf98e0806d12932dd88c46fd0283a
+DIST minikube-0.28.2.tar.gz 20077130 BLAKE2B 0d8047debc0ce633fe6696d760e838d5ade80128d319e66b19c6f34e34ff95a401102c5c177a4e9de9f2a46f9dbf97de675137881f84849002814f94f14d40d7 SHA512 ee2a08a7b6fa4d18c4c04fc51ac17eb0b8bc8e092c489db53bf2734c45afac919735d046a07a7b8af6a8ef41c97fcb87124409081751da9134cfe032ca86aacb
diff --git a/sys-cluster/minikube/minikube-0.28.2.ebuild b/sys-cluster/minikube/minikube-0.28.2.ebuild
new file mode 100644
index 000000000000..bf8d0dce0d11
--- /dev/null
+++ b/sys-cluster/minikube/minikube-0.28.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-any-r1 golang-build golang-vcs-snapshot
+
+EGO_PN="k8s.io/minikube"
+ARCHIVE_URI="https://github.com/kubernetes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Single Node Kubernetes Cluster"
+HOMEPAGE="https://github.com/kubernetes/minikube https://kubernetes.io"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened libvirt"
+
+DEPEND="dev-go/go-bindata
+ ${PYTHON_DEPS}
+ libvirt? ( app-emulation/libvirt[qemu] )"
+RDEPEND=">=sys-cluster/kubectl-1.10.0"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i -e 's/ -s -w/ -w/' -e 's#.*GOBIN=$(GOPATH)/bin go get github.com/jteeuwen/go-bindata/...##' -e 's#$(GOPATH)/bin/go-bindata#/usr/bin/go-bindata#g' src/${EGO_PN}/Makefile || die
+ sed -i -e "s/get_commit(), get_tree_state(), get_version()/get_commit(), 'gitTreeState=clean', get_version()/" src/${EGO_PN}/hack/get_k8s_version.py || die
+}
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -C src/${EGO_PN} $(usex libvirt "out/docker-machine-driver-kvm2" "") out/localkube out/minikube-linux-amd64
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ newbin out/minikube-linux-amd64 minikube
+ dobin $(usex libvirt "out/docker-machine-driver-kvm2" "") out/localkube
+ dodoc -r docs CHANGELOG.md README.md
+ popd || die
+}
+
+pkg_postinst() {
+ elog "You may want to install the following optional dependency:"
+ elog " app-emulation/virtualbox or app-emulation/virtualbox-bin"
+}