summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-20 05:21:23 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-20 05:50:01 +0100
commitf0e5e6266511cbd70a6ececfb63aefc4a6f149a8 (patch)
tree4652c9513ea8da4a0e6904adf43e0127366dc266
parentdev-python/jaraco-context: Bump to 4.3.0 (diff)
downloadgentoo-f0e5e6266511cbd70a6ececfb63aefc4a6f149a8.tar.gz
gentoo-f0e5e6266511cbd70a6ececfb63aefc4a6f149a8.tar.bz2
gentoo-f0e5e6266511cbd70a6ececfb63aefc4a6f149a8.zip
dev-python/pyproject-fmt: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyproject-fmt/Manifest1
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-0.5.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index 1c7d4ed5f497..332e97e549a7 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -1 +1,2 @@
DIST pyproject-fmt-0.4.1.gh.tar.gz 14853 BLAKE2B e06e3602290fdc4df00fb48dfe9d6d516a623ef29eaa535ab3b11754a577385611313172f207966b121f072a5b453774afcbf5e8699a0b7fd4426f5332e48e5a SHA512 f00999470e66e7f11e9299a902b686342fbad27a07634206011ff7712c7c422f9962d8a4eeffae6a6263712620b787bbdcd78c2129cb4b164631b56a45910363
+DIST pyproject-fmt-0.5.0.gh.tar.gz 14906 BLAKE2B f75482988c8e10fbfcffaa518e6004f0e96b922e8bf929e43c7be26cf16149b3fa97a3070fabfbb90641ee3d953ab17bd854ba2e107b776f65f6bc802980bd54 SHA512 58ec7975f7c69990b1d2a0ee8a29681731d7143e59754343dc64e52e135cc5d280adf3c31b6818f042982697a7221a36aa0842ffba1ede28b57cefad77bf065c
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-0.5.0.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-0.5.0.ebuild
new file mode 100644
index 000000000000..9c67644e9961
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-0.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+SRC_URI="
+ https://github.com/tox-dev/pyproject-fmt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.8.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}