summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-19 02:52:51 +0100
committerSam James <sam@gentoo.org>2021-08-19 03:00:46 +0100
commitf0f6de3c704ea0849ed8b41e1cf7d7222ccb6193 (patch)
treeb50a6e6e8165f3130e5b5f9616a9df43dc7f3f37
parentnet-analyzer/nagios-core: remove "unused" nagios-core-4.4.6.ebuild. (diff)
downloadgentoo-f0f6de3c704ea0849ed8b41e1cf7d7222ccb6193.tar.gz
gentoo-f0f6de3c704ea0849ed8b41e1cf7d7222ccb6193.tar.bz2
gentoo-f0f6de3c704ea0849ed8b41e1cf7d7222ccb6193.zip
games-strategy/s25rttr: fix build with Boost 1.77
Closes: https://bugs.gentoo.org/808767 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-strategy/s25rttr/files/s25rttr-0.9.0_pre20200723-boost-1.77-missing-include.patch17
-rw-r--r--games-strategy/s25rttr/s25rttr-0.9.0_pre20200723-r100.ebuild3
2 files changed, 20 insertions, 0 deletions
diff --git a/games-strategy/s25rttr/files/s25rttr-0.9.0_pre20200723-boost-1.77-missing-include.patch b/games-strategy/s25rttr/files/s25rttr-0.9.0_pre20200723-boost-1.77-missing-include.patch
new file mode 100644
index 000000000000..9a69797ea27a
--- /dev/null
+++ b/games-strategy/s25rttr/files/s25rttr-0.9.0_pre20200723-boost-1.77-missing-include.patch
@@ -0,0 +1,17 @@
+https://github.com/Return-To-The-Roots/s25client/pull/1431
+
+From: Sam James <sam@gentoo.org>
+Date: Thu, 19 Aug 2021 02:41:42 +0100
+Subject: [PATCH] Fix build with Boost 1.77 (missing <algorithm> include)
+
+Closes: https://bugs.gentoo.org/808767
+--- a/libs/s25main/convertSounds.cpp
++++ b/libs/s25main/convertSounds.cpp
+@@ -20,6 +20,7 @@
+ #include <libsiedler2/ArchivItem_Sound_Wave.h>
+ #include <libsiedler2/loadMapping.h>
+ #include <s25util/StringConversion.h>
++#include <algorithm>
+ #include <cmath>
+ #include <samplerate.hpp>
+ #include <sstream>
diff --git a/games-strategy/s25rttr/s25rttr-0.9.0_pre20200723-r100.ebuild b/games-strategy/s25rttr/s25rttr-0.9.0_pre20200723-r100.ebuild
index dc54ef2deafe..f15c62bc0c1d 100644
--- a/games-strategy/s25rttr/s25rttr-0.9.0_pre20200723-r100.ebuild
+++ b/games-strategy/s25rttr/s25rttr-0.9.0_pre20200723-r100.ebuild
@@ -60,6 +60,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.9.0_pre20200723-cmake_lua_version.patch
"${FILESDIR}"/${P}-gcc11-include.patch
+ "${FILESDIR}"/${P}-boost-1.77-missing-include.patch
)
S="${WORKDIR}/s25client-${COMMIT}"
@@ -98,6 +99,8 @@ src_configure() {
-DRTTR_INCLUDE_DEVTOOLS=OFF
-DRTTR_LIBDIR="$(get_libdir)/${PN}"
-DRTTR_REVISION="${COMMIT}"
+ -DRTTR_USE_SYSTEM_LIBS=ON
+ # Just to be ultra explicit.
-DRTTR_USE_SYSTEM_LIBSAMPLERATE=ON
-DRTTR_VERSION="${PV##*_pre}" # Tests expect a date.
-DLUA_VERSION=$(lua_get_version)