summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-11 02:26:32 +0000
committerSam James <sam@gentoo.org>2021-12-11 02:34:30 +0000
commitf1bcd1732a3194be1a7f69bf48d3dc42c332ff4f (patch)
treee2b4349e32cda45f6bc25f2b4029806c53c06a1e
parentmedia-gfx/scrot: drop junk accidentally committed (diff)
downloadgentoo-f1bcd1732a3194be1a7f69bf48d3dc42c332ff4f.tar.gz
gentoo-f1bcd1732a3194be1a7f69bf48d3dc42c332ff4f.tar.bz2
gentoo-f1bcd1732a3194be1a7f69bf48d3dc42c332ff4f.zip
dev-libs/aml: add 0.2.1, fix musl build
* Add 0.2.1 * Fixes musl build by depending on queue-standalone. Closes: https://bugs.gentoo.org/828806 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/aml/Manifest1
-rw-r--r--dev-libs/aml/aml-0.2.1.ebuild40
-rw-r--r--dev-libs/aml/aml-9999.ebuild20
3 files changed, 57 insertions, 4 deletions
diff --git a/dev-libs/aml/Manifest b/dev-libs/aml/Manifest
index 4b5e3e0dab4e..26e539a0c75f 100644
--- a/dev-libs/aml/Manifest
+++ b/dev-libs/aml/Manifest
@@ -1 +1,2 @@
DIST aml-0.2.0.tar.gz 20358 BLAKE2B 4be63726ea9069cbfe36fbf04e3a0b2229066d7df039aea1a41fdca27700d012fda9eda348115f8c0ef9d3f201640123722d0b96bc7b171841d920357a292152 SHA512 196cd891fdbaad47340d8b4ca9eb62a7f9e6b0969ae9ad744a3c9ea110a532691d53a1e39fde583bad0f8fdae4b51c3a4243bbdab65e952e5fc79ceb6efc3262
+DIST aml-0.2.1.tar.gz 20413 BLAKE2B 62f8cc0e75f23ac7dc8835dd874f584cdb5b394b0d7af08feded06b99ccff66395e0ec04bdd26917ef7784457dc170c2c99bc98a118ecff947602e4d9a60bf21 SHA512 0af4a50cafbddd2a593dac437e6c8121de5265d0383139818bcda97d672a7430cb410ce32552b6842bc82eaebb061bc6cc0ee1b45a483754efbdfbc2103fa2e3
diff --git a/dev-libs/aml/aml-0.2.1.ebuild b/dev-libs/aml/aml-0.2.1.ebuild
new file mode 100644
index 000000000000..5ff10f20992d
--- /dev/null
+++ b/dev-libs/aml/aml-0.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Event timer executor loop"
+HOMEPAGE="https://github.com/any1/aml/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/aml.git"
+else
+ SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="elibc_musl? ( sys-libs/queue-standalone )"
+
+src_prepare() {
+ default
+
+ # The bundled copy includes cdefs which breaks on musl and
+ # this header is already available on glibc.
+ # bug #828806
+ rm include/sys/queue.h || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ )
+
+ meson_src_configure
+}
diff --git a/dev-libs/aml/aml-9999.ebuild b/dev-libs/aml/aml-9999.ebuild
index db62c0b53724..5ff10f20992d 100644
--- a/dev-libs/aml/aml-9999.ebuild
+++ b/dev-libs/aml/aml-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
-DESCRIPTION="event timer executor loop"
+DESCRIPTION="Event timer executor loop"
HOMEPAGE="https://github.com/any1/aml/"
if [[ ${PV} == 9999 ]]; then
@@ -13,16 +13,28 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/any1/aml.git"
else
SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~riscv ~x86"
fi
LICENSE="ISC"
SLOT="0"
IUSE="examples"
+DEPEND="elibc_musl? ( sys-libs/queue-standalone )"
+
+src_prepare() {
+ default
+
+ # The bundled copy includes cdefs which breaks on musl and
+ # this header is already available on glibc.
+ # bug #828806
+ rm include/sys/queue.h || die
+}
+
src_configure() {
local emesonargs=(
$(meson_use examples)
)
+
meson_src_configure
}