summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-26 05:25:39 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-26 05:26:29 +0200
commitf1f14fe0656c9ecae5d22a54f766a1a9f37e5acf (patch)
treec06c07520d5d77a901a19f6a36736e432fe8e115
parentdev-python/krb5: Bump to 0.4.1 (diff)
downloadgentoo-f1f14fe0656c9ecae5d22a54f766a1a9f37e5acf.tar.gz
gentoo-f1f14fe0656c9ecae5d22a54f766a1a9f37e5acf.tar.bz2
gentoo-f1f14fe0656c9ecae5d22a54f766a1a9f37e5acf.zip
dev-python/py-cpuinfo: Bump to 9.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/py-cpuinfo/Manifest1
-rw-r--r--dev-python/py-cpuinfo/py-cpuinfo-9.0.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/py-cpuinfo/Manifest b/dev-python/py-cpuinfo/Manifest
index 6b927e49ab3a..d41feff8312d 100644
--- a/dev-python/py-cpuinfo/Manifest
+++ b/dev-python/py-cpuinfo/Manifest
@@ -1 +1,2 @@
DIST py-cpuinfo-8.0.0.tar.gz 99791 BLAKE2B 95024b488142e3bbb2eaa69ffef229ac27f1cb55e297fb8de050ec4c410c1b13dbf674936365d84c5c473158338dd047f6dfba58c2a7dde4e21232af356ab20c SHA512 77351f9f2fd33b09d0ee998dd2b3eb971bbe9094bee5636356d5a5a2747ebba3c112cccfdf929f77e3b7de3c745f98ecfac8edeb0d84fede100b637b554d4fd9
+DIST py-cpuinfo-9.0.0.tar.gz 104716 BLAKE2B 667f5d420fd7eeff74e5047ee05220717585332c0b8b2a61422c3b4505f9c71c6b3091bbf3ebe29a3460b574a873cea423cffb5a83c49ceec3654a1558e435af SHA512 c7711137d60ad52bcbef8738a70fb48ceaa69e1e1632d135d0ee95c282b02df6170c3dd88a1e14b3e9a386d3286a15ca9722fcfb596107da022161a7cf84509a
diff --git a/dev-python/py-cpuinfo/py-cpuinfo-9.0.0.ebuild b/dev-python/py-cpuinfo/py-cpuinfo-9.0.0.ebuild
new file mode 100644
index 000000000000..44d377ce96c7
--- /dev/null
+++ b/dev-python/py-cpuinfo/py-cpuinfo-9.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get CPU info with pure Python 2 & 3"
+HOMEPAGE="
+ https://github.com/workhorsy/py-cpuinfo/
+ https://pypi.org/project/py-cpuinfo/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest