summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-01-10 14:25:31 +1100
committerMark Wright <gienah@gentoo.org>2020-01-10 19:43:18 +1100
commitf21a55f93e024094d32d2a3a60f4b20495e65e33 (patch)
treec6abe6360e6a3140818b2497f9fef70a717560e6
parentdev-java/validation-api: rdeps of dev-java/gwt-2.8.2 require 1.0.0 (diff)
downloadgentoo-f21a55f93e024094d32d2a3a60f4b20495e65e33.tar.gz
gentoo-f21a55f93e024094d32d2a3a60f4b20495e65e33.tar.bz2
gentoo-f21a55f93e024094d32d2a3a60f4b20495e65e33.zip
dev-java/gwt: Add for sci-mathematics/rstudio
Thanks to Joel for reporting. Thanks to Joel, jakub, betelgeuse, Michael Speth, Hank Leininger, Raimonds Cicans, naota and monsieurp for working on this. Co-Authored-By: Patrice Clement <monsieurp@gentoo.org> Bug: https://bugs.gentoo.org/show_bug.cgi?id=696944 Closes: https://bugs.gentoo.org/show_bug.cgi?id=171257 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mark Wright <gienah@gentoo.org>
-rw-r--r--dev-java/gwt/Manifest2
-rw-r--r--dev-java/gwt/gwt-2.8.2.ebuild72
-rw-r--r--dev-java/gwt/metadata.xml21
3 files changed, 95 insertions, 0 deletions
diff --git a/dev-java/gwt/Manifest b/dev-java/gwt/Manifest
new file mode 100644
index 000000000000..45f07b6b71dd
--- /dev/null
+++ b/dev-java/gwt/Manifest
@@ -0,0 +1,2 @@
+DIST gwt-2.8.2.zip 22017212 BLAKE2B b112df08885e607c975f9585d6b83e2a12894e974850ada052918e4b946b11bfc8d9cf9d71f4e684121d9d16714885be549eed44d77a119e695c2b50cd6bc6c3 SHA512 ac16311c3b00b36d421eef914e73ad8dea01f022c87fc7ed722fdfee8eed391f1987cc1c34522978afc542cdb90eee791efcdcc725d9a395ab468e458b708074
+DIST gwt-tools-f42d2729a3a8e6ba9b9aec069957bce5dc0f6f6d.zip 577453206 BLAKE2B 83a3824d6418727876b4708ed44ab1f58513a5b39d4e48f9bf21290ca358f76ec2ccd98ce2aee76afe7f621fb1f703bf459b8c3d6a3d4f32d4be807bc723513e SHA512 f4f033c972d955da40258020a9fb84ae90f30b7afeb1ae8044cf00f4f5f45200129bf84e2f69660a4eb80bb60f3a5a1d3c5af69fe9e07e0b985de0e708ca933f
diff --git a/dev-java/gwt/gwt-2.8.2.ebuild b/dev-java/gwt/gwt-2.8.2.ebuild
new file mode 100644
index 000000000000..3cc6b03863d1
--- /dev/null
+++ b/dev-java/gwt/gwt-2.8.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2 java-utils-2
+
+GWT_TOOLS_COMMIT="f42d2729a3a8e6ba9b9aec069957bce5dc0f6f6d"
+GWT_TOOLS_PN="tools"
+
+GWT_COMMIT="faff18e7a1f065e3a4ac4ef32ab5cce394557070"
+
+DESCRIPTION="Google Web Toolkit library"
+HOMEPAGE="http://www.gwtproject.org/"
+SRC_URI="https://github.com/gwtproject/${PN}/archive/${PV}.zip -> ${P}.zip
+ https://github.com/gwtproject/${GWT_TOOLS_PN}/archive/${GWT_TOOLS_COMMIT}.zip -> ${PN}-${GWT_TOOLS_PN}-${GWT_TOOLS_COMMIT}.zip"
+RESTRICT="mirror"
+SLOT="2.8"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND="
+ dev-java/json:0
+ dev-java/guava:20
+ dev-java/rhino:1.6
+ >=dev-java/asm-5.0.3:4
+ dev-java/eclipse-ecj:4.5
+ dev-java/validation-api:1.0
+"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.8:*"
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_BUILD_XML="build.xml"
+EANT_BUILD_TARGET="build"
+EANT_EXTRA_ARGS="-Dgwt.gitrev=${GWT_COMMIT}"
+EANT_GENTOO_CLASSPATH="
+ json
+ asm-4
+ guava-20
+ rhino-1.6
+ eclipse-ecj-4.5
+ validation-api-1.0
+"
+
+src_compile() {
+ GWT_TOOLS="${WORKDIR}/${GWT_TOOLS_PN}-${GWT_TOOLS_COMMIT}" \
+ GWT_VERSION="${PV}" \
+ java-pkg-2_src_compile
+}
+
+src_test() {
+ GWT_TOOLS="${WORKDIR}/${GWT_TOOLS_PN}-${GWT_TOOLS_COMMIT}" \
+ GWT_VERSION="${PV}" \
+ TZ=America/Los_Angeles ANT_OPTS=-Dfile.encoding=UTF-8 \
+ ant ${EANT_EXTRA_ARGS} test || die
+}
+
+src_install() {
+ java-pkg_dojar \
+ build/lib/*.jar
+ java-pkg_dolauncher i18nCreator --main com.google.gwt.i18n.tools.I18NCreator --jar gwt-dev.jar
+ java-pkg_dolauncher webAppCreator --main com.google.gwt.user.tools.WebAppCreator --jar gwt-dev.jar
+}
diff --git a/dev-java/gwt/metadata.xml b/dev-java/gwt/metadata.xml
new file mode 100644
index 000000000000..15024df0cf40
--- /dev/null
+++ b/dev-java/gwt/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription lang="en">
+ GWT is a development toolkit for building and optimizing
+ complex browser-based applications. Its goal is to enable
+ productive development of high-performance web applications
+ without the developer having to be an expert in browser
+ quirks, XMLHttpRequest, and JavaScript. It’s open source,
+ completely free, and used by thousands of developers around
+ the world.
+ </longdescription>
+</pkgmetadata>