summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-01-13 14:09:38 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-01-13 14:09:59 -0600
commitf3247cc80148d7b4153ee57e8bc7e07eecb4576f (patch)
tree28e9685d5161ed668d98a7ef018f3c24b8c78f92
parentdev-python/cryptography: Stabilize 3.3.1 x86, #765280 (diff)
downloadgentoo-f3247cc80148d7b4153ee57e8bc7e07eecb4576f.tar.gz
gentoo-f3247cc80148d7b4153ee57e8bc7e07eecb4576f.tar.bz2
gentoo-f3247cc80148d7b4153ee57e8bc7e07eecb4576f.zip
net-misc/openvswitch: 2.14.1 bump
Closes: https://bugs.gentoo.org/765073 Package-Manager: Portage-3.0.13, Repoman-3.0.2 RepoMan-Options: --force Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--net-misc/openvswitch/Manifest3
-rw-r--r--net-misc/openvswitch/openvswitch-2.13.0-r1.ebuild146
-rw-r--r--net-misc/openvswitch/openvswitch-2.14.1.ebuild (renamed from net-misc/openvswitch/openvswitch-2.14.0.ebuild)4
3 files changed, 3 insertions, 150 deletions
diff --git a/net-misc/openvswitch/Manifest b/net-misc/openvswitch/Manifest
index f2db6af2aaf3..516a3b3af854 100644
--- a/net-misc/openvswitch/Manifest
+++ b/net-misc/openvswitch/Manifest
@@ -1,2 +1 @@
-DIST openvswitch-2.13.0.tar.gz 7233892 BLAKE2B 66dfeb8a5dd61538360b319cfccbe49273298d6cb20df2105d1db7eb4d01f40d54ec8792a7f80d9ffc767f9b28ae09fee6aa76ac3d97be6fc43f3e7f3b2a63bd SHA512 3fcd15d07925273e0c45e6b1e70b2cd9998f753e8d1a11fd0de1d1511ad56dfddedbba436bb1c347b4afb84eb9cd6fc52c3d445b710a89d599d2ff47ed46f17c
-DIST openvswitch-2.14.0.tar.gz 7359886 BLAKE2B e7633578e9db395b534e2aca84f08919d06d14b68cdf78b04de25b887bcb4eb0e476c7d6c54ae23b72f797a3b083e09d23d8eb142da1e1463b2fbcde76069108 SHA512 5fe377f9b2857e238e3d40e4452e8b36c80283230f1d0f4b983324532beba725913da817e545c8d7630762f170bb5b0dfe810fd1b8b559994d5eae828beb8ec1
+DIST openvswitch-2.14.1.tar.gz 7388751 BLAKE2B 5f73dfc76101724564b1e8a1a79a13775e0394bcd97690b4e6ab860db5f639c636573d70927d257c6f8cd80b5b1780f909ad0521b842069bc6c6e069696bc416 SHA512 1dfc119fc230ea7bc2569544d24409b624593f16eea8d7034e0fced8ccfa09b0cde65244f9032bbad30885feada12c28065b776eadef85fc714743139ce7ff0b
diff --git a/net-misc/openvswitch/openvswitch-2.13.0-r1.ebuild b/net-misc/openvswitch/openvswitch-2.13.0-r1.ebuild
deleted file mode 100644
index 41b9b1b021a5..000000000000
--- a/net-misc/openvswitch/openvswitch-2.13.0-r1.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit autotools eutils linux-info linux-mod python-r1 systemd
-
-DESCRIPTION="Production quality, multilayer virtual switch"
-HOMEPAGE="https://www.openvswitch.org"
-SRC_URI="https://www.openvswitch.org/releases/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="debug modules monitor +ssl"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ssl? ( dev-libs/openssl:0= )
- ${PYTHON_DEPS}
- ~dev-python/ovs-2.13.0[${PYTHON_USEDEP}]
- dev-python/twisted[conch,${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- debug? ( dev-lang/perl )"
-DEPEND="${RDEPEND}
- sys-apps/util-linux[caps]
- virtual/pkgconfig"
-
-PATCHES="
- "${FILESDIR}/xcp-interface-reconfigure-2.3.2.patch"
-"
-
-CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
-MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
-BUILD_TARGETS="all"
-
-pkg_setup() {
- if use modules ; then
- CONFIG_CHECK+=" ~!OPENVSWITCH"
- kernel_is ge 3 10 0 || die "Linux >= 3.10.0 and <= 4.8 required for userspace modules"
- # docs state 4.17.x code states 4.15.x
- kernel_is le 5 5 999 || die "Linux >= 3.10.0 and <= 4.18 required for userspace modules"
- linux-mod_pkg_setup
- else
- CONFIG_CHECK+=" ~OPENVSWITCH"
- linux-info_pkg_setup
- fi
-}
-
-src_prepare() {
- # Never build kernelmodules, doing this manually
- sed -i \
- -e '/^SUBDIRS/d' \
- datapath/Makefile.in || die "sed failed"
- eautoreconf
- default
-}
-
-src_configure() {
- set_arch_to_kernel
- # monitor is statically enabled for bug 596206
- # use monitor || export ovs_cv_python="no"
- # pyside is staticly disabled
- export ovs_cv_pyuic4="no"
-
- # flake8 is primarily a style guide tool, running it as part of the tests
- # in Gentoo does not make much sense, only breaks them: bug 607280
- export ovs_cv_flake8="no"
-
- local linux_config
- use modules && linux_config="--with-linux=${KV_OUT_DIR}"
-
- econf ${linux_config} \
- --with-rundir=/var/run/openvswitch \
- --with-logdir=/var/log/openvswitch \
- --with-pkidir=/etc/ssl/openvswitch \
- --with-dbdir=/var/lib/openvswitch \
- $(use_enable ssl) \
- $(use_enable !debug ndebug)
-}
-
-src_compile() {
- default
-
- use modules && linux-mod_src_compile
-}
-
-src_install() {
- default
-
- local SCRIPT
- if use monitor; then
- for SCRIPT in ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpdump,tcpundump,test,vlan-test} bugtool/ovs-bugtool; do
- sed -e '1s|^.*$|#!/usr/bin/python|' -i utilities/"${SCRIPT}"
- python_foreach_impl python_doscript utilities/"${SCRIPT}"
- done
- rm -r "${ED%}"/usr/share/openvswitch/python || die
- fi
-
- keepdir /var/{lib,log}/openvswitch
- keepdir /etc/ssl/openvswitch
- fperms 0750 /etc/ssl/openvswitch
-
- rm -rf "${ED%}"/var/run || die
-
- newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
- newconfd "${FILESDIR}/ovs-vswitchd.confd-r2" ovs-vswitchd
- newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
- newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
-
- systemd_newunit "${FILESDIR}/ovsdb-server-r3.service" ovsdb-server.service
- systemd_newunit "${FILESDIR}/ovs-vswitchd-r3.service" ovs-vswitchd.service
- systemd_newunit rhel/usr_lib_systemd_system_ovs-delete-transient-ports.service ovs-delete-transient-ports.service
- systemd_newtmpfilesd "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
-
- insinto /etc/logrotate.d
- newins rhel/etc_logrotate.d_openvswitch openvswitch
-
- use modules && linux-mod_src_install
-}
-
-pkg_postinst() {
- use modules && linux-mod_pkg_postinst
-
- # only needed on non-systemd, but helps anyway
- elog "Use the following command to create an initial database for ovsdb-server:"
- elog " emerge --config =${CATEGORY}/${PF}"
- elog "(will create a database in /var/lib/openvswitch/conf.db)"
- elog "or to convert the database to the current schema after upgrading."
-}
-
-pkg_config() {
- local db="${EROOT%}"/var/lib/openvswitch/conf.db
- if [[ -e "${db}" ]] ; then
- einfo "Database '${db}' already exists, doing schema migration..."
- einfo "(if the migration fails, make sure that ovsdb-server is not running)"
- ovsdb-tool convert "${db}" \
- "${EROOT%}"/usr/share/openvswitch/vswitch.ovsschema || die "converting database failed"
- else
- einfo "Creating new database '${db}'..."
- ovsdb-tool create "${db}" \
- "${EROOT%}"/usr/share/openvswitch/vswitch.ovsschema || die "creating database failed"
- fi
-}
diff --git a/net-misc/openvswitch/openvswitch-2.14.0.ebuild b/net-misc/openvswitch/openvswitch-2.14.1.ebuild
index 3c2a20b5c72c..95c36b7bd173 100644
--- a/net-misc/openvswitch/openvswitch-2.14.0.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.14.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ SRC_URI="https://www.openvswitch.org/releases/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="debug modules monitor +ssl"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"