summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-01 19:40:34 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-01 19:40:34 +0200
commitf333efdba59536618fae9646acb2120e251ee6e5 (patch)
tree1ce19dec560c74caf8b88462ab483d937985eca4
parentkde-plasma/xembed-sni-proxy: 5.19.5 version bump (diff)
downloadgentoo-f333efdb.tar.gz
gentoo-f333efdb.tar.bz2
gentoo-f333efdb.zip
net-misc/vde: Remove old (py2)
Closes: https://bugs.gentoo.org/705936 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-misc/vde/vde-2.3.2-r4.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/net-misc/vde/vde-2.3.2-r4.ebuild b/net-misc/vde/vde-2.3.2-r4.ebuild
deleted file mode 100644
index 868a1ad7cdb8..000000000000
--- a/net-misc/vde/vde-2.3.2-r4.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1 flag-o-matic
-
-MY_P="${PN}2-${PV}"
-
-DESCRIPTION="Virtual distributed ethernet emulator for emulators like qemu, bochs, and uml"
-SRC_URI="mirror://sourceforge/vde/${MY_P}.tar.bz2"
-HOMEPAGE="http://vde.sourceforge.net/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 x86"
-IUSE="pcap python selinux ssl libressl static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPS="pcap? ( net-libs/libpcap )
- python? ( ${PYTHON_DEPS} )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )"
-DEPEND="${COMMON_DEPS}"
-RDEPEND="${COMMON_DEPS}
- acct-group/qemu
- selinux? ( sec-policy/selinux-vde )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}/${P}-format-security.patch" )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- has_version ">=dev-libs/openssl-1.1.0" && eapply "${FILESDIR}/${P}-openssl-1.1.patch"
-}
-
-src_configure() {
- filter-flags -O0 -Os
- econf \
- $(use_enable pcap) \
- $(use_enable python) \
- $(use_enable ssl cryptcab) \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- emake -j1
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -type f -delete || die
-
- newinitd "${FILESDIR}"/vde.init-r1 vde
- newconfd "${FILESDIR}"/vde.conf-r1 vde
-}
-
-pkg_postinst() {
- einfo "To start vde automatically add it to the default runlevel:"
- einfo "# rc-update add vde default"
- einfo "You need to setup tap0 in /etc/conf.d/net"
- einfo "To use it as an user be sure to set a group in /etc/conf.d/vde"
-}