summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-07 14:38:20 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-07 14:38:47 +0100
commitf33b733eaa61e524135f614523a6968e2c53ddb5 (patch)
treeeaa73f45493cfeaaea4fec3c821e453e7ae86162
parentgames-fps/freedoom-data: Add Python 3.10 to PYTHON_COMPAT (diff)
downloadgentoo-f33b733eaa61e524135f614523a6968e2c53ddb5.tar.gz
gentoo-f33b733eaa61e524135f614523a6968e2c53ddb5.tar.bz2
gentoo-f33b733eaa61e524135f614523a6968e2c53ddb5.zip
x11-terms/rxvt-unicode: add 24-bit-colour support to 9.26
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--x11-terms/rxvt-unicode/Manifest1
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.26-r1.ebuild (renamed from x11-terms/rxvt-unicode/rxvt-unicode-9.26.ebuild)21
2 files changed, 19 insertions, 3 deletions
diff --git a/x11-terms/rxvt-unicode/Manifest b/x11-terms/rxvt-unicode/Manifest
index 369cb6668995..6f61f0985202 100644
--- a/x11-terms/rxvt-unicode/Manifest
+++ b/x11-terms/rxvt-unicode/Manifest
@@ -1,3 +1,4 @@
DIST rxvt-unicode-9.22.tar.bz2 931198 BLAKE2B ea9a12e4a8396ed6be12b4d50ae260a0376902dbd47b0628bb14ce0509c5d89f5a80370b413fdb9df9b8b81728ec26e115cbf0d88ab6e9cb2a87b03b5d79c432 SHA512 b39f1b2cbe6dd3fbd2a0ad6a9d391a2b6f49d7c5e67bc65fe44a9c86937f8db379572c67564c6e21ff6e09b447cdfd4e540544e486179e94da0e0db679c04dd9
DIST rxvt-unicode-9.22_24-bit-color_cpixl-20201108.patch.xz 8116 BLAKE2B 27940ad42ee3f26c357a50b7fae1e1539acec71f5ff43e7ed16167d0adb175c4de20ba84880f25eec0817703d937d097fda228541d16511811efe5816109e71b SHA512 2b8bbb90c6bb223f622c1e99d62a70a812604d1f8e57cea37a8faf0af578588d3888ea8009568d623710cc03e020a69269770e23476fd9ff9e46dbd9ea23f540
DIST rxvt-unicode-9.26.tar.bz2 904950 BLAKE2B 1790d02eeadf630cc9bc718288af2f6bd19c3e320d3dbfa44c8cef516c8e790e0abfbfe4e557795749ddd3ec41b8358f6eac623c060240f091b3e84a549151ad SHA512 35560b57730e17c9542ea4a615fd86ce703c4e6421323e8fe1570007737a880fde90d17943e5af9e170be4111b9769f4aa7e57efca5428421fdc1c299112f8e0
+DIST rxvt-unicode-9.26_24-bit-color_aur-20210516+eautoreconf.patch.xz 11716 BLAKE2B 7e18b0f884dbb9574515db8cfb4e1521e1e3287ac194750db288409c7e4d0bb120964e4559ce7e3b91e169935ded93f3af3045fc7c1737a5a6de2710ee2e107b SHA512 8cbcc1c04bdb83996ce08ece559ef9e7f5f530140a2a66291e0ffd049808da60787a68520b4a990dc12e1272de861a85b199ddd10ac8b245eafbfe16dc521199
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.26.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.26-r1.ebuild
index 981de5a0d605..4fa68cb62a3e 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9.26.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.26-r1.ebuild
@@ -5,14 +5,17 @@ EAPI=7
inherit autotools desktop flag-o-matic systemd prefix
+COLOUR_PATCH_NAME="${PN}-9.26_24-bit-color_aur-20210516+eautoreconf.patch"
+
DESCRIPTION="rxvt clone with xft and unicode support"
HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
-SRC_URI="http://dist.schmorp.de/rxvt-unicode/Attic/${P}.tar.bz2"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/Attic/${P}.tar.bz2
+ https://dev.gentoo.org/~marecki/dists/${PN}/${COLOUR_PATCH_NAME}.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
-IUSE="256-color blink fading-colors +font-styles gdk-pixbuf iso14755 +mousewheel
+IUSE="24-bit-color 256-color blink fading-colors +font-styles gdk-pixbuf iso14755 +mousewheel
+perl startup-notification unicode3 +utmp +wtmp xft"
RDEPEND=">=sys-libs/ncurses-5.7-r6:=
@@ -28,11 +31,12 @@ RDEPEND=">=sys-libs/ncurses-5.7-r6:=
DEPEND="${RDEPEND}
x11-base/xorg-proto"
BDEPEND="virtual/pkgconfig"
-# WARNING: will bdepend on >=sys-devel/autoconf-2.71 (masked as of 2021-05-16) if eautoreconf has to be called
+# WARNING: will bdepend on >=sys-devel/autoconf-2.71 (masked as of 2021-07-07) if eautoreconf has to be called
PATCHES=(
"${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch
"${FILESDIR}"/${PN}-9.21-xsubpp.patch
+ "${WORKDIR}"/${COLOUR_PATCH_NAME}
)
DOCS=(
Changes
@@ -56,6 +60,7 @@ src_prepare() {
src_configure() {
# --enable-everything goes first: the order of the arguments matters
econf --enable-everything \
+ $(use_enable 24-bit-color) \
$(use_enable 256-color) \
$(use_enable blink text-blink) \
$(use_enable fading-colors fading) \
@@ -88,3 +93,13 @@ src_install() {
make_desktop_entry urxvt rxvt-unicode utilities-terminal \
"System;TerminalEmulator"
}
+
+pkg_postinst() {
+ if use 24-bit-color; then
+ ewarn
+ ewarn "You have enabled 24-bit colour support in ${PN}, which is UNOFFICIAL and INCOMPLETE."
+ ewarn "You may or may not encounter visual glitches or stability issues. When in doubt,"
+ ewarn "rebuild =${CATEGORY}/${PF} with USE=-24-bit-color (the default setting)."
+ ewarn
+ fi
+}