summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-12-21 22:36:02 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-12-22 00:40:53 +0100
commitf373b422ad975add8b59468f781d10b3b2106b3f (patch)
tree70cb41f60301c044f2503ac35447924b5be79971
parentmail-client/thunderbird: synchronize with www-client/firefox (diff)
downloadgentoo-f373b422ad975add8b59468f781d10b3b2106b3f.tar.gz
gentoo-f373b422ad975add8b59468f781d10b3b2106b3f.tar.bz2
gentoo-f373b422ad975add8b59468f781d10b3b2106b3f.zip
dev-lang/spidermonkey: synchronize with www-client/firefox
Bug: https://bugs.gentoo.org/758446 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-lang/spidermonkey/spidermonkey-78.6.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-lang/spidermonkey/spidermonkey-78.6.0.ebuild b/dev-lang/spidermonkey/spidermonkey-78.6.0.ebuild
index 4fab87fc3cea..b9aea8f68d34 100644
--- a/dev-lang/spidermonkey/spidermonkey-78.6.0.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-78.6.0.ebuild
@@ -228,6 +228,7 @@ src_prepare() {
src_configure() {
# Show flags set at the beginning
einfo "Current CFLAGS: ${CFLAGS}"
+ einfo "Current CXXFLAGS: ${CXXFLAGS}"
einfo "Current LDFLAGS: ${LDFLAGS}"
einfo "Current RUSTFLAGS: ${RUSTFLAGS}"
@@ -315,8 +316,16 @@ src_configure() {
# LTO flag was handled via configure
filter-flags '-flto*'
+ if tc-is-gcc ; then
+ if ver_test $(gcc-fullversion) -ge 10 ; then
+ einfo "Forcing -fno-tree-loop-vectorize to workaround GCC bug, see bug 758446 ..."
+ append-cxxflags -fno-tree-loop-vectorize
+ fi
+ fi
+
# Show flags we will use
einfo "Build CFLAGS: ${CFLAGS}"
+ einfo "Build CXXFLAGS: ${CXXFLAGS}"
einfo "Build LDFLAGS: ${LDFLAGS}"
einfo "Build RUSTFLAGS: ${RUSTFLAGS}"