summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 11:54:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:43:55 +0200
commitf3e40f65e355f1ff933eadbbe73b3515708a90eb (patch)
tree3e9ff72076d56ebc91fb28e7dbb04e8f41f21572
parentdev-ros/rosbag_storage: Bump to 1.15.9. (diff)
downloadgentoo-f3e40f65e355f1ff933eadbbe73b3515708a90eb.tar.gz
gentoo-f3e40f65e355f1ff933eadbbe73b3515708a90eb.tar.bz2
gentoo-f3e40f65e355f1ff933eadbbe73b3515708a90eb.zip
dev-ros/rosgraph: Bump to 1.15.9.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/rosgraph/Manifest1
-rw-r--r--dev-ros/rosgraph/rosgraph-1.15.9.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/Manifest b/dev-ros/rosgraph/Manifest
index 00d95d9416dc..fd3eb70a996d 100644
--- a/dev-ros/rosgraph/Manifest
+++ b/dev-ros/rosgraph/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.15.8.tar.gz 1080826 BLAKE2B c1a1e085225a96cf0b50309cb78e1ccdabefce1f23ee669393b7fc747537c7e39bfb6ad382b0d24e3b5507b1d0f3eaf2051a1bee90507b0e724e06a83df301a2 SHA512 b1c34ab6548400fc014eda496e5d1e1c7d134b9062a031386ac4eac3245ca83b034f74f0a189ccf9ec6933c18d6df0ae1a93d05f1526d09debf70c25aa25b6b9
+DIST ros_comm-1.15.9.tar.gz 1087337 BLAKE2B 8c1582425770eee7898de42785c620c5fe82e31764d8947c16f9dbb43dd03d0201344e72d5a24911f7cc3cf4eacd51d6fc2940cc2346b635a2c769b055898297 SHA512 3f009a29d74dd74169585afb8d08c41faa19128e384ef6aa6c7bf58ae4d31345e4ea5441fc99a81b7742f724df7c7e3c16c4e51473c4fddeb4b9b6bf41cff04b
diff --git a/dev-ros/rosgraph/rosgraph-1.15.9.ebuild b/dev-ros/rosgraph/rosgraph-1.15.9.ebuild
new file mode 100644
index 000000000000..171218629338
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-1.15.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/netifaces[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep "dev-python/mock[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}