summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-08 14:04:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-08 14:22:21 +0200
commitf44ce3ca5e15c655fc1c56c2da7f99e0a0468d47 (patch)
tree880c331d8aac9106231418bd2f83005da937a6b3
parentdev-util/catkin: Remove old (diff)
downloadgentoo-f44ce3ca5e15c655fc1c56c2da7f99e0a0468d47.tar.gz
gentoo-f44ce3ca5e15c655fc1c56c2da7f99e0a0468d47.tar.bz2
gentoo-f44ce3ca5e15c655fc1c56c2da7f99e0a0468d47.zip
dev-util/catkin: bump to 0.7.12
Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--dev-util/catkin/Manifest1
-rw-r--r--dev-util/catkin/catkin-0.7.12.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/dev-util/catkin/Manifest b/dev-util/catkin/Manifest
index 46c363773aa0..d076c30612b6 100644
--- a/dev-util/catkin/Manifest
+++ b/dev-util/catkin/Manifest
@@ -1 +1,2 @@
DIST catkin-0.7.11.tar.gz 206933 BLAKE2B cda31e3d097516ce830060a2323956ec27c4113d161e95ab55564c00209e23d894e2acf3bf11b78e19538d4d8ff4c85814362a89bca58700da5fb609fb708fb8 SHA512 71810a80c1ac4334fdaed176285bee6bcb0443529debecf421723881e3d6316f41d4ed07c5eafa55515ba9d8143d5dc5fb683eda5ad54e52fda5c24085c44c96
+DIST catkin-0.7.12.tar.gz 211602 BLAKE2B ee5b9e57601847f79a2e7c49bb9b38974b0385a1c524c70cc549511d31b9fe8d03bf95e254b9c40a420fad990da40bf9c5d29f198ae42bd772c54a89cdc532b9 SHA512 ada496fae0959330b369c8a29daf9c575fcc94c3ee7e27e0180614fc49912450b23163622759975e588ffcdd49180e5f2fc8351e02bf1aef9b1f2db92811dbd6
diff --git a/dev-util/catkin/catkin-0.7.12.ebuild b/dev-util/catkin/catkin-0.7.12.ebuild
new file mode 100644
index 000000000000..6f125a7d7fb0
--- /dev/null
+++ b/dev-util/catkin/catkin-0.7.12.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros/catkin"
+fi
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ${SCM} cmake-utils python-r1 python-utils-r1
+
+DESCRIPTION="Cmake macros and associated python code used to build some parts of ROS"
+HOMEPAGE="http://wiki.ros.org/catkin"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros/catkin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/empy[${PYTHON_USEDEP}]
+ dev-util/cmake
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] dev-python/mock[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/tests.patch"
+ "${FILESDIR}/distutils.patch"
+ "${FILESDIR}/catkin_prefix_path.patch"
+ "${FILESDIR}/gnuinstalldirs.patch"
+ "${FILESDIR}/catkin_prefix_path_util_py.patch"
+ "${FILESDIR}/package_xml.patch"
+ "${FILESDIR}/etc.patch"
+ "${FILESDIR}/sitedir.patch"
+)
+
+src_prepare() {
+ # fix libdir
+ sed -i \
+ -e 's:LIBEXEC_DESTINATION lib:LIBEXEC_DESTINATION libexec:' \
+ -e 's:}/lib:}/${CMAKE_INSTALL_LIBDIR}:' \
+ -e 's:DESTINATION lib):DESTINATION ${CMAKE_INSTALL_LIBDIR}):' \
+ -e 's:DESTINATION lib/:DESTINATION ${CMAKE_INSTALL_LIBDIR}/:' \
+ -e 's:PYTHON_INSTALL_DIR lib:PYTHON_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}:' \
+ cmake/*.cmake || die
+ cmake-utils_src_prepare
+}
+
+catkin_src_configure_internal() {
+ local sitedir="$(python_get_sitedir)"
+ mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_INSTALL_DIR="${sitedir#${EPREFIX}/usr/}"
+ )
+ python_export PYTHON_SCRIPTDIR
+ cmake-utils_src_configure
+}
+
+src_configure() {
+ export PYTHONPATH="${S}/python"
+ local mycmakeargs=(
+ "$(cmake-utils_use test CATKIN_ENABLE_TESTING)"
+ "-DCATKIN_BUILD_BINARY_PACKAGE=ON"
+ )
+ python_foreach_impl catkin_src_configure_internal
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_compile
+}
+
+src_test() {
+ unset PYTHON_SCRIPTDIR
+ python_foreach_impl cmake-utils_src_test
+}
+
+catkin_src_install_internal() {
+ python_export PYTHON_SCRIPTDIR
+ cmake-utils_src_install
+ if [ ! -f "${T}/.catkin_python_symlinks_generated" ]; then
+ dodir /usr/bin
+ for i in "${D}/${PYTHON_SCRIPTDIR}"/* ; do
+ dosym ../lib/python-exec/python-exec2 "/usr/bin/${i##*/}" || die
+ done
+ touch "${T}/.catkin_python_symlinks_generated"
+ fi
+}
+
+src_install() {
+ python_foreach_impl catkin_src_install_internal
+
+ doenvd "${FILESDIR}/40catkin"
+
+ # needed to be considered as a workspace
+ touch "${ED}/usr/.catkin"
+}
+
+pkg_postinst() {
+ ewarn "Starting from version 0.7.1-r2, dev-util/catkin changed the"
+ ewarn "installation path for package.xml files on Gentoo."
+ ewarn "In order for ROS to work properly, you will need to reinstall ROS"
+ ewarn "packages that have it installed in the old location:"
+ ewarn " emerge -1O /usr/share/*/package.xml"
+ ewarn "See https://bugs.gentoo.org/show_bug.cgi?id=595004 for more details."
+}