summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-25 08:36:08 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-25 09:11:23 +0200
commitf4695c7585148436eab8b444488605c44db58352 (patch)
tree65a5b2ee91a01c419b749d137b4133ea753a6e0d
parenteclass: gentoo.org has https per default (diff)
downloadgentoo-f4695c7585148436eab8b444488605c44db58352.tar.gz
gentoo-f4695c7585148436eab8b444488605c44db58352.tar.bz2
gentoo-f4695c7585148436eab8b444488605c44db58352.zip
dev-python/lxml: Drop optional runtime deps and add optfeature
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/lxml/lxml-3.4.4.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/lxml/lxml-3.4.4.ebuild b/dev-python/lxml/lxml-3.4.4.ebuild
index d42bd067fd5e..a4ea22da4003 100644
--- a/dev-python/lxml/lxml-3.4.4.ebuild
+++ b/dev-python/lxml/lxml-3.4.4.ebuild
@@ -15,16 +15,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD ElementTree GPL-2 PSF-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris ~arm64"
-IUSE="beautifulsoup3 doc examples +threads test"
+IUSE="doc examples +threads test"
# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
RDEPEND="
>=dev-libs/libxml2-2.7.2
- >=dev-libs/libxslt-1.1.23
- beautifulsoup3? (
- $(python_gen_cond_dep 'dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]' 'python2*')
- $(python_gen_cond_dep 'dev-python/beautifulsoup:python-3[${PYTHON_USEDEP}]' 'python3*')
- )"
+ >=dev-libs/libxslt-1.1.23"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/cssselect[${PYTHON_USEDEP}] )
@@ -75,3 +71,8 @@ python_install_all() {
distutils-r1_python_install_all
}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup as a parser backend" dev-python/beautifulsoup-3*
+ optfeature "Translates CSS selectors to XPath 1.0 expressions" dev-python/cssselect
+}