summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-19 09:43:19 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-19 09:43:19 +0200
commitf49c4ef91944f8ef7886be6260aa49aa2619162a (patch)
tree3df214d2c84d3e0fd3c94f6a7ca932ff2d3c6522
parentdev-ruby/actionpack: add ruby25 (diff)
downloadgentoo-f49c4ef91944f8ef7886be6260aa49aa2619162a.tar.gz
gentoo-f49c4ef91944f8ef7886be6260aa49aa2619162a.tar.bz2
gentoo-f49c4ef91944f8ef7886be6260aa49aa2619162a.zip
dev-ruby/activestorage: add ruby25
Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--dev-ruby/activestorage/activestorage-5.2.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-ruby/activestorage/activestorage-5.2.0.ebuild b/dev-ruby/activestorage/activestorage-5.2.0.ebuild
index cbf80ddd687f..7d7401cba939 100644
--- a/dev-ruby/activestorage/activestorage-5.2.0.ebuild
+++ b/dev-ruby/activestorage/activestorage-5.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24"
+USE_RUBY="ruby23 ruby24 ruby25"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_DOCDIR=""
@@ -36,13 +36,15 @@ ruby_add_bdepend "
test? (
~dev-ruby/railties-${PV}
dev-ruby/test-unit:2
+ dev-ruby/mini_magick
dev-ruby/mocha
)"
all_ruby_prepare() {
# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|aws-sdk-s3\|google-cloud-storage\|azure-storage\|blade\|bootsnap\|hiredis\|qunit-selenium\|chromedriver-helper\|redis\|rb-inotify\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\)/ s:^:#:" \
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|aws-sdk-s3\|google-cloud-storage\|azure-storage\|blade\|bootsnap\|hiredis\|qunit-selenium\|chromedriver-helper\|redis\|rb-inotify\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|sass-rails\|rubocop\)/ s:^:#:" \
+ -e '/dalli/ s/2.7.7/2.7.9/' \
-e '/:job/,/end/ s:^:#:' \
-e '/:test/,/^end/ s:^:#:' \
-e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die