summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-10-12 22:28:13 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-10-12 22:28:13 +0900
commitf527db286e9ff3e055d2ef74149ee37e8aab47da (patch)
tree4b001f3b7edd7836f495b5498aaac56a9b02560b
parentapp-i18n/uim-tomoe-gtk: update to EAPI 7 (diff)
downloadgentoo-f527db286e9ff3e055d2ef74149ee37e8aab47da.tar.gz
gentoo-f527db286e9ff3e055d2ef74149ee37e8aab47da.tar.bz2
gentoo-f527db286e9ff3e055d2ef74149ee37e8aab47da.zip
app-shells/yash: new upstream release
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--app-shells/yash/Manifest1
-rw-r--r--app-shells/yash/yash-2.52.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
index 57368fb95740..61a7fd09a486 100644
--- a/app-shells/yash/Manifest
+++ b/app-shells/yash/Manifest
@@ -1,2 +1,3 @@
DIST yash-2.50.tar.xz 739988 BLAKE2B 4d8047150e2326b7c401f79416d87d09c099d4743026ee997e7f49d096cb23de210ded489b348cc9a264ece2fd4778b4f5c5c9999ed7391ab78699ce77ec03e0 SHA512 fc78d61b09f7c81d1d7bd3f4feefa7d4c0de910524759ebcba2b53322abc3f1e0a937007b36a5060af0ee759df210ec06d5eed2c71cf3f7ccd0825521b50edb7
DIST yash-2.51.tar.xz 753880 BLAKE2B 4c66137eb2abf454c75b50c9d153522136bd835e7c26a305b424b8cf88694fd1dc83d9012efc8e2a611abc25217b34ae1dd36c20e0645204fb349871d23feefa SHA512 53f85f98dfd66c8937db292694da05fb7fdc8d270fc4811d7ec4d2787ab56600eca8e44379ef349755ec5fb739af3b32036a588ac35be810108ccc388be122e6
+DIST yash-2.52.tar.xz 755016 BLAKE2B 44c26d310e9bd50a6f381adefedcdf9bcb49998860a8a67e300d31d5a8615d7346e06e7c4ca5e098d7232a0acc112daa2230572939f665db982f187ccd741778 SHA512 1024ff7e3cce6e64cbc0bd5c0d04a9863d0d51013baf07723d09562b156d05dbfe1fc2df5b736cdec5f562c56ad634f865554a1fe5aeeed91ec0d9276667f02a
diff --git a/app-shells/yash/yash-2.52.ebuild b/app-shells/yash/yash-2.52.ebuild
new file mode 100644
index 000000000000..d9439e440b70
--- /dev/null
+++ b/app-shells/yash/yash-2.52.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PLOCALES="en ja"
+
+inherit flag-o-matic plocale toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://yash.osdn.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/76153/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}" \
+ $(use_enable nls) \
+ CC=$(tc-getCC) \
+ LINGUAS="$(plocale_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}