summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-04 21:34:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-04 23:21:09 +0100
commitf543332f5d0454243d99adad66a7e4e020921c61 (patch)
tree2bbfe60f3f958302b0f0944e64a825efec471ceb
parentdev-python/hypothesis: Bump to 6.4.3 (diff)
downloadgentoo-f543332f5d0454243d99adad66a7e4e020921c61.tar.gz
gentoo-f543332f5d0454243d99adad66a7e4e020921c61.tar.bz2
gentoo-f543332f5d0454243d99adad66a7e4e020921c61.zip
dev-python/defusedxml: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/defusedxml/Manifest1
-rw-r--r--dev-python/defusedxml/defusedxml-0.7.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/defusedxml/Manifest b/dev-python/defusedxml/Manifest
index c4b6e6e5a009..f7be7b523b70 100644
--- a/dev-python/defusedxml/Manifest
+++ b/dev-python/defusedxml/Manifest
@@ -1 +1,2 @@
DIST defusedxml-0.7.0.rc1.tar.gz 33950 BLAKE2B d2794d0d06ca7bd1faa0b33f3fa7e02fcfb8b7bb7bfba5e0cf4119f7341a618daf80b08e0a6949cad67c5d3ceb84a5d984d731ae129b9aed383b5b583b114013 SHA512 068a6610fcb791385dc1956d1ff1e8b17b143a0138e6a10a293b8f18153d733e160e924f52c565e2df503101faa9b2c3d4718b2980f0e5652034e250b8a82f55
+DIST defusedxml-0.7.0.tar.gz 34412 BLAKE2B 661003c15c4e22877ccbd5c746f782d662bf8ba16dfb998953d979867eed181df01fda51bbec0813497059a27665ab391db7c4d442f90f1f22faafa6a27fe500 SHA512 7738175dafb4092a61d1a73941aecf5d78840e3674e2ae6bbf45e4e0ab6c71a9c9abce8a5394a148d50d90fd6a20d4e02c65241212af2ba6b655c1935e432603
diff --git a/dev-python/defusedxml/defusedxml-0.7.0.ebuild b/dev-python/defusedxml/defusedxml-0.7.0.ebuild
new file mode 100644
index 000000000000..3955f4c70145
--- /dev/null
+++ b/dev-python/defusedxml/defusedxml-0.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="XML bomb protection for Python stdlib modules, an xml serialiser"
+HOMEPAGE="https://pypi.org/project/defusedxml/"
+SRC_URI="
+ https://github.com/tiran/defusedxml/archive/v${PV/_/.}.tar.gz
+ -> ${P/_/.}.tar.gz"
+S=${WORKDIR}/${P/_/.}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ default
+
+ mv other examples || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples/
+ distutils-r1_python_install_all
+}