summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-08 05:52:51 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-08 05:52:51 +0200
commitf58b14c5b0a0cb8153d162588fb44aa292f919dd (patch)
tree3d499b7930bd509ce5c08aebaeeb26f7dff80af2
parentdev-ruby/yard: add missing rack test dependency (diff)
downloadgentoo-f58b14c5b0a0cb8153d162588fb44aa292f919dd.tar.gz
gentoo-f58b14c5b0a0cb8153d162588fb44aa292f919dd.tar.bz2
gentoo-f58b14c5b0a0cb8153d162588fb44aa292f919dd.zip
dev-ruby/yard: cleanup
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-ruby/yard/Manifest2
-rw-r--r--dev-ruby/yard/yard-0.9.12.ebuild40
-rw-r--r--dev-ruby/yard/yard-0.9.13.ebuild43
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
index 4a10db41c828..dd9fc1cfa444 100644
--- a/dev-ruby/yard/Manifest
+++ b/dev-ruby/yard/Manifest
@@ -1,4 +1,2 @@
DIST yard-0.9.11-git.tgz 916355 BLAKE2B e9f27fe129cf93c51dbf83f4a7d5745d385252ba63c90f85223f2e9436c22a55aaba296f263072069d39e4beaca3e0830775a8be121c64cdc2a15afd3539a73f SHA512 375a4878e61888cf73aaa06e9300195ae48b9898d8cd639fa796a067e5fa0b89d6ef62d327a388ee83953e80177515f4d8c070042188e3a1e597f48b82b3a72e
-DIST yard-0.9.12-git.tgz 916462 BLAKE2B 905f0e4408f7829ca599b578344d695e4c7b68d46b982f39277dcd69ee726a9ac283910e1031d635917b149f182fb302cae537ff8a8a81960fa27965fda82a0c SHA512 f987da7e46bb3dafb9ba8c761b51345ee67102e21d05181c3090f31ff37179505134c93e83efdd39bb35cf6fe6dfa530d0017ce4680a08f858e78cbb073b239f
-DIST yard-0.9.13-git.tgz 917734 BLAKE2B ac248a91c581247647dcf78e58fd9b6b9c014bb972fbfbb09179ec489c89a31ec1156e13c99c7e862ece216b0451ac4ccb0441c1bdd45a8078c90f886d1a5135 SHA512 8ae886e1c981f017f740e12f07f90470ac9bf420a51f99692b642c212e26231d0a19e1b64084e3a70e09cad4e3a7175278fca66bd3b2420eac4ba197e20876ee
DIST yard-0.9.14-git.tgz 917830 BLAKE2B dd0d1d6dbc5aa9b549bd4c110f1abd57edc76b85e7c936bca8f7d35761d705ba86cd169c3c2b2141095dda68a8ab350b46bcbeb978d655addff78b110fbd2b71 SHA512 7974d431b2c1ef4830f225fd2012592405e7fb63546aeb52b74f4ad8b498926be979f3010bd315877bb4f738f6aa6c31f54b71832b461ebd3fa54fe1a1fccf5f
diff --git a/dev-ruby/yard/yard-0.9.12.ebuild b/dev-ruby/yard/yard-0.9.12.ebuild
deleted file mode 100644
index bb7ba9c9023a..000000000000
--- a/dev-ruby/yard/yard-0.9.12.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_TASK_DOC="yard"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_DOCDIR="doc docs"
-
-RUBY_FAKEGEM_EXTRAINSTALL="templates"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Documentation generation tool for the Ruby programming language"
-HOMEPAGE="https://yardoc.org/"
-
-# The gem lakes the gemspec file needed to pass tests.
-SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/bluecloth dev-ruby/kramdown ) )"
-
-ruby_add_bdepend "test? ( >=dev-ruby/ruby-gettext-2.3.8 )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
-
- # Avoid specs that make assumptions on load ordering that are not
- # true for us. This may be related to how we install in Gentoo. This
- # also drops a test requirement on dev-ruby/rack.
- rm -f spec/cli/server_spec.rb || die
-}
diff --git a/dev-ruby/yard/yard-0.9.13.ebuild b/dev-ruby/yard/yard-0.9.13.ebuild
deleted file mode 100644
index 010fffba8102..000000000000
--- a/dev-ruby/yard/yard-0.9.13.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_TASK_DOC="yard"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_DOCDIR="doc docs"
-
-RUBY_FAKEGEM_EXTRAINSTALL="templates"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Documentation generation tool for the Ruby programming language"
-HOMEPAGE="https://yardoc.org/"
-
-# The gem lakes the gemspec file needed to pass tests.
-SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/bluecloth dev-ruby/kramdown ) )"
-
-ruby_add_bdepend "test? ( >=dev-ruby/ruby-gettext-2.3.8 )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
-
- # Avoid specs that make assumptions on load ordering that are not
- # true for us. This may be related to how we install in Gentoo. This
- # also drops a test requirement on dev-ruby/rack.
- rm -f spec/cli/server_spec.rb || die
-
- # Avoid specs that only work with bundler
- sed -i -e '/#initialize/,/^ end/ s:^:#:' spec/cli/yri_spec.rb || die
-}