summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-04-06 13:20:56 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-04-06 13:22:36 -0500
commitf5b877cf066e025bc29bd86772260cdb55a868d4 (patch)
tree958de72e334633a9fbd625322d400b9aba2c672b
parentapp-crypt/certbot: 1.26.0 bump (diff)
downloadgentoo-f5b877cf066e025bc29bd86772260cdb55a868d4.tar.gz
gentoo-f5b877cf066e025bc29bd86772260cdb55a868d4.tar.bz2
gentoo-f5b877cf066e025bc29bd86772260cdb55a868d4.zip
app-crypt/certbot-apache: 1.26.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.26.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index 5e417bc2d381..d1c6e18e2eb1 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1,3 +1,4 @@
DIST certbot-1.23.0.tar.gz 1361107 BLAKE2B a1b1e029436eb32840d56ca815478df3774a30b69552c5f7a4ca18b054a49c8ce342fe7f7ffecfb6c0fb93338bb722d57e4537e1f142ab162bb8208575ee34be SHA512 bb64139c6406e7c87571beb94d435e079368cbb249d96b522dab72a9529b3a825f9258aac70c5a582d58117c700da281fb43ed8369f40a236c0b7e6acb5237b0
DIST certbot-1.24.0.tar.gz 1360049 BLAKE2B e1c7f4b56ac66b73f74eb8c9d6c31bc12529c2e7a1a51679e715227e61a2e72a30aa5053abe1684be9d665e399ca67f2d11afcc5c60c76bb86d1c0feb68308ca SHA512 fa2a45e650107f48da1e5d7d7469e8a23598e0e0e1127bc62a66ba2351a8fe518da6ec3e53370f7042631ee74e82c65fcc323c71e8f485911363e805ccb6f045
DIST certbot-1.25.0.tar.gz 1362891 BLAKE2B c109f7777328dcaa2760b524a005f648f8695518a3a052a1d3ff20367f0b704c2a15c912ede091ef6f0f2faf2838caaa74d3bdac6deeb4cc069e6ca16cfb26a7 SHA512 e32cac530d7854cb626aed6d7bac7b4482b7c3634d94fbabd6fa767f9c1268ed3baed0c945362df247e4fc7d51147e5561825850d52c1a8f11b3a1fb2827bd4a
+DIST certbot-1.26.0.tar.gz 1364070 BLAKE2B f9b13df8fb424e579293280202b71756c37a3ec7f986da38a5fd318d00ab7e2ed89223c62a20448ad30271783bb3c44db11a0ce4afebced9f1e9ca4e4c6de3f2 SHA512 bd27cb0a0ef6fc143a3d0dcf5d530d336b93a24d7010e6427c25614befb815f33076b4a3043bb247cafdfad17b8714a19ead43257c64f4fd72ac99f02cb07cde
diff --git a/app-crypt/certbot-apache/certbot-apache-1.26.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.26.0.ebuild
new file mode 100644
index 000000000000..cf0c9621b1ae
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-1.26.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest