summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-11-13 11:47:23 +0100
committerArsen Arsenović <arsen@gentoo.org>2023-11-13 12:00:05 +0100
commitf65a3e38b5e9b39db7d08c22e1c2f5e066d539af (patch)
treea3be5d46b67ce508886c6318b6bd7eed5c1d377b
parentsys-libs/libnbd: add 1.18.1 (diff)
downloadgentoo-f65a3e38b5e9b39db7d08c22e1c2f5e066d539af.tar.gz
gentoo-f65a3e38b5e9b39db7d08c22e1c2f5e066d539af.tar.bz2
gentoo-f65a3e38b5e9b39db7d08c22e1c2f5e066d539af.zip
sys-block/nbdkit: add 1.36.1
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
-rw-r--r--sys-block/nbdkit/Manifest1
-rw-r--r--sys-block/nbdkit/metadata.xml1
-rw-r--r--sys-block/nbdkit/nbdkit-1.36.1.ebuild120
3 files changed, 122 insertions, 0 deletions
diff --git a/sys-block/nbdkit/Manifest b/sys-block/nbdkit/Manifest
index a15cca17ca1c..60eb811e64f5 100644
--- a/sys-block/nbdkit/Manifest
+++ b/sys-block/nbdkit/Manifest
@@ -1 +1,2 @@
DIST nbdkit-1.32.4.tar.gz 2342420 BLAKE2B 3ea6692a534548707bc488560b0f0bd0ddeb0daa4b2432da5de18a9a735408370c61b8c0a30d7d4ed6c915eb118948d2462ff4565036bec8a77c2c2fb712f4da SHA512 0eb1f0f492ce3558fba8d472b26f7ca3db7beeba411c98e7e06b55c5456399be56f6b4cd4adb54567f744f8e07986af9f676a983da052d174ce2e3c28109dbc5
+DIST nbdkit-1.36.1.tar.gz 2400838 BLAKE2B afbfbda18122b17cbcdcc5b3a04ab37b7dffb139d084b196ef45e33717f376af61189beb63b2541444eaae0ed860b752c20cfe9cf27bf06bfb04bba1b5ce60c8 SHA512 ca0e6e6729fb6f43a9717a3815dfb8ff54a2f182ef079e72b0e5e1b018c55f2205be52a10abc0b0a2243d0737f27b1ccf67c0d9586135454a460d39dad79f042
diff --git a/sys-block/nbdkit/metadata.xml b/sys-block/nbdkit/metadata.xml
index fef0d9dee6e7..ba85f17afedd 100644
--- a/sys-block/nbdkit/metadata.xml
+++ b/sys-block/nbdkit/metadata.xml
@@ -16,5 +16,6 @@
<flag name="libvirt">Enable the <pkg>app-emulation/libvirt</pkg> plugin.</flag>
<flag name="nbd">Enable the nbd plugin via <pkg>sys-libs/libnbd</pkg>.</flag>
<flag name="torrent">Enable the torrent plugin via <pkg>net-libs/libtorrent-rasterbar</pkg>.</flag>
+ <flag name="zlib-ng">Use <pkg>sys-libs/zlib-ng</pkg> to handle zlib decompression.</flag>
</use>
</pkgmetadata>
diff --git a/sys-block/nbdkit/nbdkit-1.36.1.ebuild b/sys-block/nbdkit/nbdkit-1.36.1.ebuild
new file mode 100644
index 000000000000..34ea8cc1967c
--- /dev/null
+++ b/sys-block/nbdkit/nbdkit-1.36.1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools optfeature bash-completion-r1
+
+DESCRIPTION="NBD server with stable plugin ABI and permissive license"
+HOMEPAGE="https://gitlab.com/nbdkit/nbdkit"
+SRC_URI="https://download.libguestfs.org/nbdkit/$(ver_cut 1-2)-stable/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="
+ curl ext2 nbd gnutls libguestfs libssh libvirt lzma selinux torrent
+ valgrind zlib zlib-ng zstd
+"
+
+RDEPEND="
+ virtual/libiconv
+ selinux? ( sys-libs/libselinux )
+ gnutls? ( net-libs/gnutls:= )
+ curl? ( net-misc/curl )
+ libssh? ( net-libs/libssh:= )
+ libvirt? ( app-emulation/libvirt:= )
+ zlib? ( sys-libs/zlib )
+ zlib-ng? ( sys-libs/zlib-ng )
+ nbd? ( sys-libs/libnbd )
+ lzma? ( app-arch/xz-utils )
+ zstd? ( app-arch/zstd:= )
+ libguestfs? ( app-emulation/libguestfs:= )
+ ext2? ( sys-fs/e2fsprogs )
+ torrent? ( net-libs/libtorrent-rasterbar:= )
+"
+DEPEND="
+ ${RDEPEND}
+ valgrind? ( dev-util/valgrind )
+"
+BDEPEND="
+ dev-lang/perl
+"
+
+src_prepare() {
+ default
+
+ # TODO(arsen): This test fails for some reason.
+ cat <<-HACK > tests/test-file-extents.sh || die
+ #!/bin/sh
+ echo Gentoo: This test is skipped
+ exit 77
+ HACK
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-extra=Gentoo
+
+ --with-iconv
+ --with-manpages
+
+ $(use_with selinux)
+ $(use_with gnutls)
+ $(use_with curl)
+ $(use_with libvirt)
+ $(use_with zlib)
+ $(use_with zlib-ng)
+ $(use_with nbd libnbd)
+ $(use_with lzma liblzma)
+ $(use_with zstd libzstd)
+ $(use_with libguestfs)
+ $(use_with ext2)
+ $(use_enable torrent)
+ $(use_enable valgrind)
+
+ --disable-linuxdisk # Not in Gentoo.
+ --disable-libfuzzer # Should not be used normally according to upstream
+ --without-libblkio # Not in Gentoo.
+ --without-bash-completions # Handled manually.
+
+ # TODO(arsen): Bindings left out
+ --disable-perl
+ --disable-python
+ --disable-ocaml
+ --disable-rust
+ --disable-ruby
+ --disable-tcl
+ --disable-lua
+ --disable-golang
+
+ # This just enabled a few code paths with no extra library
+ # dependencies, but it does have an extra xorriso runtime
+ # dependency. Seeing as it's optional, and it conflates BDEPEND
+ # and RDEPEND; I think it's okay to just specify that it uses
+ # XORRISO installed as xorriso. Maybe the user should be able
+ # to override this in the future if they prefer one of the other
+ # ISOPROGs?
+ --with-iso
+ ac_cv_prog_XORRISO=xorriso
+
+ # Involves proprietary code and a dlopen mess, see
+ # plugins/vddk/README.VDDK.
+ --disable-vddk
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+ dobashcomp bash-completion/nbdkit
+}
+
+pkg_postinst() {
+ optfeature "virtual ISO plugin via xorriso" dev-libs/libisoburn
+}