summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-18 10:27:18 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-18 10:30:14 +0100
commitf69493d12c0a11c49a8d5a6c7ba4f30967d6fcfe (patch)
tree5c54b832aeb66d2b1280536e58bce3aebd038536
parentdev-util/yacc: mark stable for the remaining arches. (diff)
downloadgentoo-f69493d12c0a11c49a8d5a6c7ba4f30967d6fcfe.tar.gz
gentoo-f69493d12c0a11c49a8d5a6c7ba4f30967d6fcfe.tar.bz2
gentoo-f69493d12c0a11c49a8d5a6c7ba4f30967d6fcfe.zip
dev-util/yacc: tidy up ebuild.
Package-Manager: portage-2.3.3
-rw-r--r--dev-util/yacc/yacc-1.9.1-r6.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/dev-util/yacc/yacc-1.9.1-r6.ebuild b/dev-util/yacc/yacc-1.9.1-r6.ebuild
index 0c253bf738b8..395b5d6091e3 100644
--- a/dev-util/yacc/yacc-1.9.1-r6.ebuild
+++ b/dev-util/yacc/yacc-1.9.1-r6.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Yacc: Yet Another Compiler-Compiler"
HOMEPAGE="http://dinosaur.compilertools.net/#yacc"
@@ -13,27 +13,23 @@ SRC_URI="ftp://metalab.unc.edu/pub/Linux/devel/compiler-tools/${P}.tar.Z"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
PATCHES=(
- # mkstemp patch from byacc ebuild
+ # mkstemp patch from byacc ebuild.
"${FILESDIR}"/${P}-mkstemp.patch
# The following patch fixes yacc to run correctly on ia64 (and
- # other 64-bit arches). See bug 46233
+ # other 64-bit arches). See bug 46233.
"${FILESDIR}"/${P}-ia64.patch
- # avoid stack access error, bug 232005
+ # Avoid stack access error. See bug 232005.
"${FILESDIR}"/${P}-CVE-2008-3196.patch
)
src_prepare() {
default
- # Use our CFLAGS and LDFLAGS
+ # Use our CFLAGS and LDFLAGS.
sed -i -e 's: -O : $(CFLAGS) $(LDFLAGS) :' Makefile || die 'sed failed'
}
@@ -51,7 +47,7 @@ src_install() {
pkg_preinst() {
# bison installs a /usr/bin/yacc symlink ...
# we need to remove it to avoid triggering
- # collision-protect errors #90089
+ # collision-protect errors. See bug 90089.
if [[ -L ${ROOT}/usr/bin/yacc ]]; then
rm -v "${ROOT}"/usr/bin/yacc || die
fi
@@ -59,7 +55,7 @@ pkg_preinst() {
pkg_postrm() {
# and if we uninstall yacc but keep bison,
- # lets restore the /usr/bin/yacc symlink
+ # let's restore the /usr/bin/yacc symlink.
if [[ ! -e ${ROOT}/usr/bin/yacc ]] && [[ -e ${ROOT}/usr/bin/yacc.bison ]]; then
ln -s yacc.bison "${ROOT}"/usr/bin/yacc || die
fi