summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-06 08:36:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-06 08:59:19 +0100
commitf6ba1bcfbb8856e297d5230c696b7cebb5984eb7 (patch)
tree11d209c224e94ee72fc1eb84b334e4f45eca6cca
parentdev-python/jupyter_client: Remove old (diff)
downloadgentoo-f6ba1bcfbb8856e297d5230c696b7cebb5984eb7.tar.gz
gentoo-f6ba1bcfbb8856e297d5230c696b7cebb5984eb7.tar.bz2
gentoo-f6ba1bcfbb8856e297d5230c696b7cebb5984eb7.zip
dev-python/jedi: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jedi/Manifest1
-rw-r--r--dev-python/jedi/jedi-0.18.1.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
index 7de7fa4cc6b1..946296b9216f 100644
--- a/dev-python/jedi/Manifest
+++ b/dev-python/jedi/Manifest
@@ -1,4 +1,3 @@
DIST django-stubs-fd057010f6cbf176f57d1099e82be46d39b99cb9.tar.gz 183312 BLAKE2B a68f6139903f5001db994ee0d881f40ab74932e81c3e2c3a0c22dc56e6be681d0fb42ce837603b21e4d0d448ccb25884ef0f69039305f309e82603267cee9f6a SHA512 506322c132f94e6a1e88cdbde6027a566387731fa6ad59934f95c3511f49d90eff2a3138363811be648b096407d418cd1f801df0bc35b1e464ef181e4076ada1
DIST jedi-0.18.1.gh.tar.gz 466884 BLAKE2B c2403b20447b27b1fb19c16d1131299154fcb767453116964b339bf7ef4a1ca20b6c3216c3fbd63c304dd2c0c02a67702d5228e1d847975b778597dc58b489d1 SHA512 c72dc4927fe44641ea57c61e68b3c74c3a3f70ddc2990454ba931026c288723e07263918ecbb4ecc6f79716d37e10a1b1448ae8cfc6d52465122b3d1e43bea25
-DIST jedi-0.18.1.tar.gz 466884 BLAKE2B c2403b20447b27b1fb19c16d1131299154fcb767453116964b339bf7ef4a1ca20b6c3216c3fbd63c304dd2c0c02a67702d5228e1d847975b778597dc58b489d1 SHA512 c72dc4927fe44641ea57c61e68b3c74c3a3f70ddc2990454ba931026c288723e07263918ecbb4ecc6f79716d37e10a1b1448ae8cfc6d52465122b3d1e43bea25
DIST typeshed-ae9d4f4b21bb5e1239816c301da7b1ea904b44c3.tar.gz 602044 BLAKE2B 53298918a7e9a1163e76d4c70ad2a2117ee90b49329aa82d82b2aaaeaf000c971872f83ed283af6dc4be068b813876760c8b1b4acb4131865572a4aed3ea9230 SHA512 b3b9da66b6c6e03e0b262b3262df31215a5e080468ca9ebf4332ed53d715cd3956db7067fad3ec267042ff704f81ac665c703ef2fd0c5b445d440bd8e52bf1aa
diff --git a/dev-python/jedi/jedi-0.18.1.ebuild b/dev-python/jedi/jedi-0.18.1.ebuild
deleted file mode 100644
index 6ae29b6d32a2..000000000000
--- a/dev-python/jedi/jedi-0.18.1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-TYPESHED_P="typeshed-ae9d4f4b21bb5e1239816c301da7b1ea904b44c3"
-DJANGO_STUBS_P="django-stubs-fd057010f6cbf176f57d1099e82be46d39b99cb9"
-
-DESCRIPTION="Autocompletion library for Python"
-HOMEPAGE="
- https://github.com/davidhalter/jedi/
- https://pypi.org/project/jedi/
-"
-SRC_URI="
- https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
- https://github.com/davidhalter/typeshed/archive/${TYPESHED_P#typeshed-}.tar.gz
- -> ${TYPESHED_P}.tar.gz
- https://github.com/davidhalter/django-stubs/archive/${DJANGO_STUBS_P#django-stubs-}.tar.gz
- -> ${DJANGO_STUBS_P/v/}.tar.gz
-"
-
-LICENSE="
- MIT
- test? ( Apache-2.0 )
-"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- =dev-python/parso-0.8*[${PYTHON_USEDEP}]
-"
-
-# RDEPEND needed because of an import jedi inside conf.py
-distutils_enable_sphinx docs \
- dev-python/parso \
- dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # upstream includes these as submodules ...
- rmdir "${S}"/jedi/third_party/{django-stubs,typeshed} || die
- mv "${WORKDIR}/${DJANGO_STUBS_P/v/}" \
- "${S}/jedi/third_party/django-stubs" || die
- mv "${WORKDIR}/${TYPESHED_P}" \
- "${S}/jedi/third_party/typeshed" || die
-
- # don't run doctests, don't depend on colorama
- sed -i "s:'docopt',:: ; s:'colorama',::" setup.py || die
- sed -i "s: --doctest-modules::" pytest.ini || die
-
- # test_complete_expanduser relies on $HOME not being empty
- > "${HOME}"/somefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # fragile
- test/test_speed.py
- # assumes pristine virtualenv
- test/test_inference/test_imports.py::test_os_issues
- )
- [[ ${EPYTHON} != python3.8 ]] && EPYTEST_DESELECT+=(
- # TODO
- 'test/test_integration.py::test_completion[lambdas:112]'
- )
-
- # some plugin breaks case-insensitivity on completions
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # django and pytest tests are very version dependent
- epytest -k "not django and not pytest"
-}