summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-06-08 21:16:16 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2021-06-08 21:16:55 +0200
commitf6c9f8ddad2e3edd98a520693ace9e60a31de68b (patch)
treeb9f37b4a32da9ed6817a515c3cbc8db1958bca52
parentdev-perl/Graph: keyworded 0.972.100 for ia64 (diff)
downloadgentoo-f6c9f8ddad2e3edd98a520693ace9e60a31de68b.tar.gz
gentoo-f6c9f8ddad2e3edd98a520693ace9e60a31de68b.tar.bz2
gentoo-f6c9f8ddad2e3edd98a520693ace9e60a31de68b.zip
net-p2p/nicotine+: 3.0.6 version bump.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
-rw-r--r--net-p2p/nicotine+/Manifest1
-rw-r--r--net-p2p/nicotine+/nicotine+-3.0.6.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-p2p/nicotine+/Manifest b/net-p2p/nicotine+/Manifest
index 332effcd8265..ab1551bb4f5d 100644
--- a/net-p2p/nicotine+/Manifest
+++ b/net-p2p/nicotine+/Manifest
@@ -1,3 +1,4 @@
DIST nicotine+-2.2.2.tar.gz 3373462 BLAKE2B 6dbcf4e9d7f85bb2e03194047c8ca9c374ae762967414d888e764e84b25682148245cf84c27ab967279f4ac5e3bad680a7920d3da7896e61d12413194c9ad207 SHA512 5d863b94d1a899701f3d6cd98d875a4ca782778b00d77fe3c490af59168592011a83f823feac6c0e71bdd4c5cfd743e023066d542d8778b68854344b73c322a1
DIST nicotine+-3.0.2.tar.gz 3126152 BLAKE2B 8575c61fc32083e687eac841e403366c516e0420c792bad2bf31b49b83dd80d2b99ace20879f7968dffd0d48e52bc6c6638300216b4eae44773c0723888ca96e SHA512 297aab9b6016df4b45e065d5e6493e237e99ef6ebbd475b7ccf66d2c476053f77c72c2ecd672c20046b422dc1f5eb431e701de687d33f2364619de5643ccef6d
DIST nicotine+-3.0.4.tar.gz 3141967 BLAKE2B d58072026ee766d81ca88dd4a11aa72f7aaee7a6e37c966e7d4cd0bdee40c8ef6537f01ea92c006b12e9692612d63fffd744011b982ee4cada2df03d2abae064 SHA512 8cc02b8b269267cc775b21ec246d84b932c1c7ef8f0983c63e3bb21de5b4c0de5fa65acdb0a07240b90c3529648f500d43fffbc0a462a260e534e86653a332a8
+DIST nicotine+-3.0.6.tar.gz 2786594 BLAKE2B 69b43c3eec37c8a01a0bd42cd11c02580a5be9ca994106e34e7f588eaabb7cfa85fd312bd527d453e62b3f8c0fb4f031eedf06207e3c1d8602e822958d98ee65 SHA512 42846568948d45559206c85c7ed708be044a5cf55f994318c209506dcc9024d6ccfd141fa21ca57f00c320a1a5ec3ab09faf211ebd442bf1d5060b960f43e8c2
diff --git a/net-p2p/nicotine+/nicotine+-3.0.6.ebuild b/net-p2p/nicotine+/nicotine+-3.0.6.ebuild
new file mode 100644
index 000000000000..3717d1e247d6
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-3.0.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
+SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ ${DEPEND}
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nicotine-plus-${PV}"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/share/doc/nicotine" "${ED}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}