summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-28 04:34:15 +0000
committerSam James <sam@gentoo.org>2022-01-28 05:16:40 +0000
commitf6ef74b63e177786e2af3f7a95fa87aba733a988 (patch)
tree263610b7fe06bbf59324f498e3a04aba4be1e3f3
parentapp-forensics/yara: run tests; misc. other changes (diff)
downloadgentoo-f6ef74b63e177786e2af3f7a95fa87aba733a988.tar.gz
gentoo-f6ef74b63e177786e2af3f7a95fa87aba733a988.tar.bz2
gentoo-f6ef74b63e177786e2af3f7a95fa87aba733a988.zip
dev-python/yara-python: run tests, convert to PEP517
Closes: https://bugs.gentoo.org/576956 See: https://github.com/gentoo/gentoo/pull/23800 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/yara-python/yara-python-4.1.3.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/yara-python/yara-python-4.1.3.ebuild b/dev-python/yara-python/yara-python-4.1.3.ebuild
index 54194680cc20..a8ccc85b7d96 100644
--- a/dev-python/yara-python/yara-python-4.1.3.ebuild
+++ b/dev-python/yara-python/yara-python-4.1.3.ebuild
@@ -3,8 +3,8 @@
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
-
inherit distutils-r1
DESCRIPTION="Python interface for a malware identification and classification tool"
@@ -16,9 +16,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="${PYTHON_DEPS}
- =app-forensics/yara-4.1*"
+ =app-forensics/yara-$(ver_cut 1-2)*"
DEPEND="${RDEPEND}"
+distutils_enable_tests unittest
+
src_compile() {
compile_python() {
distutils-r1_python_compile --dynamic-linking