summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-08-29 16:18:41 -0400
committerCraig Andrews <candrews@gentoo.org>2020-08-29 16:22:27 -0400
commitf70bba01a05e0ec7cccd20f03ac506d606694fc2 (patch)
treed3900d7c5df1ac71be7300ca0d526c1d0c350eed
parentnet-p2p/syncthing: Stabilize 1.7.1 arm, #739256 (diff)
downloadgentoo-f70bba01a05e0ec7cccd20f03ac506d606694fc2.tar.gz
gentoo-f70bba01a05e0ec7cccd20f03ac506d606694fc2.tar.bz2
gentoo-f70bba01a05e0ec7cccd20f03ac506d606694fc2.zip
media-plugins/kodi-peripheral-joystick: 1.6.1 version bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--media-plugins/kodi-peripheral-joystick/Manifest1
-rw-r--r--media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.6.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/media-plugins/kodi-peripheral-joystick/Manifest b/media-plugins/kodi-peripheral-joystick/Manifest
index 4dc9335fbbee..11ce18181814 100644
--- a/media-plugins/kodi-peripheral-joystick/Manifest
+++ b/media-plugins/kodi-peripheral-joystick/Manifest
@@ -3,3 +3,4 @@ DIST kodi-peripheral-joystick-1.4.7.tar.gz 90671 BLAKE2B 281a1d821586224ad155ac6
DIST kodi-peripheral-joystick-1.4.8.tar.gz 90965 BLAKE2B b9bb3aa6e1a5531c304f2f3466bac8f00cffcd771065052d41645f48316c7b246fa07823395aeaa484ca9839d1b8025e6640e7cb504d29642d52c02a1fb21553 SHA512 4ca692589050c225bb9ec45b79f3532a4c572c57b3c2400dd4afa398c3d77194136ffde7bc85b7d24700d7eafb0f813cc3fce5dc48d4de51869fad0f68679939
DIST kodi-peripheral-joystick-1.4.9.tar.gz 111161 BLAKE2B bcee8aedff118cbceec050ae1b6c0a559aeb735c539624f59ae59648107937b5a904ed24bc1c323443e00289d78b2c1b83ff8e18fc9affb22b8ca706b115fb12 SHA512 6d5d8e5922c7b9c38a55372da585366331f550864ee7d95369bb8b32897250b38d4cbb0e2f5fc7eb91aea34f09f6f33a62b148f731f422ac1b6ead9b2eac4ae5
DIST kodi-peripheral-joystick-1.6.0.tar.gz 117163 BLAKE2B 24e6eb1b4b4310fc3fc452a719094cdaac7caf7ef4825add4a9bcde453044e5a352b859b0c247fa445bde5554a3b82e40c65f185adc524f855140126716a3e27 SHA512 9fd11af0e75a80cfd1086caf29213616a441c0f8c5066ab2d54dac94603240c5f13af9048ae0691f6bd34511ac36c8cf478cdd6cd179ef97f282ae82f932e0fe
+DIST kodi-peripheral-joystick-1.6.1.tar.gz 117588 BLAKE2B c117990d6dc90ff53f4d23e08288df1cfe2fa0f685498a9f9630a07e6ee36207af3c2ed6faf81746e06bdcd94674cd89d97fe6ff75ea5263754c4eba10498605 SHA512 3907fea59d1919f9580e17e01b672aa525b106cb126dc6e7c873fe20b8dd68f395f39fb52ae08a02206a1c301523cd9a2b2f67076cb5e6c4b582d46800a892c7
diff --git a/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.6.1.ebuild b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.6.1.ebuild
new file mode 100644
index 000000000000..b29f362fab00
--- /dev/null
+++ b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Libretro compatibility layer for the Kodi Game API"
+HOMEPAGE="https://github.com/xbmc/peripheral.joystick"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_BRANCH="Matrix"
+ EGIT_REPO_URI="https://github.com/xbmc/peripheral.joystick.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ CODENAME="Matrix"
+ SRC_URI="https://github.com/xbmc/peripheral.joystick/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/peripheral.joystick-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ dev-libs/libpcre
+ dev-libs/tinyxml
+ "
+RDEPEND="
+ ${DEPEND}
+ "