summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2019-03-20 23:13:18 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-26 09:58:42 +0100
commitf733c76af6f80c66c237d1f905d2b488671d9e6f (patch)
tree8e9a3955fcb7388568e83e1046230b999dbb0439
parentdev-python/flexmock: Bump to v0.10.4 (diff)
downloadgentoo-f733c76af6f80c66c237d1f905d2b488671d9e6f.tar.gz
gentoo-f733c76af6f80c66c237d1f905d2b488671d9e6f.tar.bz2
gentoo-f733c76af6f80c66c237d1f905d2b488671d9e6f.zip
x11-wm/i3: Bump to 4.16.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Nelo-T. Wallus <nelo@wallus.de> Closes: https://github.com/gentoo/gentoo/pull/11429 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--x11-wm/i3/Manifest1
-rw-r--r--x11-wm/i3/i3-4.16.1.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/x11-wm/i3/Manifest b/x11-wm/i3/Manifest
index 37fd66cefdd6..815dd0648016 100644
--- a/x11-wm/i3/Manifest
+++ b/x11-wm/i3/Manifest
@@ -2,4 +2,5 @@ DIST i3-4.13.tar.bz2 1121298 BLAKE2B 94f3940406d43083c8dc577b4216a32a08ad4c4b58e
DIST i3-4.14.1.tar.bz2 1173560 BLAKE2B 96a0e1d75be13098fd530c3970464ce7710063f517c0d538939de6e7c799ab6b3ec005fb50216b1db4ccefd44584c584b263ac359bd9a86be53418d8f8d4beba SHA512 ef628af002947b40e1c88b0e872c6e93d4377a9674a120bd9adc3f323a38570b05124cd3047b5a26659e72070de2d00d83fb93186510c74ad8ddbf4f3df85472
DIST i3-4.14.tar.gz 3936748 BLAKE2B 42678130be56bc695e5700e978ddbd34bfdaeda7a65252a05568581d76fe613e80e710f3a507110e7988077fe62048bf984d4009e722d877b178206cef600221 SHA512 fe3db78813987a15ed93d182968bcd5139e1d03f29d3e8effd9fce59f87bc8309407af0b2fa5f1cd83b8583e50ea0ade6b8eafc5dda6dea9161832dc9cebfdfe
DIST i3-4.15.tar.bz2 1196263 BLAKE2B 36f20327202957dba30aface91af4d2c6261979e726584712a508a11cb4a612d812e771dc9f28ec4cfcbf3ebc9d92c72f5e940048516cca0f185eab20f95ae32 SHA512 60ab61b7e380342126bea12fb4371f98fcf18f6435f79a9519d3f59cfabdb170634366036e1aa20c5592da0832b03140ad1f0c72bad3cfaace0b7c57ad01dfc4
+DIST i3-4.16.1.tar.bz2 1211532 BLAKE2B 64a6996c0b89516069b58bf1cba92908a7f61ab04d66659b612b27411eb92fa9d49a7214eccdba33e7c33605b5f9247f69c1f0e23de629552edf113ab7520747 SHA512 3e328f8c7216697c5e484ca854605350f78844e24cc6cfb9c10e71368c2c0457387a14f819abdf8be2370d437889297f452fbf63f3924766ca81c157ab27e1b0
DIST i3-4.16.tar.bz2 1213251 BLAKE2B a65d15278a83bac9903a611628ea53c64cd554ab9fff2a8864e649fd962858b2f3e77fe69d0dc70affc93dc69b3cbbd7b3ee670a2af9d697e28e9e4ea3323f67 SHA512 99abd15349ee8e61c084b3664ef3a189c92ea07812ac59eb6a5441df7cebea8211be52204e39bddcc33d8c714447fddbbe2c5c8a25b756a96e2dc6732526cbf8
diff --git a/x11-wm/i3/i3-4.16.1.ebuild b/x11-wm/i3/i3-4.16.1.ebuild
new file mode 100644
index 000000000000..40e2cfb9d89d
--- /dev/null
+++ b/x11-wm/i3/i3-4.16.1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools out-of-source virtualx
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="https://i3wm.org/"
+SRC_URI="https://i3wm.org/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc debug test"
+
+CDEPEND="dev-libs/libev
+ dev-libs/libpcre
+ >=dev-libs/yajl-2.0.3
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+ x11-misc/xkeyboard-config
+ >=x11-libs/cairo-1.14.4[X,xcb]
+ >=x11-libs/pango-1.30.0[X]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-perl/AnyEvent
+ >=dev-perl/X11-XCB-0.120.0
+ dev-perl/Inline
+ dev-perl/Inline-C
+ dev-perl/IPC-Run
+ dev-perl/ExtUtils-PkgConfig
+ dev-perl/local-lib
+ >=virtual/perl-Test-Simple-0.940.0
+ x11-base/xorg-server[xephyr]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS"
+BDEPEND="virtual/pkgconfig"
+
+# Test without debug will apply optimization levels, which results
+# in type-punned pointers - which in turn causes test failures.
+REQUIRED_USE="test? ( debug )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.16-musl-GLOB_TILDE.patch"
+)
+
+# https://github.com/i3/i3/issues/3013
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+
+ eautoreconf
+}
+
+my_src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+my_src_test() {
+ emake \
+ test.commands_parser \
+ test.config_parser \
+ test.inject_randr15
+
+ virtx perl \
+ -I "${S}/testcases/lib" \
+ -I "${BUILD_DIR}/testcases/lib" \
+ testcases/complete-run.pl
+}
+
+my_src_install_all() {
+ doman man/*.1
+
+ einstalldocs
+ use doc && dodoc -r docs "RELEASE-NOTES-${PV}"
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}/i3wm"
+}
+
+pkg_postinst() {
+ # Only show the elog information on a new install
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "There are several packages that you may find useful with ${PN} and"
+ elog "their usage is suggested by the upstream maintainers, namely:"
+ elog " x11-misc/dmenu"
+ elog " x11-misc/i3status"
+ elog " x11-misc/i3lock"
+ elog "Please refer to their description for additional info."
+ fi
+}