summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2018-08-15 17:43:27 +0100
committerJonathan Scruggs <dracwyrm@gentoo.org>2018-08-15 18:20:47 +0100
commitf76dac14be61f812f1b2eb759f40c3dad9211ad2 (patch)
tree55d58ec4606f62deeccaa9dd393b76906288c359
parentsys-kernel/gentoo-sources: Linux patch 4.17.15 (diff)
downloadgentoo-f76dac14be61f812f1b2eb759f40c3dad9211ad2.tar.gz
gentoo-f76dac14be61f812f1b2eb759f40c3dad9211ad2.tar.bz2
gentoo-f76dac14be61f812f1b2eb759f40c3dad9211ad2.zip
media-libs/blender: change depends for OpenVDB 5.x compat
Only v2.79b and above will be compatible with OpenVDB 5.x, so make sure previous versions depend on OpenVDB 4.x. Change depend on ffmpeg because v4.x is not supported. Closes: https://bugs.gentoo.org/655030 Closes: https://github.com/gentoo/gentoo/pull/9580
-rw-r--r--media-gfx/blender/blender-2.79-r1.ebuild4
-rw-r--r--media-gfx/blender/blender-2.79.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/media-gfx/blender/blender-2.79-r1.ebuild b/media-gfx/blender/blender-2.79-r1.ebuild
index 588dd53d606..2db487bd238 100644
--- a/media-gfx/blender/blender-2.79-r1.ebuild
+++ b/media-gfx/blender/blender-2.79-r1.ebuild
@@ -48,7 +48,7 @@ RDEPEND="${PYTHON_DEPS}
collada? ( >=media-libs/opencollada-1.6.18:= )
colorio? ( media-libs/opencolorio )
cuda? ( dev-util/nvidia-cuda-toolkit:= )
- ffmpeg? ( media-video/ffmpeg:=[x264,mp3,encode,theora,jpeg2k?] )
+ ffmpeg? ( <media-video/ffmpeg-4.0:=[x264,mp3,encode,theora,jpeg2k?] )
libav? ( >=media-video/libav-11.3:=[x264,mp3,encode,theora,jpeg2k?] )
fftw? ( sci-libs/fftw:3.0= )
!headless? (
@@ -74,7 +74,7 @@ RDEPEND="${PYTHON_DEPS}
)
opensubdiv? ( >=media-libs/opensubdiv-3.3.0:=[cuda=,opencl=] )
openvdb? (
- media-gfx/openvdb[${PYTHON_USEDEP},abi3-compat(+),openvdb-compression(+)]
+ <media-gfx/openvdb-5.0.0:=[${PYTHON_USEDEP},abi3-compat]
dev-cpp/tbb
>=dev-libs/c-blosc-1.5.2
)
diff --git a/media-gfx/blender/blender-2.79.ebuild b/media-gfx/blender/blender-2.79.ebuild
index 145205ce35b..7a99f994dd2 100644
--- a/media-gfx/blender/blender-2.79.ebuild
+++ b/media-gfx/blender/blender-2.79.ebuild
@@ -48,7 +48,7 @@ RDEPEND="${PYTHON_DEPS}
collada? ( >=media-libs/opencollada-1.6.18:= )
colorio? ( media-libs/opencolorio )
cuda? ( dev-util/nvidia-cuda-toolkit:= )
- ffmpeg? ( media-video/ffmpeg:=[x264,mp3,encode,theora,jpeg2k?] )
+ ffmpeg? ( <media-video/ffmpeg-4.0:=[x264,mp3,encode,theora,jpeg2k?] )
libav? ( >=media-video/libav-11.3:=[x264,mp3,encode,theora,jpeg2k?] )
fftw? ( sci-libs/fftw:3.0= )
!headless? (
@@ -74,7 +74,7 @@ RDEPEND="${PYTHON_DEPS}
)
opensubdiv? ( >=media-libs/opensubdiv-3.3.0:=[cuda=,opencl=] )
openvdb? (
- media-gfx/openvdb[${PYTHON_USEDEP},abi3-compat(+),openvdb-compression(+)]
+ <media-gfx/openvdb-5.0.0:=[${PYTHON_USEDEP},abi3-compat]
dev-cpp/tbb
>=dev-libs/c-blosc-1.5.2
)