summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-11-06 11:09:56 -0500
committerCraig Andrews <candrews@gentoo.org>2017-11-06 11:09:56 -0500
commitf78525306ef8ed4c50b89f77b8260ef03825157a (patch)
tree7f728ec678cecc0baf3b2bcfa8a944dee13de50a
parentapp-text/poppler: Bump to version 0.61.0 (diff)
downloadgentoo-f78525306ef8ed4c50b89f77b8260ef03825157a.tar.gz
gentoo-f78525306ef8ed4c50b89f77b8260ef03825157a.tar.bz2
gentoo-f78525306ef8ed4c50b89f77b8260ef03825157a.zip
dev-cpp/waylandpp: version bump 0.1.4
Package-Manager: Portage-2.3.13, Repoman-2.3.4
-rw-r--r--dev-cpp/waylandpp/Manifest1
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.1.4.ebuild41
-rw-r--r--dev-cpp/waylandpp/waylandpp-9999.ebuild2
3 files changed, 43 insertions, 1 deletions
diff --git a/dev-cpp/waylandpp/Manifest b/dev-cpp/waylandpp/Manifest
index 721254e78e76..71c0b35f3c4d 100644
--- a/dev-cpp/waylandpp/Manifest
+++ b/dev-cpp/waylandpp/Manifest
@@ -1,2 +1,3 @@
DIST waylandpp-0.1.0.tar.gz 166427 SHA256 117df357cbd1f272737b6379e05925b38bad41bafda02761017530053fa950e7 SHA512 e0521ea99eeb7ae196ed9c8759e10d28406c5b99534b52ac51845cdd9c384ff820e4cc1fec65c537a0d071046746884793da122c72f6e75e7df4bca089d19eca WHIRLPOOL 1d589fbe1884dbd38547a0957b07533e3029cca7453618375227d87afa90fa36eded62283bf302139920860c90b250aeaca9b48e0f8098b0f9f8bbaffa889067
DIST waylandpp-0.1.2.tar.gz 166624 SHA256 fabf0b512285abea77678d9e079009569e9eb3fd98c6b851d50bc5b6c781c7d8 SHA512 2304390be26134561fb69e208a6bafd0e9789e6b212ff2f46384c6ed50ae1c9eca3f06a3b4958c8e710cc1a0be61ed84c7ff292ec7011dbb0396cd2d83363f7f WHIRLPOOL 2633f41c0038c5f353ce7d9771c09d7a60ade11e9e7d0209180fb9f450437b37c3feebc955568335ce3371aae9b5083ab3425a8256157c5e7f94e0bd009ea3df
+DIST waylandpp-0.1.4.tar.gz 168409 SHA256 fc767573f7334525839221ac52e3dc4b56ebaf3f7a7cdaf4f05eb6baa6dd88ab SHA512 3f2e9bca0776c02ec3b7a4f76a34214333e0663e2ab81d81cfbc37e1f14bda47e16b3840386b961d47ca993207b0b9f4d4859b621f22fe4e3653c4b14842e001 WHIRLPOOL 75f2ebf6725fcbfa414bfede676289167ec1118964479f2c3b23233183684769eb59d12dceb20359fe9d444f2934e032fd883c1bf2682339c8523b2eeda753e8
diff --git a/dev-cpp/waylandpp/waylandpp-0.1.4.ebuild b/dev-cpp/waylandpp/waylandpp-0.1.4.ebuild
new file mode 100644
index 000000000000..e8100f35eb98
--- /dev/null
+++ b/dev-cpp/waylandpp/waylandpp-0.1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils versionator
+
+DESCRIPTION="Wayland C++ bindings"
+HOMEPAGE="https://github.com/NilsBrause/waylandpp"
+
+LICENSE="MIT"
+IUSE="doc"
+SLOT="0/$(get_major_version)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-libs/wayland-1.11.0
+ media-libs/mesa[wayland]
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ "
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/waylandpp/waylandpp-9999.ebuild b/dev-cpp/waylandpp/waylandpp-9999.ebuild
index 73572d42b7ab..e8100f35eb98 100644
--- a/dev-cpp/waylandpp/waylandpp-9999.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-9999.ebuild
@@ -34,7 +34,7 @@ DEPEND="${RDEPEND}
src_configure() {
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)
- -DINSTALL_DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
)
cmake-utils_src_configure