summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-08-28 09:45:44 +0200
committerUltrabug <ultrabug@gentoo.org>2018-08-29 22:57:22 +0200
commitf7b2c142b2c42b219248f6118f06fc9d45991d24 (patch)
tree4ff96861121000897d55431f43df2c89947079c0
parentnet-analyzer/wireshark: Version 2.6.3. (diff)
downloadgentoo-f7b2c142b2c42b219248f6118f06fc9d45991d24.tar.gz
gentoo-f7b2c142b2c42b219248f6118f06fc9d45991d24.tar.bz2
gentoo-f7b2c142b2c42b219248f6118f06fc9d45991d24.zip
app-admin/mongo-tools: bump to 3.6.7
Package-Manager: Portage-2.3.48, Repoman-2.3.10 Closes: https://github.com/gentoo/gentoo/pull/9717
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.6.7.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index 258a50c07691..9c4a955c7323 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -11,5 +11,6 @@ DIST mongo-tools-3.6.3.tar.gz 4693833 BLAKE2B fc7139984cf3dcb7b4ce6f6c2028296651
DIST mongo-tools-3.6.4.tar.gz 4693872 BLAKE2B 5d72b32fa8ad7bc106c6ea3c09a27a093b9a1ae2392b4fa534042c5461fdc2b958dcbbf32e0ed596be234921e2ee21cc8f6132d57ae870a234abfc7adbb3b2e9 SHA512 53d06fa4a1b58de8001d6bf6e85f7edc97ce2cfbbb69c1ab05219deaa05ad9dd77d93f98c5526b4f58644a766e1b0f123686358095f059c71a4277634603f23f
DIST mongo-tools-3.6.5.tar.gz 4720814 BLAKE2B 5dd064f70557ec1ab979d08523f3dd305fb310c533b69bc99be3ad3d006036354f62b9f3d61c242e1481a254bed538a5e1cf5662f0e35705f1c50a76f31fddbb SHA512 dd2d7cc64043b42a70b5de0ea493f94722a4476248bfd77d6892861e4be6ab20175992367965dfd687bf8b7ebece6113b7f7a3e59256497e3ecd7e2678875965
DIST mongo-tools-3.6.6.tar.gz 4723751 BLAKE2B 876d46c47190398d1218a760bdeb8167c9224ef000a96b5f6080d6dcd44fe8187fdfbc38b1a61dbf437132e16e053212cf122daec3915647448d114983e51fc3 SHA512 b8cc02626accb90d8dacf50ea851619885a01503e28b17ed6a12cc9ccec2680a8cd12a566b32187d472f74c9625bf013afcdebed1a42d78ff613c49d3fc838b2
+DIST mongo-tools-3.6.7.tar.gz 4723244 BLAKE2B 82a61b8e72122a9a2b80aceeaa6767fcb13740c324c83c53b18297d9138807950dc656506ffd8a694d2f697c934342541c0ca6f62539bb07be266093e82a17a6 SHA512 5367259f27cf21234db2f69693fc2e21051b42b1acc7eaf8f9b366ed264943cff179c8565239fe36bb1d5d21f5e08ec58ff0df5d4c60526d321d63389f37fac2
DIST mongo-tools-4.0.0.tar.gz 10872217 BLAKE2B 84e92178c0e4827926de525a70d6124635d59e270a3d37e23ec8653cc64d99bb7489fa6266917437ca45aa3ca5e00bc59b81e65c5b72e717db2701c6f7327bec SHA512 d67c4aca9b41266109adc39bb1a642206738fda393e1f9f05570c02a00a02e29ec71c71e67ad232c72d66543ae7e7bfe07fbcf26958d48ed0e631da452c1904d
DIST mongo-tools-4.0.1.tar.gz 10872813 BLAKE2B 21b36c550ee7147b013414d24042ca720d3fdb961759d8857b0ffb3ba1aa3f7f3bcb363c97287d1c7084dae246f9d7f49d2d0d5c8a11bc939fa9d3113b4c2b6e SHA512 69355ca7c8d97a9a8b257aa1cde672b3b4af7ceb5b37e2cf601746e102ca6ac290ec35c20728fdb6736dd28feb8e6b6e1b948e88fd2fb4c9b53c8a3cd3688d67
diff --git a/app-admin/mongo-tools/mongo-tools-3.6.7.ebuild b/app-admin/mongo-tools/mongo-tools-3.6.7.ebuild
new file mode 100644
index 000000000000..8461951acd0c
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.6.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl ssl"
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # 1) ensure we use bash wrt #582906
+ # 2) do not substitute version because it uses git
+ sed -e 's@/bin/sh@/bin/bash@g' \
+ -e '/^sed/,+3d' \
+ -e '/^stty/d' \
+ -e '/^mv/d' \
+ -i build.sh || die
+
+ # build pie to avoid text relocations wrt #582854
+ # skip on ppc64 wrt #610984
+ if ! use ppc64; then
+ sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
+ fi
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ ./build.sh "${myconf[@]}" || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}