summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-07-16 19:33:48 -0500
committerMatt Turner <mattst88@gentoo.org>2018-07-17 07:15:22 -0700
commitf81770e41df51ad850fa78d6f57d7972a9e536bf (patch)
tree31724a26b60e43d7de391c7f49c0fdeb967936e9
parentx11-drivers/xf86-video-amdgpu: port to EAPI 7 (diff)
downloadgentoo-f81770e41df51ad850fa78d6f57d7972a9e536bf.tar.gz
gentoo-f81770e41df51ad850fa78d6f57d7972a9e536bf.tar.bz2
gentoo-f81770e41df51ad850fa78d6f57d7972a9e536bf.zip
x11-drivers/xf86-video-ati: port to EAPI 7
Package-Manager: Portage-2.3.41, Repoman-2.3.9
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-18.0.1-r2.ebuild66
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild48
2 files changed, 101 insertions, 13 deletions
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-18.0.1-r2.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-18.0.1-r2.ebuild
new file mode 100644
index 000000000000..56d17e3405a9
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-18.0.1-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="https://www.x.org/wiki/ati/"
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/driver/${PN}"
+ inherit autotools git-r3
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/driver/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+glamor udev"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=x11-libs/libdrm-2.4.78[video_cards_radeon]
+ >=x11-libs/libpciaccess-0.8.0
+ glamor? ( x11-base/xorg-server[glamor] )
+ udev? ( virtual/libudev:= )
+"
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+ else
+ CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+ fi
+ fi
+ check_extra_config
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ $(use_enable glamor)
+ $(use_enable udev)
+ )
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
index 3f5390aec7a0..56d17e3405a9 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
@@ -1,28 +1,40 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-XORG_DRI=always
-inherit linux-info xorg-2
+inherit linux-info
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="https://www.x.org/wiki/ati/"
if [[ ${PV} == 9999* ]]; then
- SRC_URI=""
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/driver/${PN}"
+ inherit autotools git-r3
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
else
+ SRC_URI="mirror://xorg/driver/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
fi
-DESCRIPTION="ATI video driver"
-HOMEPAGE="https://www.x.org/wiki/ati/"
-
+LICENSE="MIT"
+SLOT="0"
IUSE="+glamor udev"
-RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_radeon]
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=x11-libs/libdrm-2.4.78[video_cards_radeon]
>=x11-libs/libpciaccess-0.8.0
glamor? ( x11-base/xorg-server[glamor] )
- udev? ( virtual/libudev:= )"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
+ udev? ( virtual/libudev:= )
+"
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
pkg_pretend() {
if use kernel_linux ; then
@@ -35,10 +47,20 @@ pkg_pretend() {
check_extra_config
}
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] eautoreconf
+}
+
src_configure() {
- XORG_CONFIGURE_OPTIONS=(
+ local econfargs=(
$(use_enable glamor)
$(use_enable udev)
)
- xorg-2_src_configure
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
}