summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-06-23 12:12:38 +0000
committerIan Whyman <thev00d00@gentoo.org>2020-06-27 09:05:32 +0100
commitf82cc9ef3aaa9acc202b39a9d73a95894812c093 (patch)
treef1b5f236d866013de4c86d2420a09cef485cb68c
parentdev-perl/Config-Grammar: Bump to version 1.130.0 (diff)
downloadgentoo-f82cc9ef3aaa9acc202b39a9d73a95894812c093.tar.gz
gentoo-f82cc9ef3aaa9acc202b39a9d73a95894812c093.tar.bz2
gentoo-f82cc9ef3aaa9acc202b39a9d73a95894812c093.zip
dev-python/rarfile: bump to 3.1, fix tests
Bump rarfile to 3.1, which fixes the test failures reported (and more). To fix all of them, we needed to switch to Pytest, which upstream support in the new release, which is good news given Nose is on the way out. Closes: https://bugs.gentoo.org/729032 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Closes: https://github.com/gentoo/gentoo/pull/16407 Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
-rw-r--r--dev-python/rarfile/Manifest1
-rw-r--r--dev-python/rarfile/rarfile-3.1.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/rarfile/Manifest b/dev-python/rarfile/Manifest
index 896fa48cfa2d..4accbe0769cb 100644
--- a/dev-python/rarfile/Manifest
+++ b/dev-python/rarfile/Manifest
@@ -1 +1,2 @@
DIST rarfile-3.0.tar.gz 110665 BLAKE2B bdafa33600f1c7791af40f4e8c7b6a43e502980dab22bf6792a1b19eab53ea6c29bb6cb2ae4989b9f43d58c326b89ce466b9e2f82f60bad4892131895b15d400 SHA512 b0b816bf09fe455e4d8d35b447c30e7810468a6927555164a1b513d4161f3fd4e77a37439620bd935c3a12e46b1e5eda3e35d7d281899d2f9fd26b6e989aa6e4
+DIST rarfile-3.1.tar.gz 121579 BLAKE2B 3419eb0433866e060cc55fb94806a1ef0591c811e3b88eac97b05519e8e72cdb7da1e7f19fec1d5cadf60fa4caba4717cafe3fb1133556ef2d6f327da52c8c34 SHA512 eb910b0adfd1f28497163aa7994ab268d7780707e09931cb01014ffa51d985410b0bc17e5fb9ca133992b28115a0b5f443d01215624145d280f29e7065abb9d9
diff --git a/dev-python/rarfile/rarfile-3.1.ebuild b/dev-python/rarfile/rarfile-3.1.ebuild
new file mode 100644
index 000000000000..f7282bc66968
--- /dev/null
+++ b/dev-python/rarfile/rarfile-3.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Module for RAR archive reading"
+HOMEPAGE="https://github.com/markokr/rarfile"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compressed"
+
+RDEPEND="compressed? ( || ( app-arch/unrar app-arch/rar ) )"
+
+distutils_enable_tests pytest