summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-15 09:17:31 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-15 09:27:16 +0100
commitf85f24fc12198ae5de362cf7cb63c3f7436af315 (patch)
treeaea2f4662f6ca57355fa8f82f509fb9f31dc1691
parentdev-python/rjsmin: Bump to 1.2.0 (diff)
downloadgentoo-f85f24fc12198ae5de362cf7cb63c3f7436af315.tar.gz
gentoo-f85f24fc12198ae5de362cf7cb63c3f7436af315.tar.bz2
gentoo-f85f24fc12198ae5de362cf7cb63c3f7436af315.zip
dev-python/websockets: Bump to 10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/websockets/Manifest1
-rw-r--r--dev-python/websockets/websockets-10.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index 70d22f3e2853..84a8b95eb32a 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -1,3 +1,4 @@
DIST websockets-10.0-src.tar.gz 276231 BLAKE2B 6170f0540bc33be3d9a71f596ffee58e6e43c2173239a8fffe4f0c2a7555f8ce26849d85ed7865a5df6a4401f01bb0c928a341598916487cc79152a5031e9bbc SHA512 532289dc411d11cffc6e5aa07013cdad9655f124fbbd5dbdfe92985caf554644976a521466b1d3cbe124de11809e395b5e83195eac87495585779591b189c4d7
+DIST websockets-10.1-src.tar.gz 299315 BLAKE2B 425e7c8597f081874127ac75003aed11ebb2cf647ce9fed9e17c955e485a7a59c95d1112524d3f0d747b796b0cc41972258661c9fc9c7972f68aaebe3223b596 SHA512 c284ec92bc133c7083a72d4f364d9ace13d3eb6d7355ae46084d8097c137cdec3933cae9d5ab72d8a517af38328cea6c39877f747f5386df54a7362271cc7e7b
DIST websockets-9.1-python-3.10-support.patch.gz 6940 BLAKE2B e4835c7d5efaf956d07b884c85e0b95f26674bf36164fa8362d1c1a564a959bde761d25e747333c58864f74a5ea1b199f228a46ec6a1647c5495ea032020c179 SHA512 7fb4b298a9167c8d913e293fa7549b21d5acb333a5b97e0624a22cb83548ef548b819ac23750c40295140b6f83a701c73a81fdcaed3ab8e704dbee8e17d22f1d
DIST websockets-9.1-src.tar.gz 191813 BLAKE2B cb3807f01e1a4c22a40bf5150d1e8b21ca786dc5bc4da8f3e6602971f3f7c79b57092f5ddfe3ee52ec00e7fd15f3a992fdbb94b5e26599f2621a7f51434ba6dd SHA512 ff2907a913ff0b8ced6dda72b6fc6512a2ece3ffded2e2dcb8ff6805de9ad504430cc1871c1f6e02ab8069e7b96b2e7609afaf3c9c25f9271b28e2daa72bd3ac
diff --git a/dev-python/websockets/websockets-10.1.ebuild b/dev-python/websockets/websockets-10.1.ebuild
new file mode 100644
index 000000000000..3cecfefe466e
--- /dev/null
+++ b/dev-python/websockets/websockets-10.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="https://websockets.readthedocs.io/"
+SRC_URI="
+ https://github.com/aaugustin/${PN}/archive/${PV}.tar.gz -> ${P}-src.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # these fail due to timeouts on slower hardware
+ sed -e 's:test_keepalive_ping_with_no_ping_timeout:_&:' \
+ -e 's:test_keepalive_ping(:_&:' \
+ -i tests/legacy/test_protocol.py || die
+ distutils-r1_src_prepare
+}