summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Whitlock <gentoo@mattwhitlock.name>2021-10-31 01:21:51 +0000
committerSam James <sam@gentoo.org>2021-10-31 01:26:19 +0000
commitf93bf60f2cb44d2172dbd546f741c78020780048 (patch)
tree0a9ca8cd11142154a6dc0a722966f7819e4de53c
parentdev-python/PyQt5: bump to 5.15.6 (diff)
downloadgentoo-f93bf60f2cb44d2172dbd546f741c78020780048.tar.gz
gentoo-f93bf60f2cb44d2172dbd546f741c78020780048.tar.bz2
gentoo-f93bf60f2cb44d2172dbd546f741c78020780048.zip
sys-fs/e2fsprogs: merge sys-libs/e2fsprogs-libs back in (unkeyworded)
[sam: As noted in the bug, we'll need to adjust reverse dependencies to tools(-) if anything needs libext2fs or libe2p. In terms of why we're doing this in the first place, the reason is that for quite some time, e2fsprogs has been using internal copies of the libraries provided by sys-fs/e2fsprogs-libs anyway, as observed when applying a patch for a test failure which then re-appeared in progs. That is, the split has been ineffective/a no-op for quite some time, and this just makes the ebuilds reflect reality. Splitting out the packages isn't supported upstream and requires some ugly work and it's not something we're interested in rebasing very often.] Bug: https://bugs.gentoo.org/806875 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.46.4-r50.ebuild183
-rw-r--r--sys-fs/e2fsprogs/metadata.xml1
2 files changed, 184 insertions, 0 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.46.4-r50.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.46.4-r50.ebuild
new file mode 100644
index 000000000000..328bca250b30
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.46.4-r50.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic systemd toolchain-funcs udev usr-ldscript multilib-minimal
+
+DESCRIPTION="Standard EXT2/EXT3/EXT4 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v${PV}/${P}.tar.xz
+ elibc_mintlib? ( mirror://gentoo/${PN}-1.42.9-mint-r1.patch.xz )"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+# Unkeyworded for testing unsplitting of e2fsprogs-libs, bug #806875
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="cron fuse lto nls static-libs +threads +tools elibc_FreeBSD"
+
+RDEPEND="!sys-libs/com_err
+ !sys-libs/ss
+ !sys-libs/${PN}-libs
+ >=sys-apps/util-linux-2.16
+ cron? ( sys-fs/lvm2[-device-mapper-only(-)] )
+ fuse? ( sys-fs/fuse:0 )
+ nls? ( virtual/libintl )
+ tools? ( >=sys-apps/util-linux-2.16 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-apps/texinfo
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.40-fbsd.patch
+ "${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch #516854
+
+ # Upstream patches (can usually removed with next version bump)
+)
+
+pkg_setup() {
+ if use tools ; then
+ MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ext2fs/ext2_types.h
+ )
+ fi
+}
+
+src_prepare() {
+ if [[ ${CHOST} == *-mint* ]] ; then
+ PATCHES+=( "${WORKDIR}"/${PN}-1.42.9-mint-r1.patch )
+ fi
+
+ default
+
+ cp doc/RelNotes/v${PV}.txt ChangeLog || die "Failed to copy Release Notes"
+
+ # Get rid of doc -- we don't use them. This also prevents a sandbox
+ # violation due to mktexfmt invocation
+ rm -r doc || die "Failed to remove doc dir"
+
+ # prevent included intl cruft from building #81096
+ sed -i -r \
+ -e 's:@LIBINTL@:@LTLIBINTL@:' \
+ MCONFIG.in || die 'intl cruft'
+}
+
+multilib_src_configure() {
+ # Keep the package from doing silly things #261411
+ export VARTEXFONTS="${T}/fonts"
+
+ # needs open64() prototypes and friends
+ append-cppflags -D_GNU_SOURCE
+
+ local myeconfargs=(
+ --with-root-prefix="${EPREFIX}"
+ $(use_with cron crond-dir "${EPREFIX}/etc/cron.d")
+ --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ --with-udev-rules-dir="${EPREFIX}$(get_udevdir)/rules.d"
+ --enable-symlink-install
+ --enable-elf-shlibs
+ $(tc-has-tls || echo --disable-tls)
+ $(multilib_native_use_enable fuse fuse2fs)
+ $(use_enable nls)
+ --disable-libblkid
+ --disable-libuuid
+ $(multilib_native_use_enable tools e2initrd-helper)
+ --disable-fsck
+ --disable-uuidd
+ $(use_enable lto)
+ $(use_with threads pthread)
+ )
+
+ # we use blkid/uuid from util-linux now
+ if use kernel_linux ; then
+ export ac_cv_lib_{uuid_uuid_generate,blkid_blkid_get_cache}=yes
+ fi
+
+ ac_cv_path_LDCONFIG=: \
+ ECONF_SOURCE="${S}" \
+ CC="$(tc-getCC)" \
+ BUILD_CC="$(tc-getBUILD_CC)" \
+ BUILD_LD="$(tc-getBUILD_LD)" \
+ econf "${myeconfargs[@]}"
+
+ if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to https://bugs.gentoo.org/show_bug.cgi?id=81096"
+ die "Preventing included intl cruft from building"
+ fi
+}
+
+multilib_src_compile() {
+ if ! multilib_is_native_abi || ! use tools ; then
+ emake -C lib/et V=1
+ emake -C lib/ss V=1
+ if use tools ; then
+ emake -C lib/ext2fs V=1
+ emake -C lib/e2p V=1
+ fi
+ return 0
+ fi
+
+ emake V=1
+
+ # Build the FreeBSD helper
+ if use elibc_FreeBSD ; then
+ cp "${FILESDIR}"/fsck_ext2fs.c . || die
+ emake V=1 fsck_ext2fs
+ fi
+}
+
+multilib_src_install() {
+ if ! multilib_is_native_abi || ! use tools ; then
+ emake -C lib/et V=1 DESTDIR="${D}" install
+ emake -C lib/ss V=1 DESTDIR="${D}" install
+
+ if use tools ; then
+ emake -C lib/ext2fs V=1 DESTDIR="${D}" install
+ emake -C lib/e2p V=1 DESTDIR="${D}" install
+ fi
+ else
+ emake \
+ STRIP=: \
+ DESTDIR="${D}" \
+ install
+
+ # Move shared libraries to /lib/, install static libraries to
+ # /usr/lib/, and install linker scripts to /usr/lib/.
+ gen_usr_ldscript -a e2p ext2fs
+
+ if use elibc_FreeBSD ; then
+ # Install helpers for us
+ into /
+ dosbin "${S}"/fsck_ext2fs
+ fi
+ fi
+
+ gen_usr_ldscript -a com_err ss $(usex kernel_linux '' 'uuid blkid')
+
+ # configure doesn't have an option to disable static libs :/
+ if ! use static-libs ; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use tools ; then
+ insinto /etc
+ doins "${FILESDIR}"/e2fsck.conf
+
+ if use elibc_FreeBSD ; then
+ into /
+ doman "${FILESDIR}"/fsck_ext2fs.8
+
+ # filefrag is linux only
+ rm \
+ "${ED}"/usr/sbin/filefrag \
+ "${ED}"/usr/share/man/man8/filefrag.8 || die
+ fi
+ fi
+}
diff --git a/sys-fs/e2fsprogs/metadata.xml b/sys-fs/e2fsprogs/metadata.xml
index 87f72d5af237..902c90f4f054 100644
--- a/sys-fs/e2fsprogs/metadata.xml
+++ b/sys-fs/e2fsprogs/metadata.xml
@@ -9,6 +9,7 @@
<flag name="cron">Install e2scrub_all cron script</flag>
<flag name="fuse">Build fuse2fs, a FUSE file system client for ext2/ext3/ext4 file systems</flag>
<flag name="lto">Build with link time optimization (LTO)</flag>
+ <flag name="tools">Build extfs tools (mke2fs, e2fsck, tune2fs, etc.)</flag>
</use>
<upstream>
<remote-id type="cpe">cpe:/a:e2fsprogs_project:e2fsprogs</remote-id>