summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-09-07 13:11:04 -0500
committerAustin English <wizardedit@gentoo.org>2017-09-07 16:04:16 -0500
commitf9e3f47429bf581bac277323e4d5cfe3012da3c1 (patch)
tree4cb8542f4a8c2da5304fe38e2124f7be00bfa97e
parentgames-strategy/darwinia-demo: remove deprecated games eclass (diff)
downloadgentoo-f9e3f47429bf581bac277323e4d5cfe3012da3c1.tar.gz
gentoo-f9e3f47429bf581bac277323e4d5cfe3012da3c1.tar.bz2
gentoo-f9e3f47429bf581bac277323e4d5cfe3012da3c1.zip
games-strategy/defcon-demo: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild96
1 files changed, 96 insertions, 0 deletions
diff --git a/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild b/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild
new file mode 100644
index 000000000000..486a654236bb
--- /dev/null
+++ b/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs gnome2-utils
+
+MY_PN=defcon
+MY_PV=${PV:0:3}
+MY_PVR=1
+MY_P=defcon_${MY_PV}-${MY_PVR}
+
+DESCRIPTION="Global thermonuclear war simulation with multiplayer support"
+HOMEPAGE="http://www.introversion.co.uk/defcon/"
+SRC_URI="x86? ( http://www.introversion.co.uk/defcon/downloads/${MY_P}_i386.deb )
+ amd64? ( http://www.introversion.co.uk/defcon/downloads/${MY_P}_amd64.deb )"
+
+LICENSE="Introversion"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+system-libs"
+RESTRICT="mirror strip"
+
+# glibc discussion:
+# http://forums.introversion.co.uk/defcon/viewtopic.php?t=4016
+RDEPEND="
+ media-libs/libogg
+ media-libs/libvorbis
+ >=sys-libs/glibc-2.3
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ system-libs? ( media-libs/libsdl[sound,video] )"
+DEPEND=""
+
+QA_PREBUILT="/opt/${PN}/lib/${MY_PN}.bin.x86"
+
+S="${WORKDIR}/usr/local/games/${MY_PN}"
+
+src_unpack() {
+ default
+ unpack ./data.tar.gz
+
+ cd "${S}" || die
+ # maintain compatibility with old installation/script
+ [[ -e lib64 ]] && { mv lib64 lib || die ;}
+ [[ -e ${MY_PN}.bin.x86_64 ]] && { mv ${MY_PN}.bin.x86_64 ${MY_PN}.bin.x86 || die ;}
+}
+
+src_prepare() {
+ default
+
+ # FindPath scripts are ugly and unnecessary
+ if use system-libs ; then
+ rm -f lib/lib*
+ fi
+ sed \
+ -e "s:GAMEDIR:/opt/${PN}:g" \
+ "${FILESDIR}"/${MY_PN} > "${T}"/${MY_PN} || die
+ echo "int chdir(const char *d) { return 0; }" > chdir.c || die
+}
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c"
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c || die
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+
+ insinto "${dir}/lib"
+ doins *.dat
+
+ exeinto "${dir}"/lib
+ doexe lib/*.so
+ doexe ${MY_PN}.bin.x86
+
+ doicon -s 128 ${MY_PN}.png
+
+ # Can be upgraded to full version, so is not installed as "demo"
+ dobin "${T}"/${MY_PN}
+ make_desktop_entry ${MY_PN} "Defcon"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ elog "Screenshots will appear in ~/.${MY_PN}/lib"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}